Announcement

Collapse
No announcement yet.

can't get latest xf86-video-ati to output 1080p on hdmi

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • can't get latest xf86-video-ati to output 1080p on hdmi

    I switched from catalyst to the open source radeon driver on my htpc. (Also upgraded from ubuntu to arch inthe process but I doubt that should make a difference) I used to be able to pick 1920x1080 on my plasma tv on catalyst, but all I see now is 1280x720 or 1920x540, with radeon picking the 720p mode by default.

    I've tried 1920x540, assuming that's 1080i, and that resulted in a black screen. Any idea what I need to do? Here's my Xorg.log from pastebin:

    http://pastebin.com/f250975e

    and my xorg.conf

    http://pastebin.com/f798d48e9

    thanks.

  • #2
    1920x540 looks like what you want; can you pastebin a log with the "1920x540" modeline selected ?

    In the log you can see "DDC gathered modelines" and there's an interlaced 1980x540 line there. Not sure how well the driver supports interlaced displays though...

    Comment


    • #3
      Originally posted by bridgman View Post
      1920x540 looks like what you want; can you pastebin a log with the "1920x540" modeline selected ?

      In the log you can see "DDC gathered modelines" and there's an interlaced 1980x540 line there. Not sure how well the driver supports interlaced displays though...
      I'm not sure if this is what you meant. I booted clean, then logged in, and switched the display resolution to 1920x540 in kde and everything went black. Then I ssh'ed in and here's the Xorg.log

      http://pastebin.com/f7f19137d

      By the way, I know this TV supports 1080p. I've used 1920x1080 with catalyst before. Any reason why the edid info doesn't have that modeline? thanks.

      Comment


      • #4
        If your display supports 1080p I don't know why the EDID doesn't report it. Are you sure that you were really driving it at 1080p with Catalyst and not 1080i ?

        There's no indication in the log of a mode switch happening (unless I missed it); could you try switching modes with xrandr instead and see what happens ?

        Comment


        • #5
          Originally posted by ben0 View Post
          I'm not sure if this is what you meant. I booted clean, then logged in, and switched the display resolution to 1920x540 in kde and everything went black. Then I ssh'ed in and here's the Xorg.log

          http://pastebin.com/f7f19137d

          By the way, I know this TV supports 1080p. I've used 1920x1080 with catalyst before. Any reason why the edid info doesn't have that modeline? thanks.
          1920x540 is 1080i, although I'm not sure the xserver parses it right. The 1080p mode may be in the extended EDID blocks, which I don't think the xserver parses fully yet. Ma Ling from Intel posted patches on xorg-devel for extended EDID parsing, but I'm not sure they have made it into the xserver yet. If they did, you'd need xserver from git. You can manually add a 1080p mode with xrandr and cvt.

          Comment


          • #6
            Originally posted by bridgman View Post
            If your display supports 1080p I don't know why the EDID doesn't report it. Are you sure that you were really driving it at 1080p with Catalyst and not 1080i ?

            There's no indication in the log of a mode switch happening (unless I missed it); could you try switching modes with xrandr instead and see what happens ?
            I'm pretty sure it was in 1080p. There's a button on my TV remote that shows the mode. It was on 1080p, while all broadcast TV show 1080i. Also, my TV manual says 1080p's supported through hdmi.

            I think I just messed up my setup. The screen now goes black every time I go to display options in kde.

            Comment


            • #7
              Can you get mode info via the tv remote when the screen is black ? It might be useful to see what is being output...

              Also might be worth trying xrandr directly rather than the KDE utility.

              Comment


              • #8
                Originally posted by bridgman View Post
                Can you get mode info via the tv remote when the screen is black ? It might be useful to see what is being output...

                Also might be worth trying xrandr directly rather than the KDE utility.
                It said 720p. I think the blank screen in the kde utility was probably my fault. There was a kde dialog, but the font on the screen was too small, so I couldn't see and I clicked one of the buttons and it was like that from that point on.

                I've now connected the pc to a computer monitor. Will install catalyst to see if it finds any new modelines for 1080p.

                Comment


                • #9
                  Originally posted by ben0 View Post
                  It said 720p. I think the blank screen in the kde utility was probably my fault. There was a kde dialog, but the font on the screen was too small, so I couldn't see and I clicked one of the buttons and it was like that from that point on.

                  I've now connected the pc to a computer monitor. Will install catalyst to see if it finds any new modelines for 1080p.
                  You can add the mode manually on the fly with xrandr or add the mode to your config file:
                  http://wiki.debian.org/XStrikeForce/HowToRandR12

                  Comment


                  • #10
                    Originally posted by agd5f View Post
                    You can add the mode manually on the fly with xrandr or add the mode to your config file:
                    http://wiki.debian.org/XStrikeForce/HowToRandR12
                    By the way, how do I find modelines for my tv that don't get reported via EDID? Will xrandr do what xserver doesn't do and find the missing ones for me?

                    Comment


                    • #11
                      There are two separate issues here :

                      1. The X server is not reporting a mode which you feel your TV can support

                      2. When you try to switch modes to 1920x540 via KDE something goes wrong and there's no record in the log

                      Using xrandr will immediately help with #2. You can also use xrandr to add a mode but you'll need the same timing info as if you were adding a modeline in xorg.conf.

                      Comment


                      • #12
                        xrandr shows the following.

                        Screen 0: minimum 320 x 200, current 1280 x 720, maximum 1920 x 1920
                        VGA-0 disconnected (normal left inverted right x axis y axis)
                        HDMI-0 connected 1280x720+0+0 (normal left inverted right x axis y axis) 920mm x 518mm
                        1280x720 60.0*+
                        1920x540 60.1

                        I'm fine with running the machine at 720p if it's a choice between that and 1080i. My tv's native resolution is 1366x768 so there's not much loss here. 1080p probably would have only been slightly better.

                        Comment


                        • #13
                          Yeah, if your screen resolution is 1366x768 then the main reason for a 1080 input is to support players or tuners which can't upscale or downscale. That also explains why 720p is the preferred resolution rather than 1080i.

                          Comment


                          • #14
                            Originally posted by ben0 View Post
                            I'm fine with running the machine at 720p if it's a choice between that and 1080i. My tv's native resolution is 1366x768 so there's not much loss here. 1080p probably would have only been slightly better.
                            OK, wait a second....

                            The Television in question, which you have reported working at 1080p in the past has a native resolution on 1366x768..... I think you must have had some kind of downscaling option set in fglrx somewhere that allowed the driver to switch to 1080p resolution, but which was downscaled to 720p before it was output to the television.

                            I've never used fglrx before though, so you'll just have to look through it's configuration and find the options for upscaling and downscaling

                            Comment

                            Working...
                            X