Announcement

Collapse
No announcement yet.

Open-Source ATI Graphics In Ubuntu 9.04

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    Originally posted by Kamikaze321 View Post
    Guys I have similar hardware x1400 mobile and T2300 and Open Arena is runnig with like 30-60 fps in average, why its not playable?

    With the open source drivers? With my 9800pro and x800gto the game is a slideshow.

    Comment


    • #12
      Hi guys,
      Am I the only one having troubles with the S-Video (connected to a TV) with this "out of the box" driver ?

      To install Ubuntu, I have to disconnect my TV, and then install the fglrx driver .

      Talking about that, is the S-Video working fine with the open source radeonhd driver?

      Comment


      • #13
        Yes, ofcourse open source driver. My brother has the same notebook as I do, but with fglrx and opensuse (i got ubuntu and ati radeon) and he gets like 2-3 times more fps as I do. But its absolutly playable, we play online games together. Here is my x.org:

        Section "Device"
        Identifier "Configured Video Device"
        Driver "radeon"
        Option "DRI"
        # Option "AGPFastWrite" "on"
        Option "AccelMethod" "EXA"
        Option "AccelDFS" "true"
        Option "DynamicClocks" "true"
        EndSection

        Comment


        • #14
          @Melcar

          Try

          Option "AGPMode" "8"

          This helps much.

          Comment


          • #15
            Originally posted by Kano View Post
            @Melcar

            Try

            Option "AGPMode" "8"

            This helps much.

            The 9800pro already runs at AGP x8 (BIOS and my xorg log confirms it). The x800gto is PCIe. The 200M on my laptop shows similar behavior with the game. Don't play the game, so it really doesn't matter.

            Comment


            • #16
              Originally posted by quintesse View Post
              What I wondered was, if I have the appropiate hardware and I have the latest xorg and kernel stuff, how do I detect or test that I have working X-Video and EXA?
              Open a terminal and type xvinfo and you will either get very little or a long list of capabilities.

              EXA is simple, your normal desktop is smooth or not. Firefox scrolling will be more like paging if it is not working.

              If you want to be a bit more technical look in /var/log/Xorg.0.log and read the xorg loading messages.

              Comment


              • #17
                @Melcar

                fglrx used 8x, radeon used 1x. At least the versions I tested - ok a few years ago.

                Comment


                • #18
                  Guys, do you have the Bloom option enabled? Is it on by default by the PTS?

                  It certainly is off by default, and it's the only option in OA that can make it unplayable on the open drivers. It drops fps to 1-2, because it hits a sw path, this is a known bug, and a fix is said to need a proper memory manager.
                  Ie, more time before we can see some cool lighting effects..

                  Comment


                  • #19
                    Just for information, under Ubuntu Jaunty x86_64, ati 6.12 works in 2d mode for my HD3450. Good 2d and xv video and power management. No compiz or 3d accell as expected, not yet for 3000/4000 chips. So for a normal desktop there is finally a driver that works for 3000/4000 cards. The fglrx that is in the Jaunty repos works better than any that have come before, for normal desktop stuff. Even video in a window under compiz, but still works better with compiz off.

                    Comment


                    • #20
                      Originally posted by curaga View Post
                      Guys, do you have the Bloom option enabled? Is it on by default by the PTS?

                      It certainly is off by default, and it's the only option in OA that can make it unplayable on the open drivers. It drops fps to 1-2, because it hits a sw path, this is a known bug, and a fix is said to need a proper memory manager.
                      Ie, more time before we can see some cool lighting effects..

                      Yes, it is the bloom effect (don't know if PTS has it on, but turning it off in a normal OA game makes it playable). Most games I have tried are playable at medium to low settings even at 1680x1050 as long as you don't use any fancy post processing effects (AA, AF, etc.) or lighting effects.

                      Comment

                      Working...
                      X