Announcement

Collapse
No announcement yet.

No acceleration with google earth

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • No acceleration with google earth

    Using latest google earth and radeon driver from git 14/1/09 with x1600 on ubuntu intrepid, compiz disabled, I get the following message and no 3d acceleration:

    Code:
     drmWaitVBlank returned -1, IRQs don't seem to be working correctly.
    Try adjusting the vblank_mode configuration parameter.
    My xorg.conf:

    Code:
    # xorg.conf (X.Org X Window System server configuration file)
    #
    # This file was generated by failsafeDexconf, using
    # values from the debconf database and some overrides to use vesa mode.
    #
    # You should use dexconf or another such tool for creating a "real" xorg.conf
    # For example:
    #   sudo dpkg-reconfigure -phigh xserver-xorg
    Section "InputDevice"
    	Identifier	"Generic Keyboard"
    	Driver		"kbd"
    	Option		"XkbRules"	"xorg"
    	Option		"XkbModel"	"pc104"
    	Option		"XkbLayout"	"us,il"
    EndSection
    
    Section "InputDevice"
    	Identifier	"Configured Mouse"
    	Driver		"mouse"
    EndSection
    
    Section "InputDevice"
    	Identifier	"Synaptics Touchpad"
    	Driver		"synaptics"
    	Option		"SendCoreEvents"	"true"
    	Option		"Device"		"/dev/psaux"
    	Option		"Protocol"		"auto-dev"
    	Option		"HorizEdgeScroll"	"0"
    	Option 		"SHMConfig" "on"
    EndSection
    
    Section "Device"
    	Identifier	"Configured Video Device"
    	Driver		"radeon"
    	Option 		"AccelMethod" "EXA"
    	Option 		"MigrationHeuristic" "greedy"
            Option 		"EnablePageFlip" "on"
            Option          "ColorTiling"   "on"
          	#Option      	"AGPFastWrite" "yes"
    
    
    EndSection
    
    Section "Module"
    	Load		"glx"
    	Load		"dbe"
    	Load		"v4l"
    	Load "vbe"
    	Load "i2c"
    	Load "bitmap"
    	Load "ddc"
    	Load "dri"
    	Load "extmod"
    	Load "freetype"
    	Load "int10"
    EndSection
    
    Section "Extensions"
    	Option "Composite" "Enable"
    	Option "DAMAGE" "Enable"
    	Option "RENDER" "Enable"
    EndSection
    
    Section "Monitor"
    	Identifier	"Configured Monitor"
    EndSection
    
    Section "Screen"
    	Identifier	"Default Screen"
    	Device		"Configured Video Device"
    	Monitor		"Configured Monitor"
    	DefaultDepth 	24 
    	SubSection "Display"
    		Modes   "1680x1050" "800x600" "1024x768" "1280x1024" "1440X900" 
    	EndSubSection
    EndSection
    
    Section "ServerLayout"
    	Identifier	"Default Layout"
    	Screen		"Default Screen"
    	InputDevice	"Synaptics Touchpad"
    EndSection
    
    Section "ServerFlags"
       	Option "AIGLX" "true" 
    EndSection
    
    Section "DRI"
    	Group	0
    	Mode	0666
    EndSection
    Other 3d apps work fine. Any ideas how this can be resolved?

  • #2
    In my case, (Ati x1400, radeon-driver 6-10),
    I changed the parameter vblank_mode in .drirc from 1 to 0, and after that googleearth worked fine. I don't quite know what vblank_mode means, but it worked for me

    Comment


    • #3
      Originally posted by sksk View Post
      In my case, (Ati x1400, radeon-driver 6-10),
      I changed the parameter vblank_mode in .drirc from 1 to 0, and after that googleearth worked fine. I don't quite know what vblank_mode means, but it worked for me
      Thank you so much! This was it! I view your house from above now, bowing with gratitude.
      In order to get a .drirc file I had to install first the package driconf and run it. Perhaps it should be a dependency of the radeon driver, or at least suggested by it.

      Comment


      • #4
        You can use driconf (a GUI tool) to configure those options more easily.

        Comment

        Working...
        X