Announcement

Collapse
No announcement yet.

AMD R700 2D Driver Performance Comparison

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    I've installed this driver on my Gentoo system with rv770 4850 graphic card. Performance in KDE4 apps (dolphin, plasma) is great, but only witch enabled composite (by running xcompmgr). Without composite enabled, moving windows is very slow.

    But I've noticed a problem - i can't enable XRender-based desktop effects in kwin configuration window - it displays standard dialog without any usable information (it says that activating windows effects failed). Xcompmgr works without any problems. Any ideas how to force kwin to worh with experimental r600/700 radeonhd driver? I've tried "disable functionality check" option without any success.

    Comment


    • #32
      your driver installation is borked.

      Comment


      • #33
        Originally posted by energyman View Post
        your driver installation is borked.
        it's not helping me or anyone.

        I know that exa acceleration is working (very fast with xcompmgr running). This is the only usable functionality of radeonhd driver from r600/700 support branch. So, if exa is working, my installation is far from broken.

        Anyone tried using this driver with kwin from kde4?

        Comment


        • #34
          oh, you are talking radeonhd ....

          Comment


          • #35
            if you would see my comparison test, this is the link: http://www.ech0s7.netsons.org/index.php/archives/31

            ech0s7

            Comment


            • #36
              are you use that the tests are running correctly?
              Because when run with effects turned on gtkperf seems to run faster - but it also looks like some stuff simple never got drawn. So maybe radeonhd is much faster because it does not do all the stuff it is supposed to do?

              Comment


              • #37
                Originally posted by energyman View Post
                are you use that the tests are running correctly?
                Because when run with effects turned on gtkperf seems to run faster - but it also looks like some stuff simple never got drawn. So maybe radeonhd is much faster because it does not do all the stuff it is supposed to do?
                Yes, i run correctly the test, and without any effect. GtkPerf not seems to run faster, it run faster! In any case, the difference is remarkable and impressive !

                Comment


                • #38
                  There is still some corruption but AFAIK nothing is being skipped. Alex has the driver configured to fall back to SW rendering for anything which is seriously broken, so I think the comparison is valid.

                  Comment

                  Working...
                  X