Announcement

Collapse
No announcement yet.

Cant get the radeon driver to work at all on Kubuntu 8.10

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cant get the radeon driver to work at all on Kubuntu 8.10

    Hello, i just installed a fresh Kubuntu distro on ly laptop, and neither the installer nor the actual X server are able to get my GPU to work properly, my card is a:

    01:00.0 VGA compatible controller: ATI Technologies Inc M9+ 5C61 [Radeon Mobility 9200 (AGP)] (rev 01)

    Currently i can only log in with the generic 'vesa' driver with a meager 800x600 resolution; when i just try to change the driver in my xorg.conf file and start up the X server all i get is a black screen that wont even allow me to fall back to a console and i must hard boot, so no way of cheching the logs either.

    Im thinking maybe this is a problem with the default Ubuntu Kernel? I had this working just fine on my in-house compiled vanilla kernel before a crash forced me to format.

    Trying to update to the PPA's xorg video drivers has not helped either.


    Any help will be appreciated

  • #2
    Sounds like it might be AGP related. Try adding:
    Option "AGPMode" "1"
    to the device section of your config. If that doesn't work, try disabling the DRI:
    Option "DRI" "False"

    Comment


    • #3
      Originally posted by agd5f View Post
      If that doesn't work, try disabling the DRI:
      Option "DRI" "False"
      Thanks! This helped me.

      I can now log in with full resolution, but I wonder why is DRI not working? It was fine a couple of weeks ago; does this mean the hardware is no longer fully supported for DRI and therefore no more Compiz?

      Comment


      • #4
        Originally posted by havok1977 View Post
        Thanks! This helped me.

        I can now log in with full resolution, but I wonder why is DRI not working? It was fine a couple of weeks ago; does this mean the hardware is no longer fully supported for DRI and therefore no more Compiz?
        The DRI should still work fine. As I said, try AGP options:
        Option "AGPMode" "X"
        Where X = 1 or 2 or 4 or 8.

        Comment


        • #5
          Originally posted by agd5f View Post
          The DRI should still work fine. As I said, try AGP options:
          Option "AGPMode" "X"
          Where X = 1 or 2 or 4 or 8.
          Thanks again,

          I wasn't aware that this parameter could go as high as 8 (1, 2 and 4 were a no go); so 8 was what finally got things working for me.

          Cheers!

          And in case anyone has the same hardware; I can only get desktop effects to work when i configure xorg's DefaultDepth parameter at 16 bits; with 24 it just wont work...

          Comment


          • #6
            Can you pastebin the output of lspci -vn and your xorg log so I can add a quirk for your card/motherboard combo so you don't have to add this option in the future?

            Comment


            • #7
              Originally posted by agd5f View Post
              Can you pastebin the output of lspci -vn and your xorg log so I can add a quirk for your card/motherboard combo so you don't have to add this option in the future?
              Thanks for that,

              lspci -nv:

              http://pastebin.com/m52f3cc04


              /var/log/Xorg.0.log: (on 24 bits)

              http://pastebin.com/m738a1372

              Comment


              • #8
                thanks. pushed!

                549ae63aecc2624a69b41ce4db75883d03d59c23

                Comment

                Working...
                X