Announcement

Collapse
No announcement yet.

random X freeze with latest ati driver

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • random X freeze with latest ati driver

    system: ubuntu 8.10
    ati driver (opensource): compiled from git (latest version)
    device: ati radeon mobility 9700

    xorg.conf

    Driver "ati"
    Option "RenderAccel" "true"
    Option "AccelMethod" "EXA"
    Option "DynamicClocks" "true"
    Option "EnablePageFlip" "true"
    Option "DMAForXv" "true"
    Option "AGPMode" "4"
    Option "ColorTiling" "true"
    Option "AccelDFS" "true"
    Option "EXAVSync" "true"

    when i see a video or i'm using firefox or in other situation, with and without compiz, X freeze, cpu run at 100% and i must force shutdown from power button. how can i fix this problem?

  • #2
    does removing the EXAVSync option help?

    Comment


    • #3
      no, same error....i added recently EXAVSync in my xorg.conf

      Comment


      • #4
        I've got the same problem. I am using the radeon driver (from the ubuntu repositories) since fglrx broke compatibility with my Mobility Radeon 9700 three months ago. But I had "MigrationHeuristics" set to "Greedy" all the time. After reading a bit in your blog, I updated to the latest snapshot (from launchpad.net/~tormodvolden), commented out the "MigrationHeuristics" setting and added EXAVSync to my xorg.conf.

        Soon,I experienced the first lockups. Mostly when scrolling in Firefox, but also in other situations. When it happens, I cannot switch to the console, ssh into my system from another computer or even use the Magic-SysRq-Keys.

        First, I disabled the EXAVSync settings, than I reverted back to radeon from ubuntu. Didn't help. Only re-inserting the "MigrationHeuristics" setting did. As I understand it, that effectivly disables any acceleration.

        Comment


        • #5
          EDIT:
          with option migrationheuristic (greedy), freeze appears with gnome mplayer, with vlc no problem

          Comment


          • #6
            Originally posted by agd5f View Post
            does removing the EXAVSync option help?
            With me it does help. My problem is, that after a while, on a random moment, everything freezes except for the mouse. Mouse is allowed to move slowly and jerky, while keyboard and the rest of gnome is completely frozen.
            No information in logs, however, so not sure how to file a bug report.
            I have an RV515 (Gigabyte X1300PRO).

            Comment


            • #7
              Originally posted by aljaz View Post
              With me it does help. My problem is, that after a while, on a random moment, everything freezes except for the mouse. Mouse is allowed to move slowly and jerky, while keyboard and the rest of gnome is completely frozen.
              I had this problem some time ago, with the OSS driver *and* fglrx. The solution was to provide better cooling to the GPU.

              Comment


              • #8
                Originally posted by Stormking View Post
                I had this problem some time ago, with the OSS driver *and* fglrx. The solution was to provide better cooling to the GPU.
                Hmmm. This happened on three different machines (one desktop and two HP laptops) so I don't think it's a cooling problem.

                Comment


                • #9
                  I can confirm the exact same issue with a 9600Pro (Ubuntu 8.10 x86, vanilla "ati" driver and xorg settings.)

                  I will test with fglrx and see if the issue persists.

                  Comment


                  • #10
                    I've been having similar problems, myself. This occurs with both 6.9.0 and the new release candidate driver. This is with Xserver 1.5.3 and a radeon x850.

                    In particular, the problem seems to be provoked by mozilla applications - with firefox 2, it would fairly reliably crash within a few minutes of use, though I haven't noticed the same problem in the last few days (since I upgraded to firefox 3). Thunderbird 2, however, does still cause this issue.

                    When it happens, the mouse still moves (albeit jerkily - updated ~3Hz), but no other response to any other input device. The CPU usually gets pegged at 100% (from what I can tell - the CPU usage generally ceases updating about five seconds after going into this state).

                    Comment


                    • #11
                      I have this problem too.
                      Random X freeze but only with Desktop Effects enabled in kde4.
                      Can't switch to console.

                      system: gentoo
                      driver: xf86-video-ati and mesa compiled from git
                      xorg-server: 1.5.3

                      xorg.conf:
                      Identifier "Card0"
                      Driver "radeon"
                      VendorName "ATI Technologies Inc"
                      BoardName "M56P [Radeon Mobility X1600]"
                      BusID "PCI:1:0:0"
                      Option "AccelMethod" "EXA"

                      Everything freezes except for the mouse cursor.

                      Comment


                      • #12
                        Mobility radeon 9600/9700, no composite thing, no fancy xorg.conf options, laptop fails to resume from suspend to ram like 20% of the times. This started a couple of weeks ago when I removed fglrx and left only radeon on the system (version from Debian sid).

                        Comment


                        • #13
                          Does anyone investigate this issue? How can I help? I'd really like to activate acceleration because scrolling in firefox is *much* smoother this way. But when I take "MigrationHeuristics Greedy" out of my xorg.conf, X freezes after about 15 minutes.

                          Comment


                          • #14
                            Stormking, you mentioned earlier that improving cooling to the GPU fixed the problem; did it come back ?

                            Comment


                            • #15
                              Originally posted by bridgman View Post
                              Stormking, you mentioned earlier that improving cooling to the GPU fixed the problem; did it come back ?
                              There seems to be a misunderstanding. Cooling the GPU helped me with the X-freezes-but-mouse-pointer-can-still-be-moved-problem, two years ago. Now, there's a X-freezes-completely-when-acceleration-is-activated-problem.

                              Comment

                              Working...
                              X