Announcement

Collapse
No announcement yet.

random X freeze with latest ati driver

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    I have this problem too.
    Random X freeze but only with Desktop Effects enabled in kde4.
    Can't switch to console.

    system: gentoo
    driver: xf86-video-ati and mesa compiled from git
    xorg-server: 1.5.3

    xorg.conf:
    Identifier "Card0"
    Driver "radeon"
    VendorName "ATI Technologies Inc"
    BoardName "M56P [Radeon Mobility X1600]"
    BusID "PCI:1:0:0"
    Option "AccelMethod" "EXA"

    Everything freezes except for the mouse cursor.

    Comment


    • #12
      Mobility radeon 9600/9700, no composite thing, no fancy xorg.conf options, laptop fails to resume from suspend to ram like 20% of the times. This started a couple of weeks ago when I removed fglrx and left only radeon on the system (version from Debian sid).

      Comment


      • #13
        Does anyone investigate this issue? How can I help? I'd really like to activate acceleration because scrolling in firefox is *much* smoother this way. But when I take "MigrationHeuristics Greedy" out of my xorg.conf, X freezes after about 15 minutes.

        Comment


        • #14
          Stormking, you mentioned earlier that improving cooling to the GPU fixed the problem; did it come back ?

          Comment


          • #15
            Originally posted by bridgman View Post
            Stormking, you mentioned earlier that improving cooling to the GPU fixed the problem; did it come back ?
            There seems to be a misunderstanding. Cooling the GPU helped me with the X-freezes-but-mouse-pointer-can-still-be-moved-problem, two years ago. Now, there's a X-freezes-completely-when-acceleration-is-activated-problem.

            Comment


            • #16
              It's not a cooling problem. In my opinion there's a bug related to (compiz, kde desktop effects) acceleration. I don't know how to file a bug report cause the freeze can't make me switch to console.

              Comment


              • #17
                Originally posted by Stormking View Post
                There seems to be a misunderstanding. Cooling the GPU helped me with the X-freezes-but-mouse-pointer-can-still-be-moved-problem, two years ago. Now, there's a X-freezes-completely-when-acceleration-is-activated-problem.
                Got it. Thanks !

                Comment


                • #18
                  I'd like to repeat my question: Is anyone investigating this issue? And how can I help?

                  Comment


                  • #19
                    I also have freezes with my Ati Mobility Radeon 9700 and the open source radeon driver. With Desktop Effects enabled X freezes immediately, without it system sometimes holds out for some minutes, but most of the time just a few seconds after login.

                    Solution was to set AGPMode to x1 :
                    Code:
                    	Option		"AGPMode"	"1"
                    I don't know if this is really a "real" solution or just a dirty fix. Default value for this card is 4 and as far as I could measure I lose some fps, but everything is stable.

                    I hope it can help.
                    Or at least someone can tell, why default value doesn't work...

                    Comment


                    • #20
                      Originally posted by Stormking View Post
                      I had this problem some time ago, with the OSS driver *and* fglrx. The solution was to provide better cooling to the GPU.
                      The same with my Radeon 9600 and my friends Radeon 9250 - after opening the computer I noticed the graphic card is very hot (no fan on card). With computer cover open I've noticed a lot better stability on the open source drivers. Both systems use Kubuntu 8.10 and the default xorg.conf.

                      Comment

                      Working...
                      X