No announcement yet.

Please write about NVidia's 2D performance problems

  • Filter
  • Time
  • Show
Clear All
new posts

  • #21
    Originally posted by lenrek View Post
    I am using GeForce 8500 GT, no problem here as well.

    But, I do like to read more about what others are facing.
    8600GT and 8800GT. I have ~12 kde terminals open; after a few hours the
    scrolling compiler output gets slower, which I can fix by setting
    IPP=2 and GlyphCache=1 with nvidia-settings. Repeat every few hours
    (with a cronjob).

    I didn't notice any scrolling slowdowns in firefox or any other apps I


    • #22
      On my 7800GT desktop the 2D graphics gradually slows down. It would take atleast 10 hours of heavy usage before the slowdown becomes noticeable, it only gets worse until I restart X.

      The situation does not happen when using KDE3.5's compositing manager, and is worst when using Compiz.

      Running X 7.2 with X server 1.3, and 169.something drivers (although this was the case since about the ~90 or ~100 drivers)

      To get around the problem I try to restart X every day.


      • #23
        Hmm... I decided to give it a try, based on what I read so far in this thread.

        Currently, I am running total 26 Gnome-Terminalx in my desktop. 14 of them echoing "fortune -s" string, in every 1 seconds. 2 of them running 'top' command. So far, I have been running them about 18 hours. No slowness of any kind is noticeable. Neither does any of my applications (like firefox or OpenOffice Writer) has any problem.

        Before I start doing the experiment, the system has been running for > 4 days (this desktop PC is also a tor router, so most of time, I let it run continuously, even when i am not using). My desktop is Dropline GNOME, but using Compiz-Fusion instead of Metacity. So far, no system freeze of any kind.

        System info:
        $> uname -simpro
        Linux i686 Intel(R) Pentium(R) D  CPU 2.66GHz GenuineIntel GNU/Linux
        $> glxinfo | grep renderer
        OpenGL renderer string: GeForce 8500 GT/PCI/SSE2
        $> head /var/log/Xorg.0.log
        X Window System Version 1.3.0
        Release Date: 19 April 2007
        X Protocol Version 11, Revision 0, Release 1.3
        Build Operating System: Slackware 12.0 Slackware Linux Project
        Current Operating System: Linux orion #1 SMP Sat Jul 5 23:36:01 SGT 2008 i686
        Build Date: 09 May 2007
        However, IIRC, it did freeze when GL's base screensaver was enabled (that happened a few weeks ago). But, is not something that I would concern much, since I am not that fancy of screensaver. I have not enabled screensaver since then.

        Anyway, will let it run for a few more days...
        Last edited by lenrek; 07-10-2008, 11:04 AM.


        • #24
          Originally posted by lenrek View Post
          X Window System Version 1.3.0
          Well, to clarify, I'm on Ubuntu Hardy, which uses X.Org X Server, and gnome rendering is really slow here:

          $ glxinfo|grep renderer
          OpenGL renderer string: GeForce 8600M GS/PCI/SSE2


          • #25
            I've got a 6200 something-er-other in my tower. I bought it because I kept hearing how the drivers "Just Worked (TM)" in Linux. Since I'm not much on 3D, I didn't mind the ~1500 fps in glxgears. And before I started testing KDE4 last fall (and before openSUSE pushed Firefox 3 on me), the 2D stuff was just fine.

            But when it comes to KDE4 and/or Firefox 3, my laptop (X1300 graphics) literally runs circles around my tower. There's such a huge performance discrepancy that I went back to KDE3.5.9 exclusively on my tower, and only use Firefox when there's a website that gives both Konqueror and Opera fits.


            • #26
              I have no problems

              I'm using GeForce 7300 with KDE-3.5.9 and nVidia's proprietary driver.
              I did face some initial problems with 2D. But after I made the following changes to my /etc/X11/xorg.conf, most of the problems went away:

              Option "UseEvents" "on"
              Option "OnDemandVBlankInterrupts" "on"
              Option "TripleBuffer" "on"


              • #27
                I stop the test, since I can't seem to face the same problem as you guys. Maybe is the Xorg version I am using, since mine is 1.3.0.


                • #28
                  I`m Using opensuse 11 with KDE3.5.9 and 8800gts ( g80 ),
                  2D and 3D is working with no problem at all, i know this is not a issue but i wanted tell that on compination ( Distro+desktop+drivercard ), what i use, works fine and i think many other users have working system too, why thiss so, not 100% sure.


                  • #29
                    I guess KDE 4 creates some problems and in some cases Firefox 3.


                    • #30
                      Thats true kano, on opensuse i prefer much more KDE3 than 4, Firefox 3 have work fine, how it does work on other people is different thing..
                      Even i heard some problem on ubuntu/kubuntu people too, meaning KDE3 or 4 , situation, that 3 works better than 4.