Announcement

Collapse
No announcement yet.

Fallout From NVIDIA 173.08 Driver

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    As said, the driver is not as bad as the sensational style of the article sounds. It works fine on both my 8400m gs and 7300 gs, and I came to know of the problem only after browsing through forums. The bug reports have been taken and the problem has been acknowledged - case over.

    And its way better than the overhyped advertisements for new drivers with support for platinum, dri5 and exxxa that are plagued with regressions . I know a few encouraging words are helpful, but its disappointing after a streak of broken drivers.

    Now if only there is an article with headline that fglrx drivers have agp support problems and video tearing in compiz.

    Comment


    • #17
      Hi from Andrea Cimitan

      These slowdown fixes a lor of bugs, so it's appreciated.

      173.08 finally fixes rendering problems with transparency (see my transparent engine): http://arstechnica.com/articles/cult...ting-gtk.ars/3

      So ok, fix speed but I think that the correct rendering we now achieved is a way more important.

      Comment


      • #18
        It looks like nvidia fanboys came here. At first many people reported problems with STABLE drivers too. At second no one from nvidia devs even responded.

        >Hence why I stated Openbox, a nice 2D desktop WM and it runs smooth here

        Try KDE4. Ops, maybe QT4 is too much for nvidia devs?

        Comment


        • #19
          Originally posted by emprov View Post
          Try KDE4. Ops, maybe QT4 is too much for nvidia devs?
          That's exactly what I'm running on openSUSE 11A3 and don't have any issues with it.

          Comment


          • #20
            I'm still stuck with the 100% fan bug with the latest stable drivers, fyi.

            As a laptop user, I'm not entirely happy...

            Comment


            • #21
              Originally posted by deanjo View Post
              That's exactly what I'm running on openSUSE 11A3 and don't have any issues with it.
              Yes, but some (maybe many) people have problems with nvidia drivers and kde4. I'm one of them, but I'm not certainly sure that's nvidia drivers fault. Can you paste your xorg and nvidia settings please?

              Comment


              • #22
                Originally posted by emprov View Post
                Yes, but some (maybe many) people have problems with nvidia drivers and kde4. I'm one of them, but I'm not certainly sure that's nvidia drivers fault. Can you paste your xorg and nvidia settings please?
                many have problems with KDE4 and ATi proprietary drivers, too. So maybe it's a kde4 problem....

                Comment


                • #23
                  Well considering KDE4 isn't for general-user usage atm that is a strong possibility
                  KDE4.1 (due in June/July) is ment for genera-user usage. KDE4.0.# (kde4.0.3) is the present build of the kde4.0 series which is ment for developers of kde4 software get a hands-on with the desktop

                  At present (kde-svn) the panel is still kinda b0rked layout-wise, there is a task manager, but no systray

                  The last release (kde4.0.2) had issues with plasma's

                  Also KDE4 is a 2D/3D mashup desktop doing its own composite thing


                  Sure there may be issues with these BETA nvidia drivers with a mix 2D,3D desktop but testing on a desktop that isn't actually ready for mass-usage and calling foul and bad mouthing nvidia is even worse then just bad mouthing nvidia for not having 100% perfect BETA drivers, cause heaven forbid beta drivers having bugs...

                  Comment


                  • #24
                    Originally posted by Vighy View Post
                    many have problems with KDE4 and ATi proprietary drivers, too. So maybe it's a kde4 problem....
                    No, because it's working well on Intel cards and even on windows!

                    Comment


                    • #25
                      Originally posted by emprov View Post
                      No, because it's working well on Intel cards and even on windows!
                      yes cause windows has kde4

                      Comment


                      • #26
                        Originally posted by Naib View Post
                        yes cause windows has kde4
                        Why are you being sarcastic? You can install kde4 in windows (at least the applications) courtesy of Qt4


                        see here:http://windows.kde.org/

                        Comment


                        • #27
                          Originally posted by emprov View Post
                          Yes, but some (maybe many) people have problems with nvidia drivers and kde4. I'm one of them, but I'm not certainly sure that's nvidia drivers fault. Can you paste your xorg and nvidia settings please?
                          Sure here it is.

                          Code:
                          # /.../
                          # SaX generated X11 config file
                          # Created on: 2007-12-09T15:21:26-0600.
                          #
                          # Version: 8.1
                          # Contact: Marcus Schaefer <sax@suse.de>, 2005
                          # Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
                          #
                          # Automatically generated by [ISaX] (8.1)
                          # PLEASE DO NOT EDIT THIS FILE!
                          #
                          
                          Section "ServerLayout"
                              Identifier     "Layout[all]"
                              Screen         "Screen[0]" 0 0
                              InputDevice    "Keyboard[0]" "CoreKeyboard"
                              InputDevice    "Mouse[1]" "CorePointer"
                              Option         "Clone" "off"
                              Option         "Xinerama" "off"
                          EndSection
                          
                          Section "Files"
                              InputDevices      "/dev/gpmdata"
                              InputDevices      "/dev/input/mice"
                              FontPath        "/usr/share/fonts/misc:unscaled"
                              FontPath        "/usr/share/fonts/local"
                              FontPath        "/usr/share/fonts/75dpi:unscaled"
                              FontPath        "/usr/share/fonts/100dpi:unscaled"
                              FontPath        "/usr/share/fonts/Type1"
                              FontPath        "/usr/share/fonts/URW"
                              FontPath        "/usr/share/fonts/Speedo"
                              FontPath        "/usr/share/fonts/PEX"
                              FontPath        "/usr/share/fonts/cyrillic"
                              FontPath        "/usr/share/fonts/latin2/misc:unscaled"
                              FontPath        "/usr/share/fonts/latin2/75dpi:unscaled"
                              FontPath        "/usr/share/fonts/latin2/100dpi:unscaled"
                              FontPath        "/usr/share/fonts/latin2/Type1"
                              FontPath        "/usr/share/fonts/latin7/75dpi:unscaled"
                              FontPath        "/usr/share/fonts/baekmuk:unscaled"
                              FontPath        "/usr/share/fonts/japanese:unscaled"
                              FontPath        "/usr/share/fonts/kwintv"
                              FontPath        "/usr/share/fonts/truetype"
                              FontPath        "/usr/share/fonts/uni:unscaled"
                              FontPath        "/usr/share/fonts/CID"
                              FontPath        "/usr/share/fonts/ucs/misc:unscaled"
                              FontPath        "/usr/share/fonts/ucs/75dpi:unscaled"
                              FontPath        "/usr/share/fonts/ucs/100dpi:unscaled"
                              FontPath        "/usr/share/fonts/hellas/misc:unscaled"
                              FontPath        "/usr/share/fonts/hellas/75dpi:unscaled"
                              FontPath        "/usr/share/fonts/hellas/100dpi:unscaled"
                              FontPath        "/usr/share/fonts/hellas/Type1"
                              FontPath        "/usr/share/fonts/misc/sgi:unscaled"
                              FontPath        "/usr/share/fonts/xtest"
                              FontPath        "/opt/kde3/share/fonts"
                          EndSection
                          
                          Section "Module"
                              Load           "dbe"
                              Load           "type1"
                              Load           "freetype"
                              Load           "extmod"
                              Load           "glx"
                          EndSection
                          
                          Section "ServerFlags"
                              Option         "AllowMouseOpenFail" "on"
                          EndSection
                          
                          Section "InputDevice" 
                            Driver       "kbd" 
                            Identifier   "Keyboard[0]" 
                            Option "XkbModel" "logitech_g15" 
                            Option "XkbLayout" "us" 
                            Option "XkbOptions" "compose:rwin" 
                          EndSection 
                          
                          Section "InputDevice"
                            Driver       "mouse"
                            Identifier   "Mouse[1]"
                            Option       "Buttons" "12"
                            Option       "Device" "/dev/input/mice"
                            Option       "Name" "Logitech USB Gaming Mouse"
                            Option       "Protocol" "explorerps/2"
                            Option       "Vendor" "Sysp"
                            Option       "ZAxisMapping" "4 5"
                          EndSection
                          
                          Section "Modes"
                              Identifier         "Modes[0]"
                          EndSection
                          
                          Section "Monitor"
                            Option       "CalcAlgorithm" "XServerPool"
                            DisplaySize  320 230
                            HorizSync    30-92
                            Identifier   "Monitor[0]"
                            ModelName    "COMPAQ P700"
                            Option       "DPMS"
                            VendorName   "CPQ"
                            VertRefresh  43-120
                            UseModes     "Modes[0]"
                          EndSection
                          
                          Section "Device"
                              Identifier     "Device[0]"
                              Driver         "nvidia"
                              VendorName     "Nvidia"
                              BoardName      "Geforce 8800GT 512"
                              Option       "XvMCUsesTextures"
                              Option       "NoLogo"
                              Option       "RenderAccel"
                              Option       "HWcursor"
                              Option "Coolbits" "1"
                          EndSection
                          
                          Section "Screen"
                              Identifier     "Screen[0]"
                              Device         "Device[0]"
                              Monitor        "Monitor[0]"
                              SubSection     "Display"
                                  Modes      "default"
                              EndSubSection
                          EndSection
                          Section "Extensions"
                              Option         "Composite" "Enable"
                          EndSection

                          Comment


                          • #28
                            Originally posted by deanjo View Post
                            Sure here it is.
                            Thank you, but that didn't help.

                            Comment


                            • #29
                              Well, I take back my comment about 2D working faster with these drivers. They have now become the dogs bollocks

                              Comment


                              • #30
                                the 2d performance on 8800gt, with ANY nvidia driver, is simply horrible, its so slow that its basically useless.. i can smash in a pci card, thats 10 years ago, and get same performance out of the vesa driver..

                                nvidia is simply doing a horrible job.

                                Comment

                                Working...
                                X