Announcement

Collapse
No announcement yet.

Slow Compiz performance with 8800 GT

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Slow Compiz performance with 8800 GT

    Hi there.

    I just got my new Gainward 8800 GT, and chose nVidia because I had heard so much praise of their drivers (or actually just the lack of complaining).

    The weird thing is, that even with this card being a lot more powerful than my previous card, Radeon X1950 Pro, it has a pitiful fps when running Compiz. If I remember correctly, I had several hundreds of fps in Compiz. Now I get 60 fps tops, and when having the cube transparent or lots of windows open it drops to 30 fps.

    Other annoying thing is playing Flash videos; it flickers like hell. you can easily see the border between the previous frame and the new one as the card is drawing it. And this happens when Compiz is off too.

    The drivers should be correctly installed, I have direct rendering, Nexuiz runs fast and smooth with ultimate settings, and there are no error messages in Xorg.0.log.

    Any ideas what might be causing it?

    Then theres one more problem. I'm using Mandriva 2008.0, and after I had manually installed the nVidia drivers (the .run installer), by mistake I had Mandriva install the driver packages, too. Now I have the driver installed twice, and also have two "Nvidia X settings" shortcuts in the Tools menu.
    So I'd really like to be able to remove the manually installed driver as I think the packages will be easier to maintain. Could someone give me instructions how to do that?

    Btw. the 2 drivers installed -problem is not causing the compiz performance -problem, as it existed even before I had installed the second driver by mistake.
    And yes, I have uninstalled all previous ATI drivers.

    Any help would be much appreciated.
    Thank you.

  • #2
    nvidia-installer --uninstall

    deletes the files the nvidia installer added.

    Comment


    • #3
      Thanks for that, it worked.

      Yet the performance issue remains...
      Has anybody had same kind of experiences?

      EDIT: Got the flash video playback smooth by enabling the RENDER -option... but Compiz is still patheticly slow.

      EDIT: The problem seems to be in AIGLX, as running Compiz with XGL is about 1700 fps, and when turning the cube 500 fps... but I'd reeeally prefer AIGLX instead of XGL, so I'd like to get this solved.

      One more EDIT: interesting, adding --indirect-rendering when starting compiz improves the performance, by going as high as 360 fps with about 60-80 fps when rolling the cube. Now this is fully usable, but still it makes me wonder why I have to use compiz --replace --indirect-rendering ... doesn't --indirect-rendering mean that it will use AIGLX? Shouldn't it use AIGLX by default? And why am I getting even a lot higher performance in XGL?
      Mysteries. Or just my ignorance, either way
      Last edited by anyone; 02-07-2008, 12:03 PM.

      Comment


      • #4
        Try "Loose Binding" in Fusion Icon. --indirect-rendering isn't the best solution.

        Comment


        • #5
          Well, Mandriva doesn't install fusion-icon with the packages, but I did try it with compiz --loose-binding ... it adds some 1500 fps with the --indirect-rendering used :P thanks a lot. But minimizing windows and adding new tabs in Opera still lags like hell...

          EDIT: woah, even weirder things going on... if I have a download running in Opera, it lags like hell too. All the time.
          Last edited by anyone; 02-08-2008, 01:21 PM.

          Comment


          • #6
            Disable refresh rate detection and Vsync and manually set the refresh rate to a multiple of the refresh rate you're currently using. For example, my monitor is running at 60 Hz so I set it to 120 Hz. This way I get a really smoothly working compiz with my very low-end IGP (GeForce 7050). Obviously you'll see some tearing due to disabled Vsync, but it's not that bad, really.

            Comment


            • #7
              Originally posted by greg View Post
              Disable refresh rate detection and Vsync and manually set the refresh rate to a multiple of the refresh rate you're currently using. For example, my monitor is running at 60 Hz so I set it to 120 Hz. This way I get a really smoothly working compiz with my very low-end IGP (GeForce 7050). Obviously you'll see some tearing due to disabled Vsync, but it's not that bad, really.
              I'm pretty inexperienced with the Nvidia driver, so I can't find the options to do that... neither in GUI or command line.
              I'd need some more details

              Comment


              • #8
                These are not options of the driver but compiz options. You can find them in the CompizConfig Settings Manager (ccsm) under General / Display Settings.

                Comment


                • #9
                  Originally posted by greg View Post
                  These are not options of the driver but compiz options. You can find them in the CompizConfig Settings Manager (ccsm) under General / Display Settings.
                  Thanks, but changing those didn't really do anything... I don't see any difference.

                  I think the problem is, that the Nvidia binary drivers use too much cpu power, which means that the display lags when CPU is in hard use.
                  But I still wonder why it runs more smoothly under XGL.

                  Comment


                  • #10
                    Originally posted by anyone View Post
                    Thanks, but changing those didn't really do anything... I don't see any difference.

                    I think the problem is, that the Nvidia binary drivers use too much cpu power, which means that the display lags when CPU is in hard use.
                    But I still wonder why it runs more smoothly under XGL.
                    I don't know why you have this problem but I can say that generally nvidia cards don't have problems with compiz. My 7300 GT works fine and I have good performance and no flickerings.

                    Comment


                    • #11
                      You never should enable RENDER as option in Extensions section. That forces emulation mode - this works with every card but you will not get accelleration.

                      Comment


                      • #12
                        Funny... with the RENDER option in Mandriva Control Center disabled it lags as much or little more than with it enabled.

                        Actually it seems, that Mandriva Control Center doesn't enable RENDER in xorg.conf, but some option called RenderAccel. The label says Enable RENDER Acceleration. I had just expected it to enable RENDER, but guess I was wrong :P

                        Comment


                        • #13
                          RenderAccel is specifically for the nvidia driver... In recent drivers its enabled by default. In recent Xorg RENDER is also enabled by default...in theory you shouldn't need to have it enabled specifically, however I don't really know how mandriva does things

                          Comment


                          • #14
                            same same on 8400GS

                            I'm seeing the exact same problems on my laptop with a 8400GS card. Read somewhere, might have been on this forum, but I can't remember) that there is a problem with 8xxx cards and compiz. Especially cube and blur.

                            I have just tried 173.08 and the problem is still there.

                            /Sinner

                            Comment


                            • #15
                              newer xserver problems

                              There is also a composite performance regression in newer xservers 1.4.caused by a securtiy fix.

                              8xxx series cards have serious 2d gfx slowness which is why switching tabs/scrolling etc. can be sluggish.

                              Comment

                              Working...
                              X