No announcement yet.

NVIDIA 169.04 Beta Linux Driver

  • Filter
  • Time
  • Show
Clear All
new posts

  • NVIDIA 169.04 Beta Linux Driver

    Phoronix: NVIDIA 169.04 Beta Linux Driver

    Late last month NVIDIA released the GeForce 8800GT graphics card, however, today NVIDIA has finally delivered an updated Linux display driver to add this new product support as well as correct other outstanding issues. This new Linux display driver is version 169.04 Beta, which is a large version bump from the previous 100.14 series.

  • #2
    ubuntu 7.10 64bit, 7800GTX, new nvidia beta driver: and etqw is now broken (for me) :\

    Initializing SDL subsystem
    thread priority set to 1
    Loading GL driver '' through SDL
    signal caught: 'Segmentation fault', si_code 1
    double fault: 'Segmentation fault', bailing out

    edit1: all 32bit OpenGL apps are broken for now, for me, mhhh

    edit2: well, there went sth. wrong with the installer, i simply reinstalled it, and now it works great
    Last edited by .CME.; 11-16-2007, 06:28 PM.


    • #3
      It works for me, tho i only have a 6600GT. Also noticed a slight increase in performance. Nice release so far...


      • #4
        Originally posted by .CME. View Post
        you did goto init-3 and rmmod the present nvidia driver and then modprobe the new driver didn't you before starting X again.

        That segfault is usually due to the OpenGL userland libs not compatable with present in-use driver

        Either way driver good for ET:QW


        • #5
          Nvidia 8800gt oc 512mb pci-express and Nvidia 169.04 beta driver

          I am considering buying the Nvidia 8800GT OC 512mb pci-e
          graphics card and am wondering if there are issues with it running Linux.


          • #6
            Michael already mentioned, that he'd post some benchmarks, as soon as the GT is supported by the linux-driver.


            • #7
              Ubuntu 7.10, 8800 GTX, AMD Athalon 64 2.4Ghz, 2G PC3200

              I tried the 100.19 driver and the new beta and they seemed to have fixed the 2D slow redraw issue, I still see some flicker on HD video playback though. Seems to use more resources and playback is jumpier than my older ge6600.


              • #8
                I'm using it on my 7600GT AGP and all seems normal, i like the new PowerMizer monitor even if i don't really know whats its function.


                • #9
                  When I use the new beta driver, compiz doesn't want to start up, just displaying this:

                  compiz: Trying '/usr/$LIB/'
                  ERROR: object '/usr/$LIB/' from LD_PRELOAD cannot be preloaded: ignored.
                  compiz (core) - Fatal: No GLXFBConfig for default depth, this isn't going to work.
                  compiz (core) - Error: Failed to manage screen: 0
                  compiz (core) - Fatal: No manageable screens found on display :0.0
                  Some games are a bit unstable and in COD in wine there is slight graphical glitches like far away flashes of light repeat themselves on the whole one side of the skybox.


                  • #10
                    Yes, that Compiz Fusion error drove me crazy the first day I tried out the new driver.

                    What I discovered was that on certain configurations Compiz automatically falls back to indirect openGL rendering. If your card can support direct rendering, this is an unnecessary fallback and it apparently isn't even working with the new driver.

                    The solution for me was to add the --no-libgl-fallback switch to the other switches used when starting Compiz. Manually for me this would be:

                    export __GL_YIELD="NOTHING"
                    compiz --replace --no-libgl-fallback --sm-disable --ignore-desktop-hints ccp &

                    You may want to try that before editing whatever configuration file starts Compiz for you on your distro. If it works, you're mostly there. If you usually start it manually from a terminal, congratulations! Otherwise you've got to figure out what starts Compiz for you. If you are used to using fusion-icon to run Compiz for you, you will need to stop doing that as I haven't figured out a way to add stuff to the fusion-icon script. I tried editing the script I found but it had no effect. You can start Compiz manually as I said, then start fusion-icon with:

                    fusion-icon -n

                    That will load Fusion Icon into your system tray without reloading or starting Compiz. This way you will have the ability to switch window-decorators on the fly, open ccsm or the Emerald Manager easily, etc.

                    If you do that, instead of using the icon for switching between Kwin, Metacity, and Compiz, instead switch those from the terminal:

                    kwin --replace &
                    killall kde-window-decorator

                    metacity --replace &
                    The gtk decorator doesn't need killing as it exits properly, and so does emerald.

                    If you use compiz-manager to start things, it automatically runs fusion-icon with that -n switch. So you only need to:

                    kdesu kate /usr/bin/compiz-manager


                    gksu gedit /usr/bin/compiz-manager


                    gnomesu gedit /usr/bin/compiz-manager

                    Then you add to the Compiz startup OPTIONS line the:


                    Fusion Icon can be tricky on distro's that do not use compiz-manager because KDE or Gnome may load it because it was running in the tray and the session is restored. In that case I guess you could try to remember to right click exit from the Fusion Icon before logging off or it would attempt to start Compiz without that switch and fail, leaving you without Metacity or Kwin as well, just an unresponsive desktop. With Compiz Manager, it always beats Fusion Icon to the punch (in my experience) and so things go pretty smoothly.

                    I hope that switch works for you. It did for me.


                    • #11
                      I usually start compiz by typing this into the console:
                      compiz --replace ccp &
                      It always fell back to Indirect Rendering but if I added --no-libgl-fallback it went away. Both ways worked perfectly and I didn't see any difference.

                      With the new driver it crashes/gives up with both. I even tried to enter it exactly like yours and it still doesn't work.

                      By the way, what does the export __GL_YIELD="NOTHING" do?


                      • #12
                        It's what these auto-loaders such as Fusion Icon and Compiz Manager do before running Compiz when they detect that an MVidia card is being used. So I just copied that when doing the starting of Compiz from a terminal myself. It also has appeared in Forum posts on the Compiz Fusion forum and in the Compiz Fusion wiki as a recommended way to start up Compiz Fusion with an NVidia card. Think I saw it at forum as well.

                        As to your situation, perhaps try uninstalling and reinstalling the NVidia driver:

                        On OpenSUSE:
                        su -
                        put the root password
                        init 3
                        login as root
                        nvidia-installer --uninstall
                        cd to your NVidia installer script
                        sh -q
                        sax2 -r -m 0=nvidia
                        save and exit sax2 after adjusting the monitor
                        nvidia-xconfig --composite
                        shutdown -a -r now
                        kdesu kate /etc/X11/xorg.conf
                        gnomesu gedit /etc/X11/xorg.conf
                        change HWCursor from off to on
                        save, close, exit the editor
                        logout, ctrl-alt-backspace, login
                        kdesu or gnomesu nvidia-settings
                        save to configuration file
                        logout, ctrl-alt-backspace, login
                        Try to run Compiz Fusion

                        On Debian systems do the same except:
                        login as root
                        /etc/init.d/kdm or gdm stop
                        The rest is the same except not needing to deal with the HWCursor blinky mouse cursor and having a drop-down link to click in KDM to restart the X server without needing to ctrl-alt-backspace, and instead of the sax2 stuff doing:

                        dpkg-reconfigure -phigh xserver-xorg
                        (phigh makes it start with a clean auto-detection)
                        dpkg-reconfigure xserver-xorg
                        nvidia-xconfig --composite

                        If that doesn't work then try reinstalling and/or purging all the compiz stuff and installing it again.

                        That's what I would try. Other than that stuff I wouldn't know what to do and would post to the Compiz Fusion forum for help from all those developer and expert Compiz folks.