Announcement

Collapse
No announcement yet.

How does one get nVidia MCP51 High Definition Audio working

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • How does one get nVidia MCP51 High Definition Audio working

    How does one get nVidia MCP51 High Definition Audio working with SuSE 10.0

    It seems one needs to use the snd-hda-intel alsa driver, but that it doesn't work in many cases.

    Anyone, know how to get it working.

  • #2
    I have had no problems getting the MCP51 working with Fedora.

    Did you try compiling ALSA 1.0.13 manually?
    Michael Larabel
    http://www.michaellarabel.com/

    Comment


    • #3
      Originally posted by Michael View Post
      I have had no problems getting the MCP51 working with Fedora.

      Did you try compiling ALSA 1.0.13 manually?
      Michael -- that's not very helpful.

      By the way, I have come across articles asking how to get MCP51 sound working with Fedora, so it didn't work at some earlier time.

      First: Is it necessary to recompile the ALSA drivers?

      I have just seen articles which say it is necessary to use >= ALSA 1.0.11. Is this really the case?

      If it is necessary, I have just come across this page

      http://alsa.opensrc.org/Quick+Install

      which looks helpful.

      Comment


      • #4
        I don't use SuSE much so I don't know off hand what version it uses or any configurations that the developers may have made to it.

        I would try seeing if an ALSA update is available from the SuSE official repositories otherwise try compiling it manually.

        It is usually best to use the latest version of ALSA. The ALSA documentation is usually good for telling how to build the various parts of ALSA.
        Michael Larabel
        http://www.michaellarabel.com/

        Comment


        • #5
          Originally posted by Jade View Post
          How does one get nVidia MCP51 High Definition Audio working with SuSE 10.0

          It seems one needs to use the snd-hda-intel alsa driver, but that it doesn't work in many cases.

          Anyone, know how to get it working.
          ALSA 1.0.12 AND ALSA 1.0.13 "accidently" do not compile.

          ALSA 1.0.11 works like a charm.

          That's it.

          Comment


          • #6
            The reason that compiling ALSA 1.0.11 works for SuSE 10.0 is that it matches the SuSE 10.0 kernel.

            ALSA 1.0.12 AND ALSA 1.0.13 work for more recent versions of the kernel (but not for SuSE 10.0).

            Comment

            Working...
            X