No announcement yet.

Fedora Core 6 With NVIDIA Drivers

  • Filter
  • Time
  • Show
Clear All
new posts

  • Fedora Core 6 With NVIDIA Drivers

    Like I have done for the ATI fglrx drivers, I have written a script to automatically package (and download if need be) the NVIDIA 1.0-9626 display drivers to make it an easy installation process for those new to Linux.

    The script can be downloaded @

    To build the NVIDIA drivers you need kernel-devel and kernel-headers installed along with xorg-X11-server-sdk and the standard development packages.

    The script should work with both x86 and x86_64 architectures. If the driver is unable to locate the x86 or x86_64 driver in the working directory as the script, it will attempt to download the respective architecture from NVIDIA HTTP. The script is set to work for the 1.0-9626 display drivers.

    All this script does is automatically patch the nv-linux header file so it no longer relies on linux/config.h but now refers to linux/autoconf.h. This script should no longer be needed once NVIDIA releases new updated drivers.

    This was made at user request, and I haven't properly tested it, etc... yet. If you run into any problems just post.

    Also, Livna is a viable alternative for those who want RPMs.
    Last edited by Michael; 10-24-2006, 11:46 PM.
    Michael Larabel

  • #2


    I just tried the script and it had a few errors:

    config.h reference is not in nv.h but nv-linux.h

    I think some of the if, fi loops are off as you fi before else if; I just used the patch anyway (well saw what it did and applied it).

    After that was working X failed to load due to selinux. Being new to all this I just disabled selinux altogether and the driver works.

    [amadeus@poff ~]$ glxinfo | grep pixmap
    GLX_EXT_texture_from_pixmap, GLX_ARB_multisample, GLX_NV_float_buffer
    GLX_EXT_fbconfig_packed_float, GLX_EXT_texture_from_pixmap
    GLX_EXT_texture_from_pixmap, GLX_ARB_multisample, GLX_NV_float_buffer,

    I'm running Fedora Core 6 release.

    However the "Enable Desktop effects" fails with just the message: "Desktop effects could not be enabled".

    Any ideas how I can get this working?


    Last edited by amadeus_z; 10-27-2006, 05:59 PM.


    • #3

      Ok so I found the solution from a google cache page:

      I needed to add the following to xorg.conf:

      Section "Extensions"
      Option "Composite"

      In the "Device" section, add:
      Option "AddARGBGLXVisuals" "True"

      In the "Module" section, add:
      Load "extmod"