Announcement

Collapse
No announcement yet.

304.48 pre-release for Linux/Solaris/FreeBSD

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • 304.48 pre-release for Linux/Solaris/FreeBSD

    Please refer to this post for more information.

    Thanks,
    - Pierre-Loup
    NVIDIA Linux Graphics
    Last edited by Plagman; 09-11-2012, 07:50 PM.

  • #2
    Thanks.

    It's been a long time since the KDE VDPAU problem was confirmed. Any plans on fixing that? VDPAU is unusable right now (and has been for a long time.)

    Comment


    • #3
      Really? I use both KDE and mplayer+vdpau daily and they work just fine together.
      Occasionally mplayer locks up due to some vdpau quirk, but that's it.

      Comment


      • #4
        @Plagman: looks like you are now the nVidia Linux mascot. We need you in a head to head with Linus!
        Any news on the *official * nVidia Linux forum?

        Comment


        • #5
          Originally posted by mlau View Post
          Really? I use both KDE and mplayer+vdpau daily and they work just fine together.
          Occasionally mplayer locks up due to some vdpau quirk, but that's it.
          VDPAU has never worked for me. It's this bug:

          http://www.nvnews.net/vbulletin/showthread.php?t=173519

          It was confirmed by NVidia back then. But still no fix till this day.

          Comment


          • #6
            Still working on the forums; we realize how unfortunate the current situation is right now and are trying to work it out as soon as possible.

            As for the VDPAU / KWin interaction problems, we're currently looking into it and discussing potential solutions with the KWin developers.

            Thanks!

            Comment


            • #7
              Some progess, regarding a tear free desktop shoud be top priority, because most opengl DE shows tearing in the upper portion of the screen (KWIN, COMPIZ), using nvidia drivers.

              Comment


              • #8
                Originally posted by narciso View Post
                Some progess, regarding a tear free desktop shoud be top priority, because most opengl DE shows tearing in the upper portion of the screen (KWIN, COMPIZ), using nvidia drivers.
                This is because the GPU switches to an extremely low power mode (50Mhz) and stays there. The "PowerMizer" thing simply refuses to unstuck itself from the 50Mhz mode, even if you produce activity on the desktop. The only thing that seems to wake it up is launching a 3D app or something like Firefox and scroll around in a page. And even then, it's too slow to adapt. Worst of all, you can't change the settings in a meaningful way (like disable only the 50Mhz mode and leave the others as they are.)

                I had to force the GPU to a higher mode because of that, or else the desktop (KDE) sucks major (heavy tearing and jerky animations.) This, however, disables automatic power mode switching, so now I'm stuck with just one mode (the middle one, between extremely low and full throttle.)

                This thing should have never made it past QA, IMO. It's annoying as hell.
                Last edited by RealNC; 09-12-2012, 06:08 PM.

                Comment


                • #9
                  Great, I hope this fixes my problem with the lastest driver hanging the X server about when my mouse randomly skips. It only happens when I'm gaming in 3d. When the same thing happend 2 years ago, I replaced my mouse thinking that was the issue (skips but not lockups) eventually a nvidia driver update fixed it. As it stands now, when it locks up I gotta hard reset or ssh in and kill/restart the X server manually.

                  Comment


                  • #10
                    Originally posted by RealNC View Post
                    This is because the GPU switches to an extremely low power mode (50Mhz) and stays there. The "PowerMizer" thing simply refuses to unstuck itself from the 50Mhz mode, even if you produce activity on the desktop. The only thing that seems to wake it up is launching a 3D app or something like Firefox and scroll around in a page. And even then, it's too slow to adapt. Worst of all, you can't change the settings in a meaningful way (like disable only the 50Mhz mode and leave the others as they are.)

                    I had to force the GPU to a higher mode because of that, or else the desktop (KDE) sucks major (heavy tearing and jerky animations.) This, however, disables automatic power mode switching, so now I'm stuck with just one mode (the middle one, between extremely low and full throttle.)

                    This thing should have never made it past QA, IMO. It's annoying as hell.
                    The problem is not the powermizer, but the way nvidia deals with vsync. Compiz latest development release implemented a fix for tearing on nvidia, Kwin dev's passed the ball to nvidia drivers.

                    Comment


                    • #11
                      Originally posted by narciso View Post
                      Kwin dev's passed the ball to nvidia drivers.
                      KWin developers just trying to find root of the tearing issues with nVidia drivers: http://blog.martin-graesslin.com/blo...#comment-50548
                      Last edited by RussianNeuroMancer; 09-13-2012, 10:01 AM.

                      Comment


                      • #12
                        Well, I was told that it's X11's fault and that the low power mode of the GPU is enough for Windows Aero, but not enough for X11. The GPU can't keep up with the memory bandwidth requirements of X11 (yes, that means that compositing on X11 is a resource hog compared to Windows, which is supposed to be light-weight.) Wayland is supposed to fix that.

                        The result is framebuffer tearing (which in the end is just as visible as screen tearing.) Switching the GPU to higher speed gets rid of that tearing.

                        Edit:
                        This is the thread: http://forum.kde.org/viewtopic.php?f=111&t=99090

                        Comment


                        • #13
                          Hi, I also work on the NVIDIA Linux Graphics team and have been investigating the kwin/VDPAU interaction problems.

                          There is an upstream fix for the performance issue described in this link in kde-workspace; see

                          https://projects.kde.org/projects/kd...0d7dc5d08401a5

                          I have backported this patch to kde-workspace_4.8.4a-0ubuntu0.1; see http://pastebin.com/8DmsyTP7 . I hope this helps!

                          Brian Nguyen
                          NVIDIA Linux Graphics

                          Comment


                          • #14
                            Hi, I am also a developer on the NVIDIA Linux Graphics team, and I have been investigating the performance issue described in the nvnews thread (http://www.nvnews.net/vbulletin/showthread.php?t=173519).

                            A fix has been submitted upstream to kde-worskpace; see https://projects.kde.org/projects/kd...0d7dc5d08401a5 . I have backported this patch to the kde-workspace_4.8.4a-0ubuntu0.1 version; see http://pastebin.com/8DmsyTP7 .

                            I hope this helps!

                            Regards,
                            Brian Nguyen
                            NVIDIA Linux Graphics

                            Comment

                            Working...
                            X