Announcement

Collapse
No announcement yet.

NVIDIA 304.37 Linux Driver Brings 41 Official Changes

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #21
    hmm, I can't replicate it. Is it because I'm using kwin gles?

    Comment


    • #22
      304.30 had blue tint for me
      304.32 fixed the blue tint.

      Problem is 304.32 resulted in <20fps for HoN while 302.17 is ~= 40fps

      304 has (or had if 304.37 is good) some nasty performance regressions.

      I really wanted to try fxaa since it should give a nice performance boost when aa is use

      Comment


      • #23
        Originally posted by boast View Post
        hmm, I can't replicate it. Is it because I'm using kwin gles?
        You're using gles with the NVidia driver?

        Er, isn't that impossible?

        Comment


        • #24
          mmm ok this is odd...
          I can't seem to enable FXAA with the 304.37 driver & 304.37 nv-settings

          was able to with 304.32 ... gets in some silly pseudo-radiobutton mode...

          --edit-- ahh I see now, and the fact the behaviour now kinda makes sense explains why it might have had issues last time

          --edit--
          still trash... 20fps...


          --edit-
          well it crashed to 4fps but it seems fxaa overriding apps isn't like in windows, you actually have to disable aa in the application as well.
          upto 30fps, need to see how stable it is, msaa would result in 40fps crashing to 20 in a big fight
          Last edited by Naib; 08-13-2012, 09:01 PM.

          Comment


          • #25
            Originally posted by boast View Post
            hmm, I can't replicate it. Is it because I'm using kwin gles?
            You are not alone. I tried tonight on the GTX-580/GT-520 and the GTX-275 systems and vdpau playback (smplayer2) with kwin effects on works fine with zero slowdown or tearing (media framerates of 59.94/29.97/24/23.97 tried) using the openGL backend. (Unlike the intel graphics system in the i3).

            Comment


            • #26
              I also have this issue sometimes the performance is fine but X is using 90% cpu ...
              The best workaround is just to disable composition for video playback there is an option which turn off composition on fullscreen.
              But I'm using just the "alt+shift+F12" shortcut if I play a video. It's kind of annoying if you don't watch a fullscreen video and have to disable composition...

              Comment


              • #27
                Originally posted by Naib View Post
                well it crashed to 4fps but it seems fxaa overriding apps isn't like in windows, you actually have to disable aa in the application as well.
                upto 30fps, need to see how stable it is, msaa would result in 40fps crashing to 20 in a big fight
                That's just a shader applied over, why would you bother since you have *real* AA already? just use it without any AA or not

                Originally posted by RealNC View Post
                Using VDPAU makes everything, including the mouse cursor itself, run with something like 5FPS. In other words, the whole desktop becomes unusable while VDPAU is active.
                oh, that one, yeah I get that too with mplayer2 but not mplayer1 so you can guess where to point the finger :P ( KDE 4.8.x 64bit w/ OpenGL composition + SMPlayer )

                @all: stop feeding teh [strikeout]uid313[/strikeout]troll

                Regarding X stability: it's the same as on W7, as in, it's as rock solid as the apps you use, I'm not sure a WDM driver restart is such a fun thing to have in the end.

                Comment


                • #28
                  Originally posted by deanjo View Post
                  You are not alone. I tried tonight on the GTX-580/GT-520 and the GTX-275 systems and vdpau playback (smplayer2) with kwin effects on works fine with zero slowdown...
                  It's there...





                  ... and it's confirmed http://www.nvnews.net/vbulletin/showpost.php?p=2553685&postcount=25


                  Comment


                  • #29
                    Originally posted by Licaon View Post
                    That's just a shader applied over, why would you bother since you have *real* AA already? just use it without any AA or not
                    because fxaa is a different approach to aa which is fast, why use MSAA when FXAA looks suitable when/if you can reclaim some fps...
                    Also there instances where fxaa actually provides better visual results as well as being faster. check out the white papers and results.

                    MSAA has better anti-aliasing during motion (which is what you see the most of in every game, unless you're playing solitaire or something)
                    but FXAA has benefits in that it will anti-alias the entire screen and not just edges... so shaders get anti-aliased, too
                    for games that dont have FXAA built-in, forcing FXAA will also anti-alias text, interfaces, and other stuff you probably dont want it to and since linux nvidia-settings doesn't provide per-app options (like on windows) it means the desktop get AA applied to it

                    Here is a screenshot of HoN using fxaa at a nice high res.





                    --edit forum has downsized it, so open in a browser
                    https://impas.se/screenshots/pc/3516...ofnewerth2.png
                    Last edited by Naib; 08-14-2012, 05:05 AM.

                    Comment


                    • #30
                      You're taking this the wrong way. This is just so people who don't know what they're doing and want their graphics to work, having followed umpteen internet tutorials and installed both drivers, get the better working ones of the bunch instead of having nouveau interfere. It's also an option that's not on by default, so something suggests to me that someone else will be turning it on.

                      Comment

                      Working...
                      X