Announcement

Collapse
No announcement yet.

Video tearing using vdpau and wrong colors in flash 11.2 videos. 295.40 driver

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Video tearing using vdpau and wrong colors in flash 11.2 videos. 295.40 driver

    Ubuntu 12.04 with 295.40: Tried with an xvid (mpeg 4 part 2 asp) video annoying tearing is visible. Looks like framerate is too high to match the refresh rate. Also playing accelerated youtube flash videos, colors are wrong (blue instead of red i think... bgr instead of rgb?). When accel is disabled goes back to normal. Are there solutions to these problems?

  • #2
    The Flash issue is an Adobe bug that, probably, they will refuse to fix. You're right to say that they totally borked the colorspace. On the nvidia forums (nvnews.net) there is a thread about it with a really awful hack that nvidia devs came up with to work around Adobe's obstinate stupidity. It's probably easier to just disable hardware acceleration like you say. That's the route I chose.

    As for the tearing, I can't say. It may be compiz related. Is sync to vblank turned on? You're not using TwinView, are you? Does it still tear if you login to Unity2D instead?

    Comment


    • #3
      You can try 2 things:

      a) full accelleration:
      Code:
      sudo -i
      mkdir -p /etc/adobe;echo EnableLinuxHWVideoDecode=1 > /etc/adobe/mms.cfg
      b) disable vdpau:
      Code:
      sed -i s/libvdpau/libvdpax/g $HOME/.mozilla/plugins/libflashplayer.so

      Comment


      • #4
        Originally posted by Kano View Post
        You can try 2 things:

        a) full accelleration:
        Code:
        sudo -i
        mkdir -p /etc/adobe;echo EnableLinuxHWVideoDecode=1 > /etc/adobe/mms.cfg
        Thanks i can enable the acceleration from right mouse button flash menu now with 0 problems.

        Ooops i forgot to select vdpau as output in smplayer, forget the first issue.

        Comment

        Working...
        X