No announcement yet.

Logout freeze using Nvidia Proprietary driver (latest and even older versions)

  • Filter
  • Time
  • Show
Clear All
new posts

  • Logout freeze using Nvidia Proprietary driver (latest and even older versions)

    I've built a HTPC running Linux (Ubuntu 12.04) w/ AMD Liano processor and a Fusion motherboard with HDMI. Initially I was using AMD processor and Catalyst driver output to HDMI.

    Then I realized that video decoding acceleration is poor with this combination. I've installed vaapi acceleration packages but XBMC refused to work with it. Not to mention even flash acceleration is not working as it requires vdpau.

    So I brought a Nvidia GT 520 card for this. Lucky the card is quiet cheap

    Once I installed the card with Nvidia proprietary driver, everything seems to now well with output going to the HDMI in Nvidia card. Sound works great, video acceleration works as well with vdpau as I can see Chrome Flash youtube is now consuming very few processing power. Of course I've the blue tint problem with the flash but I managed to fix it with the /etc/adobe/mms.cfg thing.

    However a problem happens.

    Whenever I try to logout (either my Unity session or a delicated XBMC session), the system freeze with some console message (I can't recall exactly "SYSV service stop......" or "using libgcrypt-1.5 ...." and I cannot get back to the login screen (I'm using ubuntu so it should be lightdm).

    I tried to ping the machine and SSH to it. Ping responses with either problem with connection or reply with a very long latency. SSH doesn't work (I think probably due to long network latency). Seems like the machine is still on but with a very high CPU utilization.

    Keyboard / mouse is not responding (alt-ctrl-f1 doesn't work) and I've to hard reset the machine.

    Anyone have similar issue and any fix? Now I've reverted back to AMD (and open source radeon driver which seems to work pretty well). Really hope that I can get some video decoding acceleration.

  • #2
    Do you insist on using Ubuntu? Try using a different distribution. Ubuntu family tends to have tons of small and weird bugs, thanks to their custom patch frenzy. I found Fedora to be user friendly equally to Ubuntu. If you go down Fedora route, don't forget about RPMFusion repository for non-free software. Also, take a look at "Fedora spins" for a choice of environments different than GNOME 3.


    • #3
      The problem doesn't happen when I am using the ATI on-board card, either the open source or proprietary driver. So I don't know if it is a problem with nvidia, ubuntu or anything else. Will probably give fedora a try but would still like to know how it can be fixed here.


      • #4
        Originally posted by mikejuni View Post
        The problem doesn't happen when I am using the ATI on-board card, either the open source or proprietary driver. So I don't know if it is a problem with nvidia, ubuntu or anything else. Will probably give fedora a try but would still like to know how it can be fixed here.
        The warning that you got could be useful to track the issue. Not sure however, where Ubuntu stores its logs.


        • #5
          I've reinstalled everything hoping to find out little bit more.

          Now I found out that the issue generally occurs after logout, when the x server is shutdown and reloaded for lightdm. The I suspected lightdm issue and use gdm instead.

          Still the same issue occurs.

          The xorg log immediately before freeze indicates xorg and nvidia driver unloaded successfully. Then the system seems to hang. I can actually ssh to the server and the response is extremely slow, which I think indicates some program locks the system with some kind of infinite loop.

          Other than that doesn't seem to have any unusual log. The problem occurs only with the nvidia restricted driver or the driver I downloaded from nvidia directly. Nouveau doesn't have the same problem, neither do the ati card (radeon or catalyst).

          Now I am sticking to radeon driver. The catalyst driver have other problems (xbmc not able to play video with vaapi enabled)


          • #6
            You can not play h264 l5.1 with xvba-video (nor would it work with xbmc-xvba). I requested a hotkey to disable accelleration without going thru the menus but nobody cared


            • #7
              Yes, and that's why I reverted to AMD open source driver. My system is APU based so it is on board.

              Actually performance is quite ok for HTPC (I can decode blu-ray 1080p without problem), just no hardware video acceleration so no fancy things such as motion compensation or other post-processing.

              Really hope I can get the nvidia driver working so that I can use GT520 for all these with VDPAU. The application support is much wider (flash, XBMC, VLC and almost everything else).


              • #8
                I just want to update my experience and share with everyone here about the issue.

                My card is a ASUS GT520 (passive cooling). The kernel freeze happens with 295.40 driver.

                Today I installed the 295.49 driver, the "freeze" had disappeared. I got response from the machine and SSH works fine now.

                However, still having Xid messages in the kernel log and still X wouldn't start up again after I logoff, kill / restart lightdm (am using Ubuntu) and the error messages are consistent.

                I tried 302 beta driver however there is no HDMI sound coming out. Hence it is not an option. I tried to ask for help in and simply cannot register in the forum (the register link is broken).

                Just want to know if there are any other help channels?


                • #9
                  If you use kdm try this:
                  sed -i 's/^[#]*\(TerminateServer=\).*/\1true/' /etc/kde4/kdm/kdmrc
                  Otherwise look for a similar option. I have got no HDMI issues with kernel 3.2 and 302.xx or 295.xx using pa (and nv 405 (rebranded 210). Maybe you use the wrong system
                  Last edited by Kano; 05-11-2012, 01:23 AM.


                  • #10
                    Don't think it is a config issue since I have no hdmi issue with 295.49 driver. Just that 295.49 driver I annoy have X restarted.

                    I have similar finding reports in with exactly same configuration gt520


                    • #11
                      Finally I've fixed the issue (it seems).

                      Putting the nvidia driver into persistent mode (nvidia-smi -pm 1) seems fix the problem by preventing the kernel driver from unloading and reloading during X restart!

                      The bug seems to be related to how nvidia.ko initiate and re-initiate display devices. By preventing it from unloading/reloading, the reinit process is skipped.


                      • #12
                        same issue

                        I just installed an Asus GT520 and I got the exact same problem, and this was the only place Google led me when I tried to describe it.

                        Some more data points for other people coming across this, before I try applying your fix:

                        I've often used nVidia GPUs before, and on ubuntu. Back as far as GeForce 6100, via GeForce 9400, GT218, GT320M (on a mac mini) all using ubuntu, all using the binary drivers, various versions of Ubuntu up to Quantal - which I overwrote with a fresh Precise install earlier today hoping it might clear this. I never had this problem before.

                        I'm having it now on an Ubuntu Precise 64-bit install with the nvidia 302.17 driver from ubuntu-x-swat updates ppa. I didn't keep the original nvidia driver version long enough on the new install to see if it happens on that, but I bet it does, seeing as it did for you, and 302.17 didn't have these issues on other nvidia cards.

                        if you install mcelog, this is logged in /var/log/mcelog when it happens:

                        mcelog: failed to prefill DIMM database from DMI data
                        mcelog: mcelog read: No such device
                        Hardware event. This is not a software error.
                        MCE 0
                        CPU 0 BANK 5
                        MISC 7fff ADDR 3fffa0059e95
                        TIME 1342806593 Fri Jul 20 18:49:53 2012
                        MCG status:
                        MCi status:
                        Uncorrected error
                        Error enabled
                        MCi_MISC register valid
                        MCi_ADDR register valid
                        Processor context corrupt
                        MCA: Internal Timer error
                        STATUS be00000000800400 MCGSTATUS 0
                        MCGCAP 1c09 APICID 0 SOCKETID 0
                        CPUID Vendor Intel Family 6 Model 26

                        I suspect the issue is with this model of card, which probably has a firmware bug. Like you, I find that otherwise it works perfectly for XBMC, but having it crash the system on logout (Precise seems to have a watchdog that reboots it after a minute or two, which is something) is a bit of a downer.

                        I shall now try to apply your 'fix'. Where do you put that so it happens on boot? Or do you only need to enter it once and the setting's stored on the card?
                        Last edited by StrangeNoises; 07-20-2012, 02:21 PM. Reason: fix emoticon


                        • #13
                          ... and i can confirm that worked for me too. And it doesn't persist on its own, so I put the line in /etc/rc.local and that seems to do it.
                          Last edited by StrangeNoises; 07-20-2012, 02:20 PM. Reason: fix emoticon


                          • #14
                            Originally posted by asdx
                            use nouveau
                            when it can handle vdpau fully i might even do that. (I'm also using this for XBMC.) Until then, it's not a very useful suggestion; especially as on the default install, when nouveau is used, it chose to display the X desktop on my TV zoomed in (probably an overscan mode being off) and no obvious way to stop it doing that.

                            All things being equal I too prefer the open-source driver approach. But things are not equal. (And yes I know it's nVidia's fault for not being more open, but it still works out as the best solution for xbmc.)