Announcement

Collapse
No announcement yet.

NVIDIA 1.0-9625 Beta!

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • NVIDIA 1.0-9625 Beta!

    NVIDIA has decided to issue a Beta Rel90 Linux driver! As well as for Solaris and BSD

    http://www.nzone.com/object/nzone_do..._1.0-9625.html

    * Added initial support for GLX_EXT_texture_from_pixmap.
    * Added new "Display Configuration" page in nvidia-settings.
    * Improved workstation OpenGL performance in Xinerama.
    * Added support for NVIDIA Quadro Plex.
    * Added support for Quad SLI.
    * Improved X driver error recovery.
    * Improved workstation overlay performance.
    * Added SMBus functionality to the Linux/i2c interface.
    * Fixed DFP scaling support.
    * Added support for OpenGL 2.1.
    * Added new "TwinViewXineramaInfoOrder" X configuration option to control the order of display devices when in TwinView.
    In the middle of testing now...
    Michael Larabel
    http://www.michaellarabel.com/

  • #2
    Some quick thoughts are @ http://www.phoronix.com/vr.php?view=7393

    More to come soon...
    Michael Larabel
    http://www.michaellarabel.com/

    Comment


    • #3
      Not run for me

      Originally posted by Michael View Post
      NVIDIA has decided to issue a Beta Rel90 Linux driver! As well as for Solaris and BSD

      http://www.nzone.com/object/nzone_do..._1.0-9625.html



      In the middle of testing now...

      I've downloaded and installed it but when I try to start my X server a black screen is all the thing that I obtain.



      I've a GeForce FX5500 on a SuSE 10.1 (Xorg 6.9.0).
      Someone know why this happen?

      My Xorg.0.log is interrupted and the latest lines reported are
      ...
      (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
      (**) NVIDIA(0): Option "NoLogo" "true"
      (**) NVIDIA(0): Option "NvAGP" "0"
      (**) NVIDIA(0): Option "UseEDID" "true"
      (**) NVIDIA(0): Option "RenderAccel" "true"
      (**) NVIDIA(0): Option "AllowGLXWithComposite" "true"
      (**) NVIDIA(0): Option "Rotate" "off"
      (**) NVIDIA(0): Option "TripleBuffer" "true"
      (**) NVIDIA(0): Enabling RENDER acceleration
      (**) NVIDIA(0): Disabling static screen rotation.
      (**) NVIDIA(0): Use of AGP disabled per request

      I've tried to disable AGP but don't seems to depend on this.
      I've also disabled all the options in my Driver section of xorg.conf file, and all the Extensions.

      I have to warn nvidia? How?

      Thanks.

      Alex.

      Comment


      • #4
        toalex,

        Welcome to the forums.

        It sounds like you could have the i2c problem that a few users have already reported. NVIDIA has already released a patch, which removes this. See more @ http://www.nvnews.net/vbulletin/show...3&postcount=20
        Michael Larabel
        http://www.michaellarabel.com/

        Comment


        • #5
          installed and running with aiglx now on Gentoo x86_64 system.

          Comment


          • #6
            Heres a link to the amd64 drivers:
            http://www.nzone.com/object/nzone_do..._1.0-9625.html

            I am going to try this now. The new features look awesome .

            Comment


            • #7
              Is it possible to enable vsync and be running aiglx to result in a vsync'ed desktop ala Mac OSX?

              Comment


              • #8
                Originally posted by oneman View Post
                Is it possible to enable vsync and be running aiglx to result in a vsync'ed desktop ala Mac OSX?
                I tried to turn on vsync. But it did not seem to work so I still got screen tearing .

                Comment


                • #9
                  Yes is the i2c. Thanks

                  Originally posted by Michael View Post
                  toalex,

                  Welcome to the forums.

                  It sounds like you could have the i2c problem that a few users have already reported. NVIDIA has already released a patch, which removes this. See more @ http://www.nvnews.net/vbulletin/show...3&postcount=20
                  Yes is the i2c problem.

                  I've applied the instruction on the link on nwnews and now the driver works very well.

                  Many many thanks

                  Comment


                  • #10
                    Originally posted by siti View Post
                    I tried to turn on vsync. But it did not seem to work so I still got screen tearing .
                    Hey, it seems compiz has a sync to vblank option you might could try.

                    Comment

                    Working...
                    X