Announcement

Collapse
No announcement yet.

Powermizer works poorly and cannot be set from xorg.conf

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Powermizer works poorly and cannot be set from xorg.conf

    I use geforce 9400M G on ubuntu 10.10 64 bit. My driver version is 260.19.26.

    Up until recently I could set the powermizer mode to "Maximum performance" using xorg.conf. However, this does not work any more. My system starts with powermizer mode set to "adaptive", and I have to change it manually back.

    This wouldn't be a problem if adaptive mode would work properly, but it doesn't. When I play 3d games, like lugaru (or any other), in adaptive mode, the game starts fine but then I experience severe drops in the frame rate. It is as if the powermizer does not know a 3d app is running.

    So my questions are:
    1. Can adaptive mode be made to work, is it actually adapts the clock speed to the system demands?
    2. If it cannot, can the powermizer be set automatically so I do not have to open nvidia-settings and change it manually after reboot?
    3. Can I supply more useful information in order to solve the problem(s)?

    My xorg.conf is:

    Code:
    Section "ServerFlags"
    	Option		"IgnoreABI" "True"
    EndSection
    
    Section "Screen"
    	Identifier	"Default Screen"
    	DefaultDepth	24
    EndSection
    
    Section "Device"
    	Identifier	"Default Device"
    	Driver	"nvidia"
    	Option  "FlatPanelProperties"  "Scaling = Aspect-Scaled"
    	Option  "OnDemandVBlankInterrupts" "true"
    	Option	"NoLogo"	"True"
    	Option  "coolbits" "1"
    	Option "RegistryDwords" "PowerMizerEnable=0x1; PerfLevelSrc=0x3322; PowerMizerDefaultAC=0x1"
    EndSection
    
    Section "InputClass"
            Identifier "enable synaptics SHMConfig"
            MatchIsTouchpad "on"
            MatchDevicePath "/dev/input/event*"
            Option "SHMConfig" "on"
    EndSection

  • #2
    Powermizer works well here. Let me guess your suffering using compiz?

    Comment


    • #3
      Originally posted by deanjo View Post
      Powermizer works well here. Let me guess your suffering using compiz?
      That's right! Good call. So far the problem is not reproduced with metacity.

      So, until compiz and powermizer learn how to play nicely together, my question remains: how can I make my system remember my preferrred powermizer settings?

      Comment


      • #4
        Originally posted by Wise Ferret View Post
        That's right! Good call. So far the problem is not reproduced with metacity.

        So, until compiz and powermizer learn how to play nicely together, my question remains: how can I make my system remember my preferrred powermizer settings?
        You can force the powermizer levels in your xorg.conf file. An example:

        Code:
        Section "Device"
            Identifier     "Videocard0"
            Driver         "nvidia"
            VendorName     "NVIDIA Corporation"
            BoardName      "GeForce 9400M G" 
            # force Powermizer to a certain level at all times
            # level 0x1 = highest
            # level 0x2 = med
            # level 0x3 = lowest
            Option  "RegistryDwords"    "PowerMizerLevel=0x3"
        EndSection
        Compiz has had a long time issue with powermizer. Kwin4 doesn't seem to have this issue.

        Comment


        • #5
          Originally posted by deanjo View Post
          You can force the powermizer levels in your xorg.conf file. An example:

          Code:
          Section "Device"
              Identifier     "Videocard0"
              Driver         "nvidia"
              VendorName     "NVIDIA Corporation"
              BoardName      "GeForce 9400M G" 
              # force Powermizer to a certain level at all times
              # level 0x1 = highest
              # level 0x2 = med
              # level 0x3 = lowest
              Option  "RegistryDwords"    "PowerMizerLevel=0x3"
          EndSection
          Compiz has had a long time issue with powermizer. Kwin4 doesn't seem to have this issue.
          This worked for me until recently, but now (I think after moving to the current series of drivers) this setting has no effect. My xorg.conf contains this line and after resetting X my powermizer mode is still adaptive.

          Comment


          • #6
            Does its behavior change when you have the power adapter plugged in vs off of battery power?

            Comment


            • #7
              Probably better to ask over at nvnews. That "registrydwords" crap never worked for me either (never had problems with compiz though). Try using nvidia-settings, and make sure it detects the power status via ACPI. You might also try some compiz options like loose-bindings or so, but I'm not.sure.

              Comment


              • #8
                Originally posted by deanjo View Post
                Does its behavior change when you have the power adapter plugged in vs off of battery power?
                No, it happens anyway.

                Comment


                • #9
                  Originally posted by not.sure View Post
                  Probably better to ask over at nvnews. That "registrydwords" crap never worked for me either (never had problems with compiz though). Try using nvidia-settings, and make sure it detects the power status via ACPI. You might also try some compiz options like loose-bindings or so, but I'm not.sure.
                  Thanks. I'll ask there. In nvidia-settings I do not see anything about ACPI. What do you mean exactly? Where should I see it?

                  Comment

                  Working...
                  X