Announcement

Collapse
No announcement yet.

Curious behavior with monitors

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Curious behavior with monitors

    I'm using ubuntu 9.04 with nvidia driver 180. I have two screens:
    - LG: HDMI (but with overscan) and VGA
    - Packard bell (PB): VGA, DVI, HDMI

    My nvidia card (8600 GTS) has two outputs:
    - HDMI
    - DVI (with a DVI-VGA converter for the LG)

    HDMI on the LG is tricky because of the overscan, plus if I enable a high resolution, it...vibrates... for lack of a better word, the contents on the screen are fuzzy due to what seems to be a vibrating motion. So I use VGA on the LG.

    If i plug in HDMI on the PB, the "nvidia-settings" manager will pick up the PB and its model name, so it clearly detects the screen, but when I enable twinview, nothing happens. The screen is not active.

    Here is where it get's freaky:
    - if i plug in both DVI & HDMI in the PB, both work fine! (HDMI at high resolution is ok, no fuzziness or nothing!)
    - if i plug in VGA & HDMI in the LG, vga works, HDMI is overscanned and at high resolution fuzzy

    Now in the second case, if i transfer the HDMI connection from the LG to the PB...the PB works! The nvidia manager still shows the old screen (by model name i mean), but then i have a working setup for HDMI & VGA, however, a few things:

    - in high resolution... the PB gets fuzzy! (this means the fuzziness is not screen-related?)
    - once nvidia manager catches on that its the PB and not the LG, it stops working

  • #2
    Well first thing I would do is upgrade your driver. There have been a few screen detection fixes put in since the now VERY old 180 series driver.

    Comment


    • #3
      I have updated ubuntu to 9.10 and now have the "185.18.36" driver.

      I have tried pretty much every configuration with the nvidia settings, nothing will actually enable the second screen it seems.

      Mind you that the screen does show up in the nvidia settings AND that the 9.04 ubuntu livecd sets up a cloned environment out of the box.

      Comment


      • #4
        Originally posted by akshara View Post
        I have updated ubuntu to 9.10 and now have the "185.18.36" driver.

        I have tried pretty much every configuration with the nvidia settings, nothing will actually enable the second screen it seems.

        Mind you that the screen does show up in the nvidia settings AND that the 9.04 ubuntu livecd sets up a cloned environment out of the box.
        That is still a very old and outdated version. the current versions of drivers are official 190.53 and the beta 195.30.

        http://www.nvnews.net/vbulletin/showthread.php?t=122606

        Comment


        • #5
          Well, i fixed it by switching to the "nv" driver and using xrandr to set it all up. Thanks for the feedback!

          Comment

          Working...
          X