Announcement

Collapse
No announcement yet.

Intel X3100 - OpenGL support?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Originally posted by BlackStar View Post
    You are missing the point. Intel is thought to be the leader in OSS video drivers as far as features, stability and user experience is concerned. As such, I was looking forward to (finally!) trying a chip that wouldn't need countless hours of xorg.conf tweaking just to work - but the expectation didn't play out.
    Had you read what I'd said to you:

    Many, many others seem to have had decent results with it. Keep in mind that many laptop and motherboard vendors do screwy things with the chips they implement- some of which would cause problems. I know for a fact that the driver works FINE on my eeePC, but the same GMA on my Dell Optiplex 745 at work is unstable with 3D operation and I had to swap in a 6200LE just to work with things on the machine. BIOS settings and timings can play a BIG part in things working or not.
    You'd have already gotten the idea that I didn't miss your point. Moreover, you indicate that this device has issues with WINDOWS- which indicates something a bit more problematic than a "driver" issue. In your case, your hardware vendor did something that made things complicated.

    I quote your comments here:

    I'm not saying this only occurs on Linux either. The very same X3100 chip would blue screen windows, until the July drivers fixed what looked like an invalid memory allocation (this certainly didn't help my opinion of this card).
    This has more to do with the way Fujitsu deployed the chipset and the BIOS settings (Keep solidly in mind that other people don't have your problems, including under Linux...) than the drivers or Intel itself- start blaming people in order of the evidence (and not just yours...), in this case, very, very few people have issues with the X3100. That should point to a motherboard vendor screwing something up.

    As for performance... My GMA950 on my eeePC works well as does my X3500 on my HTPC. The Dell Optiplex 745 GMA950 DOES NOT work stably and when it does run, doesn't do 3D as well as it ought to. I strongly suspect you've got a problem with your laptop that puts the GMA in a suboptimal configuration.

    Comment


    • #17
      If you have got stability problems check your ram or replace it for testing.

      Comment


      • #18
        #14:
        so i must have missed the commit providing GLSL support? i guess i did..

        andwith the issues you describe, its blatantly obvious that you have some sort of giant issue, which people normally dont have..

        my experience with X3100 spans 5 laptops, all working excellently, and then my brother has a non-X 3100(htpc), which also runs excellently..

        I also know of people running GMA950 with compiz perfectly fine.

        by now you should realize that either there is something extremely wrong with your hardware, or your install.

        Comment


        • #19
          I haven't seen these compiz bugs on my x3100 setup.
          This is a good sign. Which distro? Which xorg version?

          Many, many others seem to have had decent results with it. Keep in mind that many laptop and motherboard vendors do screwy things with the chips they implement- some of which would cause problems. I know for a fact that the driver works FINE on my eeePC, but the same GMA on my Dell Optiplex 745 at work is unstable with 3D operation and I had to swap in a 6200LE just to work with things on the machine. BIOS settings and timings can play a BIG part in things working or not.
          You'd have already gotten the idea that I didn't miss your point. Moreover, you indicate that this device has issues with WINDOWS- which indicates something a bit more problematic than a "driver" issue. In your case, your hardware vendor did something that made things complicated.
          The windows crashes were 99% driver-related. They started happening after an update to the intel video drivers. The stopped happening with another video driver update. (Note that these drivers came from intel, not fujitsu.)

          I'm not saying that the BIOS or vendor implementation can't break things - I've worked around my share of ACPI bugs. However, there's no indication of BIOS problems here (standby/hibernate work perfectly on both platforms) - given the aforementioned experience on windows, it's only natural to assume the drive.rs are at fault

          If you have got stability problems check your ram or replace it for testing.
          Thanks for the suggestion, but I haven't had any stability problems under linux (or windows after the driver update) Besides, I've already replaced my RAM (moved from 2x1GB to 2x2GB - memtest succeeds in both cases).

          so i must have missed the commit providing GLSL support? i guess i did..
          Just checked the mobility 9700: the vendor/driver strings return "ATI Technologies Inc. ATI MOBILITY RADEON 9600-9700 Series 2.1.7412 Release". A quick test with OpenTK shows that 1288 out of 1528 OpenGL functions return non-null entry points.

          Maybe the open drivers haven't caught up yet, but soon enough they will. The point is, R300 can and does support GL2.0+.


          Anyway, thank you, your replies have helped me create a clearer picture regarding intel video hardware: it is solid (unless you fall into some specific hardware mis-configuration, which could happen anyway). Stability is great, 2d and video works fine. 3d is being worked upon (GL2.0 support is coming and let's hope GL3 support won't be too far off). If integrated graphics cover your needs, it's a great choice.

          Now on to find some solution to the issues I'm seeing...

          Comment


          • #20
            I'm running hardy 64 bit on a thinkpad t61. Xorg = 7.3

            Are you using fglrx to get opengl 2.0 support on r300? I was under the impression that the OSS driver doesn't have the bits for it included yet.

            I would like to add that the intel driver is on the forefront of adding new features. DRI2, TTM/GEM, xvmc, aiglx support, accelerated EXA, and new product support all arrive faster than other vendors' drivers.

            Comment


            • #21
              I'm runing hardy 64 bit on a thinkpad t61. Xorg = 7.3
              Thanks, that's the exact same configuration as here.

              Are you using fglrx to get opengl 2.0 support on r300? I was under the impression that the OSS driver doesn't have the bits for it included yet.
              Yes, using fglrx for now. I think you are right regarding GL2 in the OSS driver, but I'm too lazy to uninstall fglrx to check.

              The only reason for using fglrx (on this laptop) was that I knew off-hand how to setup a vertical big desktop - I just didn't have the time at that point to learn how to configure the OSS driver. Btw, the intel chip was a breeze to configure - just typed the mode ("1440x900+1280x1024") and xorg picked it up at once. Great!

              Anyway, for now I'm content using the x3100 for 2d work and mesa indirect for 3d development on the go. Back home, I test on a R500 and a G70 - with the target hardware being a quadro 3-thousand-something. A strange combination, but you get good compatibility (and become familiar with all shorts of driver quirks...)

              Once the x3100 gets stable GL2 support now, I'll be happy.

              Comment

              Working...
              X