Announcement

Collapse
No announcement yet.

KDE 4.11 Haswell Desktop Effects Performance

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • KDE 4.11 Haswell Desktop Effects Performance

    Phoronix: KDE 4.11 Haswell Desktop Effects Performance

    For those using Intel graphics does toggling the "suspend desktop effects for fullscreen windows" KDE Kwin window manager option lead to better OpenGL Linux gaming performance? Here's some new benchmarks to answer that question for Intel Core i7 hardware...

    http://www.phoronix.com/vr.php?view=MTQ5MjE

  • #2
    what a wonderful benchmark you did there, Michael.

    void Options::setUnredirectFullscreen(bool unredirectFullscreen)
    {
    if (GLPlatform::instance()->driver() == Driver_Intel)
    unredirectFullscreen = false; // bug #252817

    whoops, the option is ignored for all Intel hardware.

    Comment


    • #3
      This problem is from 2011, why didn't Intel still fix it?
      ## VGA ##
      AMD: X1950XTX, HD3870, HD5870
      Intel: GMA45, HD3000 (Core i5 2500K)

      Comment


      • #4
        Originally posted by darkbasic View Post
        This problem is from 2011, why didn't Intel still fix it?
        Probably because the bug hasn't been reported to the mesa bugtracker (I can't find it).

        on topic: I see a noticeable increase in performance when I disable desktop effects using alt+shift+F12 when gaming in a window, so I would think fullscreen windows would also get a noticeable increase if compositing is disabled.
        Last edited by mdias; 10-21-2013, 02:32 PM.

        Comment


        • #5
          I'm not sure how good that suspend compositing in fullscreen option really is? Maybe someone of you have benchmarked that option against the blocked compositing. Please share the results if you have benchmarked that?

          So I have always just totally blocked the compositing when I run softwares like Steam and mplayer (that fixed all 1080p tearing problems). And I use binary nvidia drivers.

          So if you don't know how to totally block the compositing...

          Shortcut key combination to toggle compositing on/off

          Shift+alt+f12

          Or automatically for certain programs:

          System settings > Window Behavior > Window rules > New

          First tab:

          - Description = "Name the setting"

          - Window class (application) = "Binary name of the running program ex. steam"

          Last tab:

          - Check the BLOCK COMPOSITING, select FORCE and YES options.
          Last edited by josk; 10-21-2013, 02:44 PM.

          Comment


          • #6
            Originally posted by darkbasic View Post
            This problem is from 2011, why didn't Intel still fix it?
            It's not clear that it hasn't been fixed.

            The first bug from a couple years ago looks like it was. There may be another problem present only in the i915g driver, which Intel doesn't support (they have a classic driver instead) but it's not clear whether that is still currently present or not.

            Comment


            • #7
              Originally posted by mgraesslin View Post
              what a wonderful benchmark you did there, Michael.

              void Options::setUnredirectFullscreen(bool unredirectFullscreen)
              {
              if (GLPlatform::instance()->driver() == Driver_Intel)
              unredirectFullscreen = false; // bug #252817

              whoops, the option is ignored for all Intel hardware.
              Shouldn't the user be informed when setting an option that is broken for their hardware rather than silently ignoring it?
              Michael Larabel
              http://www.michaellarabel.com/

              Comment


              • #8
                Originally posted by Michael View Post
                Shouldn't the user be informed when setting an option that is broken for their hardware rather than silently ignoring it?
                Yes, probably.
                But at least you did say it could just be an issue for Intel drivers. I guess next time you can test it on Nvidia cards, more testing must be done.
                It is pretty odd that such a noticable performance bug affects such a large percentage of the users. :U

                Comment


                • #9
                  Originally posted by Bathroom Humor View Post
                  ...
                  lol that nick rocks!

                  Comment


                  • #10
                    Originally posted by mdias View Post
                    on topic: I see a noticeable increase in performance when I disable desktop effects using alt+shift+F12 when gaming in a window, so I would think fullscreen windows would also get a noticeable increase if compositing is disabled.
                    Indeed. I'm on Ivy Bridge and I can see quite a difference. Not as huge of a difference as on Nouveau, though, but still pretty notable.

                    Comment


                    • #11
                      Originally posted by josk View Post
                      I'm not sure how good that suspend compositing in fullscreen option really is? Maybe someone of you have benchmarked that option against the blocked compositing. Please share the results if you have benchmarked that?

                      So I have always just totally blocked the compositing when I run softwares like Steam and mplayer (that fixed all 1080p tearing problems). And I use binary nvidia drivers.

                      So if you don't know how to totally block the compositing...

                      Shortcut key combination to toggle compositing on/off

                      Shift+alt+f12

                      Or automatically for certain programs:

                      System settings > Window Behavior > Window rules > New

                      First tab:

                      - Description = "Name the setting"

                      - Window class (application) = "Binary name of the running program ex. steam"

                      Last tab:

                      - Check the BLOCK COMPOSITING, select FORCE and YES options.

                      I thought I read that totally disabling composition caused tearing due to lack of Vsync? This idea of whether compositing causing issues or fixes them seems to go around in circles on this site. I have no idea what to think anymore.

                      I use Unity for my desktop, would the ctrl-alt-F12 help me when running full screen? Does it cause or fix tearing? Does it et me more FPS? Can someone whom actually understands this, test it for me and report back?

                      Comment


                      • #12
                        Originally posted by dh04000 View Post
                        I thought I read that totally disabling composition caused tearing due to lack of Vsync? This idea of whether compositing causing issues or fixes them seems to go around in circles on this site. I have no idea what to think anymore.
                        For me disabling the composition for mplayer fixed the tearing issues with GeForce210 when I played 1080p x264 video content. And yes I tried that suspend desktop effect for fullscreen option and it didn't worked.

                        Comment


                        • #13
                          Shift+alt+f12 Worked for me AMD catalyst drivers. hd 5750

                          After some time I changed the settings of kde.
                          Turning about everything off, in the settings.

                          KDE knows about these problems for a while, so they might have fixed it.

                          I remember a question, why "we" would want to run programs full screen, on this forum by somebody who matters kde wise.
                          (not recently though)

                          Comment


                          • #14
                            Originally posted by smitty3268 View Post
                            It's not clear that it hasn't been fixed.

                            The first bug from a couple years ago looks like it was. There may be another problem present only in the i915g driver, which Intel doesn't support (they have a classic driver instead) but it's not clear whether that is still currently present or not.
                            Yes both of the associated upstream bugs are marked as fixed:

                            https://bugs.freedesktop.org/show_bug.cgi?id=32303

                            https://bugs.freedesktop.org/show_bug.cgi?id=30509

                            That bug mentioned by one user was specific to i915 as you say so was never looked at upstream:

                            https://bugs.freedesktop.org/show_bug.cgi?id=58834

                            Obviously disabling a feature on all Intel drivers because of a possible bug in one unsupported driver reported by one user is a bit extreme, a point that is made by some users in the KDE bug report.

                            Comment


                            • #15
                              Originally posted by Michael View Post
                              Shouldn't the user be informed when setting an option that is broken for their hardware rather than silently ignoring it?
                              Well it's a homeopathic config option. The user thinks his system is faster by just clicking an option ;-)

                              No, it's quite simple: change introduced after translation freeze.

                              Comment

                              Working...
                              X