Announcement

Collapse
No announcement yet.

VaAPI with Intel HD Graphics Clarkdale i3 proc not working with mplayer

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #21
    Get bucks bunny as a test file from here. Afaik, on my system I get a picture + sound.
    Perhaps your file has a mp4 profile vaapi doesn't support yet.

    Comment


    • #22
      Just have a look here.
      I wonder if 10 % CPU is not too high. I will check against windows.

      Comment


      • #23
        Ok, playing with WMP over dxva2 gives me almost 0% CPU time.
        Playing with MPC HC gives me ~10% CPU, too.

        Quite unsure, whats the reason. Someone has an explanation for this?

        Comment


        • #24
          Originally posted by Rabauke View Post
          Just have a look here.
          I wonder if 10 % CPU is not too high. I will check against windows.
          That's a good idea to play the same file and compare.

          -vo vaapi: no image no sound
          Code:
          xabix@xabix-desktop:/usr/local/src/mplayer-vaapi-20100713/mplayer-vaapi$ ./mplayer -vo vaapi /media/RAID/Video/big_buck_bunny_720p_h
          MPlayer SVN-r31722-4.4.3 (C) 2000-2010 MPlayer Team
          mplayer: could not open config files /home/xabix/.lircrc and /etc/lirc//lirc/lircrc
          mplayer: No such file or directory
          Failed to read LIRC config file ~/.lircrc.
          
          Playing /media/RAID/Video/big_buck_bunny_720p_h264.mov.
          libavformat file format detected.
          [mov,mp4,m4a,3gp,3g2,mj2 @ 0x1aed280] max_analyze_duration reached
          [lavf] stream 0: video (h264), -vid 0
          [lavf] stream 2: audio (aac), -aid 0, -alang eng
          VIDEO:  [H264]  1280x720  24bpp  24.000 fps  5146.8 kbps (628.3 kbyte/s)
          Clip info:
           major_brand: qt  
           minor_version: 537199360
           compatible_brands: qt  
          libva: libva version 0.31.1
          libva: va_getDriverName() returns 0
          libva: Trying to open /usr/lib/dri/i965_drv_video.so
          libva: va_openDriver() returns 0
          ==========================================================================
          Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
          Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
          ==========================================================================
          ==========================================================================
          Opening audio decoder: [faad] AAC (MPEG2/4 Advanced Audio Coding)
          AUDIO: 48000 Hz, 2 ch, s16le, 437.6 kbit/28.49% (ratio: 54700->192000)
          Selected audio codec: [faad] afm: faad (FAAD AAC (MPEG-2/MPEG-4 Audio))
          ==========================================================================
          [AO OSS] audio_setup: Can't open audio device /dev/dsp: No such file or directory
          AO: [alsa] 48000Hz 2ch s16le (2 bytes per sample)
          Starting playback...
          Movie-Aspect is undefined - no prescaling applied.
          VO: [vaapi] 1280x720 => 1280x720 Planar YV12 
          A:  75.4 V:  75.4 A-V:  0.000 ct:  0.021   0/  0 18%  1%  2.3% 0 0 
          
          Exiting... (Quit)
          http://xabix.free.fr/uploads/mplayer-1.png

          -vo vaapi -va vaapi: image and no sound
          xabix@xabix-desktop:/usr/local/src/mplayer-vaapi-20100713/mplayer-vaapi$ ./mplayer -vo vaapi -va vaapi /media/RAID/Video/big_buck_bu
          MPlayer SVN-r31722-4.4.3 (C) 2000-2010 MPlayer Team
          mplayer: could not open config files /home/xabix/.lircrc and /etc/lirc//lirc/lircrc
          mplayer: No such file or directory
          Failed to read LIRC config file ~/.lircrc.

          Playing /media/RAID/Video/big_buck_bunny_720p_h264.mov.
          libavformat file format detected.
          [mov,mp4,m4a,3gp,3g2,mj2 @ 0x19e1300] max_analyze_duration reached
          [lavf] stream 0: video (h264), -vid 0
          [lavf] stream 2: audio (aac), -aid 0, -alang eng
          VIDEO: [H264] 1280x720 24bpp 24.000 fps 5146.8 kbps (628.3 kbyte/s)
          Clip info:
          major_brand: qt
          minor_version: 537199360
          compatible_brands: qt
          libva: libva version 0.31.1
          libva: va_getDriverName() returns 0
          libva: Trying to open /usr/lib/dri/i965_drv_video.so
          libva: va_openDriver() returns 0
          ================================================== ========================
          Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
          [VD_FFMPEG] VA API accelerated codec.
          Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
          ================================================== ========================
          ================================================== ========================
          Opening audio decoder: [faad] AAC (MPEG2/4 Advanced Audio Coding)
          AUDIO: 48000 Hz, 2 ch, s16le, 437.6 kbit/28.49% (ratio: 54700->192000)
          Selected audio codec: [faad] afm: faad (FAAD AAC (MPEG-2/MPEG-4 Audio))
          ================================================== ========================
          [AO OSS] audio_setup: Can't open audio device /dev/dsp: No such file or directory
          AO: [alsa] 48000Hz 2ch s16le (2 bytes per sample)
          Starting playback...
          Unsupported PixelFormat 61
          [VD_FFMPEG] Trying pixfmt=1.
          Movie-Aspect is undefined - no prescaling applied.
          VO: [vaapi] 1280x720 => 1280x720 H.264 VA-API Acceleration
          [VD_FFMPEG] XVMC-accelerated MPEG-2.
          A: 177.5 V: 177.5 A-V: 0.000 ct: 0.022 0/ 0 11% 4% 2.2% 3 0
          http://xabix.free.fr/uploads/maplyer-2.png

          If I play my h264 1080p mkv file with -vo vaapi and -va vaapi then I got this warning:
          ************************************************
          **** Your system is too SLOW to play this! ****
          ************************************************

          Possible reasons, problems, workarounds:
          - Most common: broken/buggy _audio_ driver
          - Try -ao sdl or use the OSS emulation of ALSA.
          - Experiment with different values for -autosync, 30 is a good start.
          - Slow video output
          - Try a different -vo driver (-vo help for a list) or try -framedrop!
          - Slow CPU
          - Don't try to play a big DVD/DivX on a slow CPU! Try some of the lavdopts,
          e.g. -vfm ffmpeg -lavdopts lowres=1:fast:skiploopfilter=all.
          - Broken file
          - Try various combinations of -nobps -ni -forceidx -mc 0.
          - Slow media (NFS/SMB mounts, DVD, VCD etc)
          - Try -cache 8192.
          - Are you using -cache to play a non-interleaved AVI file?
          - Try -nocache.
          Read DOCS/HTML/en/video.html for tuning/speedup tips.
          If none of this helps you, read DOCS/HTML/en/bugreports.html.
          which is strange has the CPU hits no more than 10% of one core.

          Rythmbox play the sound correctly and if I use SMplayer it also works but with SMplayer I don't have the image either. I think I need to find the config file of SMplayer in order to also set the va option so I can get the image and the sound

          I just wanted to share with you my results to compare but CPU wide it's perfect!

          Thanks
          XabiX

          Comment


          • #25
            So in the advance section of SMplayer you can configure additional options to be passed to Mplayer. Looking at the logs here is how Mplayer is launched:
            /usr/local/src/mplayer-vaapi-20100713/mplayer-vaapi/mplayer -noquiet -nofs -nomouseinput -sub-fuzziness 1 -identify -slave -vo vaapi -ao alsa -nokeepaspect -framedrop -dr -double -input nodefault-bindings:conf=/dev/null -stop-xscreensaver -wid 39846231 -monitorpixelaspect 1 -ass -embeddedfonts -ass-line-spacing 0 -ass-font-scale 1 -ass-styles /home/xabix/.config/smplayer/styles.ass -fontconfig -font Arial -subfont-autoscale 0 -subfont-osd-scale 20 -subfont-text-scale 20 -subcp ISO-8859-1 -vid 0 -aid 0 -subpos 100 -volume 50 -cache 2000 -ss 76 -osdlevel 0 -vf-add pp -autoq 6 -vf-add screenshot -slices -channels 2 -af scaletempo -softvol -softvol-max 110 -vo vaapi -va vaapi /home/xabix/Vidéos/big_buck_bunny_720p_h264.mov

            which I though would some my issue of back screen but there must be another option not working. At least I can find the audio options and now try to launch the Mplayer directly in cmd line and maybe have the sound too.

            SMplayer used is version 0.6.9.

            Comment


            • #26
              Did you try vlc yet? That works pretty good too. I do not use smplayer usually, i prefer command line for mplayer.

              Comment


              • #27
                Also why do you think the -aid must be 0? Usually only with -demuxer lavf you get so low numbers. Remove that option, you can choose audio with # key too later.

                Comment


                • #28
                  You've got no sound because of "[AO OSS] audio_setup: Can't open audio device /dev/dsp: No such file or directory"

                  Comment


                  • #29
                    Originally posted by Rabauke View Post
                    You've got no sound because of "[AO OSS] audio_setup: Can't open audio device /dev/dsp: No such file or directory"
                    Yes this what I was thinking too. But as at the end is to have the family using the HTPC server I prefer to let them a GUI interface then a cmd line

                    So I am focussing on the SMplayer issue right now.
                    From the cmd line above I should be able to find the right sound options but I like the GUI

                    Thanks for pointing the issue.

                    XabiX

                    Comment


                    • #30
                      I am still investigation but what I noticed is Mplayer doesn't like the option -wid.

                      Code:
                      Starting playback...                                                  
                      Unsupported PixelFormat 61                                                  
                      [VD_FFMPEG] Trying pixfmt=1.                                                  
                      Movie-Aspect is undefined - no prescaling applied.                                                  
                      VO: [vaapi] 1280x720 => 1280x720 H.264 VA-API Acceleration                                                   
                      X11 error: BadWindow (invalid Window parameter)                                                  
                      X11 error: BadWindow (invalid Window parameter)                                                  
                      X11 error: BadDrawable (invalid Pixmap or Window parameter)                                                  
                      X11 error: BadWindow (invalid Window parameter)                                                  
                      X11 error: BadDrawable (invalid Pixmap or Window parameter)                                                  
                      [VD_FFMPEG] XVMC-accelerated MPEG-2.                                                  
                      X11 error: BadWindow (invalid Window parameter)                                                  
                      X11 error: BadDrawable (invalid Pixmap or Window parameter)                                                  
                      X11 error: BadWindow (invalid Window parameter)                                                  
                      X11 error: BadDrawable (invalid Pixmap or Window parameter)                                                  
                      mplayer: dri2_util.c:109: dri2GetRenderingBuffer: Assertion `buffers' failed.
                      From google:
                      To embed the video window, smplayer uses the -wid option. According to the mplayer manpage that option only works with X11, OpenGL and DirectX, so if none of them is available in osx then I think that can't be done.

                      You can always check the option to use the mplayer window in preferences, at least this way the smplayer video widget will be hidden.
                      I am closed. Then I will try vlc.

                      Thanks

                      Comment

                      Working...
                      X