Announcement

Collapse
No announcement yet.

Intel, ATI Kernel Mode-Setting Continues To Mature

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Intel, ATI Kernel Mode-Setting Continues To Mature

    Phoronix: Intel, ATI Kernel Mode-Setting Continues To Mature

    There's been a whole flurry of activity going on within the kernel mode-setting world if you have looked at any of the Phoronix news entries from the past weeks. With the Linux 2.6.32 merge window opening up, activity on KMS for ATI and Intel hardware especially has increased...

    http://www.phoronix.com/vr.php?view=NzUzMA

  • #2
    Unbelievable how fast the opensource side of graphics is developing right now

    Comment


    • #3
      Then again, basework for what has been happening has been laid in during the last few years or so.

      Comment


      • #4
        Indeed, good stuff.

        On the other hand, GPU support hasn't been good for a long time now, so it's about time this happened.

        Comment


        • #5
          That are good news. I hope that -rc1 will be released soon. I can't await KMS support for my graphics card.

          Comment


          • #6
            Originally posted by FallenWizard View Post
            That are good news. I hope that -rc1 will be released soon. I can't await KMS support for my graphics card.
            Don't forget that it's not enabled by default and you will need updated DDX etc.

            Comment


            • #7
              Originally posted by d2kx View Post
              Don't forget that it's not enabled by default and you will need updated DDX etc.
              what exactly do i need to do?
              compiling kernel seems not to be enough, and - well maybe thats because im a noob - compiling and installing mesa 7.5.1 didnt change the glxinfo string, it still says mesa 7.4

              is there any possibility to check whether its active or not?

              Comment


              • #8
                Originally posted by d2kx View Post
                Don't forget that it's not enabled by default and you will need updated DDX etc.

                In fact, I have KMS already running.

                Code:
                [drm] radeon kernel modesetting enabled.
                radeon 0000:01:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
                radeon 0000:01:00.0: setting latency timer to 64
                [drm] radeon: Initializing kernel modesetting.
                [drm] register mmio base: 0xFE9E0000
                [drm] register mmio size: 65536
                ATOM BIOS: 11X
                [drm] Clocks initialized !
                [drm] Detected VRAM RAM=512M, BAR=256M
                [drm] RAM width 128bits DDR
                [TTM] Zone  kernel: Available graphics memory: 1027546 kiB.
                [drm] radeon: 512M of VRAM memory ready
                [drm] radeon: 512M of GTT memory ready.
                [drm] Loading RV730 CP Microcode
                platform radeon_cp.0: firmware: using built-in firmware radeon/RV730_pfp.bin
                platform radeon_cp.0: firmware: using built-in firmware radeon/RV730_me.bin
                [drm] GART: num cpu pages 131072, num gpu pages 131072
                [drm] ring test succeeded in 1 usecs
                [drm] radeon: ib pool ready.
                [drm] ib test succeeded in 0 usecs
                [drm] radeon: kernel modesetting successfully initialized.
                [drm] Radeon Display Connectors
                [drm] Connector 0:
                [drm]   DVI-I
                [drm]   DDC: 0x7f10 0x7f10 0x7f14 0x7f14 0x7f18 0x7f18 0x7f1c 0x7f1c
                [drm]   Encoders:
                [drm]     DFP1: INTERNAL_UNIPHY1
                [drm]     CRT2: INTERNAL_KLDSCP_DAC2
                [drm] Connector 1:
                [drm]   VGA
                [drm]   DDC: 0x7e20 0x7e20 0x7e24 0x7e24 0x7e28 0x7e28 0x7e2c 0x7e2c
                [drm]   Encoders:
                [drm]     CRT1: INTERNAL_KLDSCP_DAC1
                [drm] fb mappable at 0xD0141000
                [drm] vram apper at 0xD0000000
                [drm] size 5242880
                [drm] fb depth is 24
                [drm]    pitch is 5120
                executing set pll

                Comment

                Working...
                X