Announcement

Collapse
No announcement yet.

Intel Pushes Out A Big Bug-Fix X.Org Driver Update

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Intel Pushes Out A Big Bug-Fix X.Org Driver Update

    Phoronix: Intel Pushes Out A Big Bug-Fix X.Org Driver Update

    We have already burned through more than half of Q1'09 and have yet to see Intel's quarterly X.Org Linux driver update approaching (or even any release candidate, although the 2.6 release was late). While xf86-video-intel 2.7.0 isn't ready yet, a fairly significant bug-fix release has been issued in the 2.6 series. Eric Anholt has announced the release of xf86-video-intel 2.6.2, which carries some weight compared to the quick 2.6.1 release...

    http://www.phoronix.com/vr.php?view=NzA5MA

  • #2
    Can anyone verify if all these changes happen to fix VSYNC for DRI2/UXA?

    Comment


    • #3
      Yeah, I would like to know as well. I have an 4500MHD and get tearing in videos with or without Compiz enabled.

      Comment


      • #4
        i would love to see if this fix and the upcoming 2.7.0 driver fixes the weird performance problems with Intel that we're experiencing lately. Hope to see it on Ubuntu Jaunty.

        Comment


        • #5
          Tearing isn't fixed.

          Comment


          • #6
            Has someone UXA working without problems on 965-era (GMA X-series, X3000, X3500, X4500) Intel graphics? It works okayish for me on 915, GMA 950, but not on my GMA X3000 and GMA X3100 (hangs, hard drive churn...).

            Comment


            • #7
              Maybe someone with more knowledge can tell me, but does this post http://lists.freedesktop.org/archive...ry/001516.html mean they found a way to stop the tearing ?

              Comment


              • #8
                Originally posted by Timo Jyrinki View Post
                Has someone UXA working without problems on 965-era (GMA X-series, X3000, X3500, X4500) Intel graphics? It works okayish for me on 915, GMA 950, but not on my GMA X3000 and GMA X3100 (hangs, hard drive churn...).
                I've got a X3100 and lately no problem (with UXA and KDE 4.2 with kwin effects) but I use the complete X stack directly from git so for this particular release..???

                in fact I've problems with openarena and perf in general but in both case not new...

                Comment


                • #9
                  Originally posted by Timo Jyrinki View Post
                  Has someone UXA working without problems on 965-era (GMA X-series, X3000, X3500, X4500) Intel graphics? It works okayish for me on 915, GMA 950, but not on my GMA X3000 and GMA X3100 (hangs, hard drive churn...).
                  X4500 here, UXA is working.

                  I used to have some problem with freezes but seems to be gone now.

                  Comment


                  • #10
                    Originally posted by beecher View Post
                    Maybe someone with more knowledge can tell me, but does this post http://lists.freedesktop.org/archive...ry/001516.html mean they found a way to stop the tearing ?
                    This has been added to master now:

                    Code:
                    commit 67fef27f4b76490be085d232aba0ca9cbb3c5e59
                    Author: Xiang, Haihao <haihao.xiang@intel.com>
                    Date:   Fri Mar 6 09:40:07 2009 +0800
                    
                        Xv: free tearing on textured video
                        
                        Add an Xv attribute XV_SYNC_TO_VBLANK which has three values -1(auto), 0(off
                        and 1(on) to control whether textured adapter synchronizes the screen
                        update to the vblank. The default value is -1(auto).
                    Has anyone else tried it out? It doesn't work on my G45, if anything tearing seems worse now.

                    Comment

                    Working...
                    X