Announcement

Collapse
No announcement yet.

Mobility HD2600 PowerPlay problem

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Mobility HD2600 PowerPlay problem

    Hello,
    i have a PowerPlay problem on my HD2600 in Toshiba A200. I have Vista and Debian dualboot. On Vista works everything properly, but on Debian is bad FPS everywhere. I think, that problem is caused by PowerPlay.
    Sometimes, when i return from suspend, then my graphic run great for some time (~1 minute) - tested on glxgears - when returning from suspend, i have about 4800 FPS, but after some time it gets down to ~2500FPS. I am using Catalyst 8.10.
    My question is - is there any chance to get my graphic card properly working on fullspeed (i dont require to get her slower in powersaving mode)?
    Thanks for answer.
    Some thinks you should wanna know:
    schmaker@SchmakBook:~$ glxgears //glxgears after resume from suspend
    30210 frames in 5.0 seconds = 6041.911 FPS
    24473 frames in 5.0 seconds = 4894.000 FPS
    11661 frames in 5.0 seconds = 2320.883 FPS
    10554 frames in 5.0 seconds = 2110.680 FPS

    schmaker@SchmakBook:~$ aticonfig --lsp
    Error: POWERplay is not supported on your hardware.

    schmaker@SchmakBook:~$ fglrxinfo
    display: :0.0 screen: 0
    OpenGL vendor string: ATI Technologies Inc.
    OpenGL renderer string: ATI Mobility Radeon HD 2600
    OpenGL version string: 2.1.8087 Release

  • #2
    Hi, you have to know that glxgears is not a benchmark, if you really want to know the performance (before and after suspend) you should use something different... like the phoronix test suite

    speaking about powerplay, --lsp is deprecated.
    You should use --pplib-cmd instead:

    aticonfig --pplib-cmd "get activity"
    tells you about what's going on in general in this moment

    aticonfig --pplib-cmd "get clock"
    tells you the ranges between the clocks can vary. (they depend on the state you are: battery or ac)

    aticonfig --pplib-cmd="notify psrc dc"
    aticonfig --pplib-cmd="notify psrc ac"
    tells to the driver that we are in battery/ac, to control the clocks.

    is it enough?

    Comment


    • #3
      Thanks

      Thanks for your reply. I of course know, that glxgears isnt benchmark, but on full speed it gives 4500FPS (i tried it before FPS drop) without problem, but now i have 2,5k FPS and it is visible in every game, so there i dont see any problem.

      Back to aticonfig:
      schmaker@SchmakBook:~$ aticonfig --pplib-cmd "get activity"
      Current Activity is Core Clock: 500MHZ
      Memory Clock: 400MHZ
      VDDC: 1100
      Activity: 0 percent
      Performance Level: 0
      Bus Speed: 2500
      Bus Lanes: 16
      Maximum Bus Lanes: 16

      schmaker@SchmakBook:~$ aticonfig --pplib-cmd "get clock"
      Engine Clock Range: 500-500 MHZ; Memory Clock Range: 400-400 NHZ;
      I've tried to change "powersource" as you told me - Core clock had changed to 250MHz, but FPS does not changed.

      Comment


      • #4
        uh there's something strange there!

        Code:
        ben@Santa^s_lil^_helper ~ $ aticonfig --pplib-cmd "get activity"
        Current Activity is Core Clock: 220MHZ
        Memory Clock: 252MHZ
        VDDC: 900
        Activity: 0 percent
        Performance Level: 0
        Bus Speed: 2500
        Bus Lanes: 16
        Maximum Bus Lanes: 16
        and

        Code:
        ben@Santa^s_lil^_helper ~ $ aticonfig --pplib-cmd "get clock"
        Engine Clock Range: 220-500 MHZ; Memory Clock Range: 252-400 NHZ;
        when i'm not running anything.

        are you sure you did enable powerplay in the catalyst control center?

        Comment


        • #5
          Powerplay is enabled

          Yes, i am sure, powerplay is enabled, but i have no idea why it isnt properly working. Maybe some Catalyst developer can help here?

          Maybe i have to give some additional informations:
          I havent this problem first time. I fixed it once - when i shutdowned Vista on battery, then i got bad FPS on Debian. I fixed it by reboot to Vista, put it on cable and reboot back to debian, but it doesnt work now (i tried it about 7 times :/ )

          Comment


          • #6
            mhh try erasing /etc/ati/amdpcsdb

            I hope it's just a configuration problem, in fact it's not related to vista for sure.

            Comment


            • #7
              It didnt solved anything - i restarted X, new amdpcsdb was created and FPS still isnt good... It makes me a bit nervous :/
              edit: Damn, it looks like its fixed - after suspend it works now okay... Thanks for your help!
              edit2: No, its not okay... FPS falled down after longer time
              Last edited by Schmaker; 10-30-2008, 01:12 PM.

              Comment


              • #8
                Maybe its problem in "Activity"? This is Activity level while i was running glxgears - ~50% and in glxgears i have about 2500FPS... Shouldnt be activity 100%?
                schmaker@SchmakBook:~$ aticonfig --pp "notify psrc ac"
                PPLIB command execution is Successful!
                schmaker@SchmakBook:~$ aticonfig --pp "get activity"
                Current Activity is Core Clock: 500MHZ
                Memory Clock: 400MHZ
                VDDC: 1100
                Activity: 45 percent
                Performance Level: 1
                Bus Speed: 2500
                Bus Lanes: 16
                Maximum Bus Lanes: 16

                Comment


                • #9
                  and how is cpu activity? is at least 1 core at 100%??

                  Comment


                  • #10
                    Yes, 2nd core is on 100%

                    Comment


                    • #11
                      glxgears is CPU bound
                      is your CPU changing speed?

                      Comment


                      • #12
                        I have CPU set to performance and was on cable when trying it. So it was on full (1,6GHz) speed..

                        Comment


                        • #13
                          Another possibility is a background task, usually started by cron or anacron. Since glxgears is CPU bound, rather than GPU bound, CPU intensive background tasks can do this. Unfortunately, cron/anacron don't run nice'd by default.

                          Comment


                          • #14
                            i am sure, that it isnt caused by CPU usage. Its GPU related, because i have bad FPS in games as well. I think it is powerplay related, but i cant be sure.. Maybe is there another bug in drivers? Or maybe it can be kernel related? I really dont know...

                            Comment


                            • #15
                              Originally posted by Schmaker View Post
                              i am sure, that it isnt caused by CPU usage. Its GPU related, because i have bad FPS in games as well. I think it is powerplay related, but i cant be sure.. Maybe is there another bug in drivers? Or maybe it can be kernel related? I really dont know...
                              8-10 maybe 8-9 as well has a bug that causes a fps drop in quake3 demo timedemos after the first run.

                              It's not 100% reproduceable and with what little testing I did (using OSS drivers currently) it seemed like it could be fixed by running other 3D apps IIRC the unigine benchmark after which it was fine. That observation could be a red herring.

                              It happened on both my AGP X1600 and AGP HD3850 cards.

                              Comment

                              Working...
                              X