Announcement

Collapse
No announcement yet.

Yes, Catalyst 8.10 Is Out There

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Yes, Catalyst 8.10 Is Out There

    Phoronix: Yes, Catalyst 8.10 Is Out There

    Yesterday we reported on Canonical shipping an unreleased ATI Catalyst driver with the forthcoming release of Ubuntu 8.10. This driver labeled fglrx 8.54.3 adds support for X Server 1.5 / X.Org 7.4 and the Linux 2.6.27 kernel...

    http://www.phoronix.com/vr.php?view=Njc4OA

  • #2
    I have to say, I must give a boo for this move. It is long past time to support xserver 1.5, and distributing a different version of the driver to Ubuntu than everyone else is not very nice.

    ATI needs to get their act together with fglrx and offer customers a decent level of support, not continually falling behind with needed updates and ignoring rampant bugs.

    Comment


    • #3
      As a _Fedora_ 9 user who had to manually downgrade his X server to Fedora 8 (gah!) to get fglrx installed so his dual-head would work, and has been waiting for X Server 1.5 support, BOOOOOO ATI!!

      Comment


      • #4
        Originally posted by hubick View Post
        As a _Fedora_ 9 user who had to manually downgrade his X server to Fedora 8 (gah!) to get fglrx installed so his dual-head would work, and has been waiting for X Server 1.5 support, BOOOOOO ATI!!
        fedora is meant to be a development platform, not something you should use for productive work. And Ati just treats it like that.

        Use Ubuntu

        Comment


        • #5
          Not a particularly respectworthy move by AMD. But who knows. Maybe they bring out a halloween special, including tearing-free video playback, support for the new XServer and free candy.

          Comment


          • #6
            The realease notes are there!
            https://a248.e.akamai.net/f/674/9206...810_linux.html

            Comment


            • #7
              fedora 9? the fglrx devels run rhel 4.7 or 5.2 or sled 10 i guess (from the look of their release notes). nope, not debian lenny (or sarge with xfree 4.3 ).

              Comment


              • #8
                I am experiencing poor performance with the new driver.

                Glxgears gives me about half the frames of 8.9 and I also get corruption on fullscreen 3d apps,not just wine but native as well.

                My card is the igp 3200HD
                Last edited by nstamoul0; 10-17-2008, 08:24 PM.

                Comment


                • #9
                  I just upgraded from 8.7 drivers to the 8.10 drivers. I downloaded the 8.10 from AMD official site.

                  Can't really notice much difference only thing maybe is that video playback is a little better can now play my 1280x720 videos lag or stutter free. But that could have been fixed whit some other updates that I did just before I updated to 8.10 though. (was a long list in the update manager, so...)

                  Didn't break or improve my compiz functionality and I still get blinking/flashing video when in window mode but the workaround I had from before gives at least non-flashing video in full screen whit compiz going.
                  Still get video tearing like BADLY.. (using mplayer whit Xv)

                  I have the Gigabyte GA-MA78GM-S2H rev1.1 whit HD3200 graphics, Phenom X4 9750 and 2x2Gb 800Mhz 4.4.4.12 memory whit Ubuntu 8.04 64bit.

                  glxgears give alot less fps but as I know it isn't a real bench in any way. I don't have any games installed or the like so can't test such how they work.

                  Comment


                  • #10
                    Originally posted by Nighthog View Post
                    glxgears give alot less fps but as I know it isn't a real bench in any way. I don't have any games installed or the like so can't test such how they work.
                    *cough* Phoronix Test Suite *cough*

                    Comment


                    • #11
                      Ok installed the the test suite 1.2 and tested lightsmark... Works in no way correctly....

                      First when choosing native size 1920x1200... you have a don't know what to call... boxes of few pixels thick colours in more boxes patterned all over the screen, making unrecognisable or what it might be in any way.

                      when choosing some other than native resolution I get it boxed to the left top corner from the screen going right and down to it's resolution size and I can see my desktop around where the benchmark isn't running. But the benchmark flickers back and forth between my desktop and what it should show. But I can see in what the test is showing the things or effects it should show are not working.. you basically only get a light showing parts off a pitch black room. The most basic light effect? HDR, radiosity etc don't show anything else but the most basic light.
                      wait.. I tested again whit 800x600 and this time the effects worked.. hmm.. ok I ran the test again and now it didn't work... Something seriously not working as it should! I tested whit compiz running and switching to metacity didn't help either, same thing.

                      Now also tested Warsow benchmark. There atleast I get fullscreen whit each resolution but I get that random patterns graphics that you can't make anything out from whit the short lines in rows and boxes. The benchmark does still run and you hear the game going and the benchmark completed in the end and gave me a result. 1920x1200 Warsow performed 60.80fps on my computer with the HD3200 and catalyst 8.10, phenom 9750, 4Gb 800Mhz 4.4.4.12 2T

                      Unigine Sanctuary 1920x1200 gave me laughing 3.88FPS and same fullscreen mess. 800x600 gave me 28.19fps but same thing otherwise. can't see anything coherent.
                      Last edited by Nighthog; 10-19-2008, 08:32 AM.

                      Comment


                      • #12
                        Anyone knows it there is any performance review for this or even 8.09, in linux ?
                        Had Ati (9800se) lots of problems, new system to nvidia 7900gs. Now having this nvidia and no issues. Now considering a newer system, with amd 790gx/fx and a hd4850 i would like to know if it is a good choise (main system a linux one ) but don't wanna remember old times ...
                        Last edited by AndreAPL; 11-01-2008, 05:51 PM.

                        Comment

                        Working...
                        X