Announcement

Collapse
No announcement yet.

This is laughable

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • This is laughable

    When I updated to 8.9, everything broke. ETQW didn't work anymore, and even aticonfig broken up (aticonfig --lsp told me I had no POWERplay...).

    Ok, I thought, they just need more time. So I went back to 8.8.

    Now 8.10 is out, it's even worse. aticonfig is still broken, performance is about 50% of 8.8 and nothing works right when it comes to 3D.

    Whatever AMD is doing, it's not working on the fglrx driver. I wonder how they managed to get so much crap into this release...

    For those few who might be using my APower utility for power setting on laptop cards, don't update past 8.8. You won't be able to set power modes (not my fault).
    Last edited by Almindor; 10-16-2008, 05:30 AM.

  • #2
    OTOH, 8.9 was the first release where ETQW completely worked for me, and 8.10 works fine as well

    You do know about the 3 concurrent fglrx development versions, right? Regressions shouldn't happen, but sometimes they do. If 8.8 works for you, the "next" version really would be 8.11, you just have to wait 3 months for it...

    Comment


    • #3
      Originally posted by grantek View Post
      OTOH, 8.9 was the first release where ETQW completely worked for me...
      same here

      (oh, I need 10 cahracters. Here they are.)

      Comment


      • #4
        Originally posted by Almindor View Post
        performance is about 50% of 8.8 and nothing works right when it comes to 3D.
        Which card? Does glxinfo | grep direct say yes?

        I haven't noticed any major regressions on my HD3850 AGP (yet), in fact the Unigine demos have got a good FPS boost with 8-10, maybe etqw aswell.

        On the downside Tropics still dies after a while and mipmaps in compiz don't work.
        Since 8-9 (I think) there is now a problem with the timedemos in the Quake 3 demo, where the fps randomly falls off alot with repeated runs.

        Edit one thing to check if ETQW stops working is that seta r_useIndexBuffers is "1" in your ~/.etqw/base/etqwconfig.cfg
        Last edited by legume; 10-16-2008, 11:05 AM.

        Comment


        • #5
          ATI Mobility Radeon X1600 on x86_64 linux and yes the driver is used for 3d and reported as such by fglrxinfo.

          It's a friggin disgrace.

          NOTE: ETQW crashes with 8.7 (IIRC), has artefacts in 8.8 and is outright unplayable in 8.9+.

          Comment


          • #6
            i think phoronix has become ati customer care.

            Comment


            • #7
              haha! thank god i'm enjoying thank 2 open drivers 4 my x1800.. no more fglrx pains

              Comment


              • #8
                You don't get GL 1.4+ support with OSS drivers ATM. I need it for school projects and whatnot (especially GLSL).

                Comment


                • #9
                  Originally posted by cruiseoveride View Post
                  i think phoronix has become ati customer care.
                  I lol'd <10characterlimitbreak>

                  Comment

                  Working...
                  X