Announcement

Collapse
No announcement yet.

ATI Catalyst 8.10 Driver

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    Another thing you can do is to just install the 8.10 version from amd's website and then copy the files in the x740 directory into the appropriate locations.

    Comment


    • #12
      I'm having better luck with this release. My plan was to stick with a more proven kernel, usually I went with whatever is latest. I stuck with a more proven kernel 2.6.26.x and I am having better luck with fglrx than I have before. I don't know if this release is actually better or if it's just because I'm sticking with the old kernel. More proven old version of Fedora as well, 8, rolled a kernel with the deprecated calls stuff and installed this driver manually (GPL hacks needed). No segfaults so far, of course I've probably jinxed it by saying that. Hope not. My problem wasn't performance for quite a few releases now, it was that segfaults made it useless, brought the whole system down at times. My advice is to forget about bleeding edge kernels and Xorg if you're going to try using this driver, maybe that is the key.

      Comment


      • #13
        Originally posted by Kano View Post
        a) remove all old arch common x* dirs completely
        b) create a new common dir, put etc lib opt usr from 8.543 in there the rest just copy to extracted 8-10 dir
        c) rename x740 to x710 and x740_64a to x710_64a
        d) now you can execute

        ./ati-installer.sh 8.542 --install
        Thanks, following the first 2 steps I created an archive ati-driver-installer-8-10b-x86.x86_64.tar.gz that can be installed with an ebuild. It compiles fine with 2.6.27 kernels without patching and works ok with xorg-server-1.5. The only problem I have is that now amdcccle segfaults.

        The diff for the ebuild:
        Code:
        --- /usr/portage/x11-drivers/ati-drivers/ati-drivers-8.532.ebuild	2008-09-30 01:24:49.000000000 +0200
        +++ ati-drivers-8.543.ebuild	2008-10-16 21:23:02.000000000 +0200
        @@ -9,7 +9,7 @@
         DESCRIPTION="Ati precompiled drivers for recent chipsets"
         HOMEPAGE="http://www.ati.com"
         ATI_URL="https://a248.e.akamai.net/f/674/9206/0/www2.ati.com/drivers/linux/"
        -SRC_URI="${ATI_URL}/ati-driver-installer-8-9-x86.x86_64.run"
        +SRC_URI="${ATI_URL}/ati-driver-installer-8-10b-x86.x86_64.tar.gz"
         
         LICENSE="AMD GPL-2 QPL-1.0 as-is"
         KEYWORDS="~amd64 ~x86"
        @@ -114,7 +114,7 @@
         	fi
         
         	# Only support xorg-server >=1.1
        -	BASE_DIR="${S}/x710"
        +	BASE_DIR="${S}/x740"
         
         	# This is used like $(get_libdir) for paths in ati's package.
         	if use amd64 ; then
        @@ -130,8 +130,7 @@
         src_unpack() {
         	#Switching to a standard way to extract the files since otherwise no signature file
         	#would be created
        -	local src="${DISTDIR}/${A}"
        -	sh "${src}" --extract "${S}"  2&>1 /dev/null
        +	unpack "${A}"
         
         	# These are the userspace utilities that we also have source for.
         	# We rebuild these later.
        @@ -160,7 +159,7 @@
         			|| die "Replacing 'finger' with 'who' failed."
         		# Adjust paths in the script from /usr/X11R6/bin/ to /opt/bin/ and
         		# add funktion to detect default state.
        -		epatch "${FILESDIR}"/8.532/ati-powermode-opt-path-2.patch
        +		epatch "${FILESDIR}"/8.543/ati-powermode-opt-path-2.patch
         	fi
         
         	pushd ${MODULE_DIR} >/dev/null

        Comment


        • #14
          Originally posted by Kano View Post
          For Xserver 1.5 packages on other systems then Ubuntu you can try this hack
          Thought so - it's a shame AMD couldn't release it this way, but hopefully all the other distros that package binary drivers can set it up for 1.5 as well. I hope the reason AMD didn't flick the "enable" switch isn't too serious though...

          Comment


          • #15
            Did anyone get the 8.10 release working with kernel 2.6.27 yet? I tried both the old, working 8.9 patch with addapted lines as well as a diff of the ubuntu firegl_public.c to the original one. Both with same result sadly - a black screen after running X. Ctrl+Alt+Backspace doesn't quit the X server, Ctrl+Alt+Delete results in a clean shutdown though. The X logfile didn't ring anything for me. You can check the Xorg.0.log here. Anyone been successful yet or got a clue?

            Comment


            • #16
              Hey this is the first time something like that happens!!
              It reminds me something very older when a driver from the old codebase used to display a watermark with AMD's logo at the lower right corner of the screen(I think so..) and AMD took the driver back after 1-2 days and gave out a new with the problem fixed! But this was not that serious!!

              Guys from AMD please do the same for this thing cause 8.10 driver from the website doesn't offer us anything new actually except for me that I don't have to disable my onboard HD 3200 chip everytime I boot into openSUSE cause screen used to remain black with 8.9 but still my on board 3200 is not a candidate for a Crossfire chain so still not usable!
              -XvMC enabled but not usable...
              -I still use 7.3 Xorg (xserver 1.4.0) although all the other Xorg packages are of 7.4 version from Xorg:X11 repo of suse 11(except for driver-input package cause otherwise mouse and keyboard don't work)
              -I just noticed that Anisotropic Filtering at AMDCCCLE reached x16 level but without HD 3200's support my HD 3450 cannot handle these levels easily...

              So nothing new that it is vitaly usable!

              You must replace it with Canonical's driver version even if it is in beta stage!!
              Last edited by djdoo; 10-16-2008, 08:29 PM.

              Comment


              • #17
                Well I tried Xine with XvMC (xxmc xine driver) and it is showing a correct menu at the settings after loading and also it is playing video!! DVD checked.
                In the past, I mean 8.9 and earlier, xxmc Xine driver could not be load at all...

                Seems that Mplayer is not usable! (Which I don't care too much about)

                Check Xine guys it might be a good surprise!

                Comment


                • #18
                  I just love these threads! they just remind me how shitty AMD and their drivers are! I LOVE YOU AMD I NEVER GET BORED WITH YOU.

                  Comment


                  • #19
                    It was to good to be true sadly...
                    Video plays and after going down all DVD menus the playback starts and stops after a few moments freezing xine.

                    But try it! It might work better for you...

                    Comment


                    • #20
                      Originally posted by djdoo View Post
                      Check Xine guys it might be a good surprise!
                      I checked Kaffeine with xine engine and it still freezes the system with XV output. It can play video for several seconds but hangs anyway. And the picture gets screwed up when I stop or pause playback. With xshm it works fine.

                      Comment

                      Working...
                      X