Announcement

Collapse
No announcement yet.

Fedora 7 Test 1 + AMD fglrx Drivers

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    See: http://www.michaellarabel.com/index.php?k=blog&i=35

    Packaged them all up nicely.
    Michael Larabel
    http://www.michaellarabel.com/

    Comment


    • #17
      Originally posted by Michael View Post
      See: http://www.michaellarabel.com/index.php?k=blog&i=35

      Packaged them all up nicely.
      Michael,

      Got the script. Almost working. The dri issues is still there. Here is the output:
      Code:
      ...
      error: Installed (but unpackaged) file(s) found:
         /usr/lib/dri/atiogl_a_dri.so
      
      
      RPM build errors:
          Installed (but unpackaged) file(s) found:
         /usr/lib/dri/atiogl_a_dri.so
      somewhere it is being called.

      Let me know what I can do next.

      Thanks!
      Partha

      www.partha.com

      Comment


      • #18
        Replying to myself ,,,,

        Maybe this will help...

        Code:
        extracting debug info from /tmp/ATI-fglrx-8.33.6-1-7815-root/tmp/ATI-fglrx-8.33.6-1.-root-root/usr/lib/dri/atiogl_a_dri.so
        ..
        Also, I am now using the latest kernel 2919.

        Thanks,
        Partha

        www.partha.com

        Comment


        • #19
          Try now. It seems one of the lines for the x86_64 packages got removed. Just re-run the script so it redownloads the new scripts off michaellarabel.com
          Michael Larabel
          http://www.michaellarabel.com/

          Comment


          • #20
            Originally posted by Michael View Post
            Try now. It seems one of the lines for the x86_64 packages got removed. Just re-run the script so it redownloads the new scripts off michaellarabel.com
            OK - That worked.

            Looks like I have 3d acceleration and fgl_grears seems to give numbers similar to FC6. I am going to test this driver out. Maybe install Xgl. i will start a new column on my site about this testing.

            Anything in particular you want me to test?

            Thanks for everything!!

            Partha

            www.partha.com

            Comment


            • #21
              Well just getting it to install and up and running is most of the battle... Now that it's taken care of, just making sure everything functions right.
              Michael Larabel
              http://www.michaellarabel.com/

              Comment


              • #22
                Originally posted by Michael View Post
                Well just getting it to install and up and running is most of the battle... Now that it's taken care of, just making sure everything functions right.


                The new script works fine for me also -- everything now installs fine and I'll be testing things with kernel 2.6.20.2622 and 2.6.19.2619.

                Thanks for getting this to be reality.

                Pabloa

                Comment


                • #23
                  2632 seems to be broken. I am now getting a blank screen.

                  Partha

                  www.partha.com

                  Comment


                  • #24
                    Can you post your Xorg.0.log?
                    Michael Larabel
                    http://www.michaellarabel.com/

                    Comment


                    • #25
                      Michael,

                      My apologies. I meant to say that 2932 was broken as in kernel 2.6.20-1.2932.fc7. The previous kernel 2922 is fine. Anyway it is the same old sympton, The system stops after initializing DRI. According to the Fedora-test-list, what we have in this kernel is:

                      kernel-2.6.20-1.2932.fc7
                      ------------------------
                      * Wed Feb 14 2007 Adam Jackson <ajax redhat com>
                      - nouveau drm

                      ------------------------

                      Anyway, here is the Xorg.0.log file from that boot.

                      Thanks,
                      Partha

                      www.partha.com

                      Comment


                      • #26
                        I can't seem to post the Xorg.0.log file. I keep getting a not-acceptable php thing back.

                        Comment


                        • #27
                          Originally posted by partha View Post
                          Michael,

                          My apologies. I meant to say that 2932 was broken as in kernel 2.6.20-1.2932.fc7. The previous kernel 2922 is fine. Anyway it is the same old sympton, The system stops after initializing DRI. According to the Fedora-test-list, what we have in this kernel is:

                          kernel-2.6.20-1.2932.fc7
                          ------------------------
                          * Wed Feb 14 2007 Adam Jackson <ajax redhat com>
                          - nouveau drm

                          ------------------------

                          Anyway, here is the Xorg.0.log file from that boot.

                          Thanks,
                          Partha

                          www.partha.com
                          Update:

                          Perhaps this post from Bill Nottingham might explain this?

                          https://www.redhat.com/archives/fedo.../msg00492.html

                          Thanks,
                          Partha

                          www.partha.com

                          Comment


                          • #28
                            So your DRI problems went away? The drivers continue to work for me when I last updated Rawhide a couple days back.

                            The 8.34 drivers this month contain my F7 fixes, and next month 8.35 will contain additional changes.
                            Michael Larabel
                            http://www.michaellarabel.com/

                            Comment


                            • #29
                              Originally posted by Michael View Post
                              So your DRI problems went away? The drivers continue to work for me when I last updated Rawhide a couple days back.

                              The 8.34 drivers this month contain my F7 fixes, and next month 8.35 will contain additional changes.
                              No, The new kernel is broken for me. I get a blank screen instead of the logon screen. The problem is similar to the one that plagued the 200M for a long time.

                              I tried posting the Xorg.0.log, but I kept getting and error. I will see if I can post it piecemeal.

                              Thanks,
                              Partha

                              www.partha.com

                              Comment


                              • #30
                                X Window System Version 7.2.0
                                Release Date: 24 December 2006
                                X Protocol Version 11, Revision 0, Release 7.2
                                Build Operating System: Fedora Core 7 Red Hat, Inc.
                                Current Operating System: Linux localhost 2.6.20-1.2932.fc7 #1 SMP Thu Feb 15 10:45:46 EST 2007 x86_64
                                Build Date: 04 February 2007
                                Build ID: xorg-x11-server 1.2.0-5.fc7
                                Before reporting problems, check http://wiki.x.org
                                to make sure that you have the latest version.
                                Module Loader present
                                Markers: (--) probed, (**) from config file, (==) default setting,
                                (++) from command line, (!!) notice, (II) informational,
                                (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
                                (==) Log file: "/var/log/Xorg.0.log", Time: Sat Feb 17 17:26:45 2007
                                (==) Using config file: "/etc/X11/xorg.conf"
                                (==) ServerLayout "Default Layout"
                                (**) |-->Screen "aticonfig-Screen[0]" (0)
                                (**) | |-->Monitor "aticonfig-Monitor[0]"
                                (**) | |-->Device "aticonfig-Device[0]"
                                (**) |-->Input Device "Keyboard0"
                                (**) |-->Input Device "Synaptics"
                                (II) No default mouse found, adding one
                                (**) |-->Input Device "<default pointer>"
                                (==) FontPath set to:
                                unix/:7100,
                                built-ins
                                (==) RgbPath set to "/usr/share/X11/rgb"
                                (==) ModulePath set to "/usr/lib64/xorg/modules"
                                (**) Extension "Composite" is disabled
                                (II) Open ACPI successful (/var/run/acpid.socket)
                                (II) Loader magic: 0x79f680
                                (II) Module ABI versions:
                                X.Org ANSI C Emulation: 0.3
                                X.Org Video Driver: 1.0
                                X.Org XInput driver : 0.6
                                X.Org Server Extension : 0.3
                                X.Org Font Renderer : 0.5
                                (II) Loader running on linux
                                (II) LoadModule: "pcidata"
                                (II) Loading /usr/lib64/xorg/modules//libpcidata.so
                                (II) Module pcidata: vendor="X.Org Foundation"
                                compiled for 7.2.0, module version = 1.0.0
                                ABI class: X.Org Video Driver, version 1.0
                                (++) using VT number 7
                                (II) PCI: PCI scan (all values are in hex)
                                (II) PCI: 00:00:0: chip 1002,5950 card 103c,309b rev 01 class 06,00,00 hdr 00
                                (II) PCI: 00:01:0: chip 1002,5a3f card 0000,0000 rev 00 class 06,04,00 hdr 01
                                (II) PCI: 00:04:0: chip 1002,5a36 card 0000,0000 rev 00 class 06,04,00 hdr 01
                                (II) PCI: 00:13:0: chip 1002,4374 card 1002,4374 rev 00 class 0c,03,10 hdr 80
                                (II) PCI: 00:13:1: chip 1002,4375 card 1002,4375 rev 00 class 0c,03,10 hdr 00
                                (II) PCI: 00:13:2: chip 1002,4373 card 1002,4373 rev 00 class 0c,03,20 hdr 00
                                (II) PCI: 00:14:0: chip 1002,4372 card 103c,309b rev 11 class 0c,05,00 hdr 80
                                (II) PCI: 00:14:1: chip 1002,4376 card 103c,309b rev 00 class 01,01,8a hdr 00
                                (II) PCI: 00:14:3: chip 1002,4377 card 0000,0000 rev 00 class 06,01,00 hdr 80
                                (II) PCI: 00:14:4: chip 1002,4371 card 0000,0000 rev 00 class 06,04,01 hdr 81
                                (II) PCI: 00:14:5: chip 1002,4370 card 103c,309b rev 02 class 04,01,00 hdr 80
                                (II) PCI: 00:14:6: chip 1002,4378 card 103c,309b rev 02 class 07,03,00 hdr 80
                                (II) PCI: 00:18:0: chip 1022,1100 card 0000,0000 rev 00 class 06,00,00 hdr 80
                                (II) PCI: 00:18:1: chip 1022,1101 card 0000,0000 rev 00 class 06,00,00 hdr 80
                                (II) PCI: 00:18:2: chip 1022,1102 card 0000,0000 rev 00 class 06,00,00 hdr 80
                                (II) PCI: 00:18:3: chip 1022,1103 card 0000,0000 rev 00 class 06,00,00 hdr 80
                                (II) PCI: 01:05:0: chip 1002,5955 card 103c,309b rev 00 class 03,00,00 hdr 00
                                (II) PCI: 06:02:0: chip 14e4,4318 card 103c,1355 rev 02 class 02,80,00 hdr 00
                                (II) PCI: 06:04:0: chip 104c,8031 card a400,0000 rev 00 class 06,07,00 hdr 82
                                (II) PCI: 06:04:2: chip 104c,8032 card 103c,309b rev 00 class 0c,00,10 hdr 80
                                (II) PCI: 06:04:3: chip 104c,8033 card 103c,309b rev 00 class 01,80,00 hdr 80
                                (II) PCI: 06:04:4: chip 104c,8034 card 103c,309b rev 00 class 08,05,00 hdr 80
                                (II) PCI: 06:06:0: chip 10ec,8139 card 103c,309b rev 10 class 02,00,00 hdr 00
                                (II) PCI: End of PCI scan

                                Comment

                                Working...
                                X