Announcement

Collapse
No announcement yet.

AMD Catalyst 8.9 Gets WINE Fix, RandR 1.2 Support

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    While it's great to see such a large bugfix list, it's sad to see that new problems have been introduced, or that they haven't been solved completely. For example, when I started reading the article, I was like 'This is it! This is the driver release that will end all problems!', and then I get bummed by 3D corruption on the Unigine Tropics engine :/ Why is having normal 3D acceleration too hard?

    Comment


    • #32
      Still Tearing?

      Is xv output (eg with mythtv) still tearing? While the changelog is impressive I won't be able to ditch my nvidia card until I can get tear-free output on mythtv.

      Comment


      • #33
        while everybody complains about small missing features :P
        I do complain about a bad regression that segfaults my Xorg on start-up.

        It already happened with Catalyst 8.7...

        Code:
        [...snip...]
        (II) fglrx(0): Direct rendering enabled
        (II) fglrx(0): Interrupt handler installed at IRQ 16.
        (II) fglrx(0): Exposed events to the /proc interface
        (II) fglrx(0): Finished Initialize PPLIB!
        (II) fglrx(1): === [atiddxPreInit] === begin
        (EE) fglrx(1): Quitting secondary screen -- no monitor specified.
        (EE) fglrx(1): PreInit failed
        (II) fglrx(1): === [atiddxPreInit] === end
        
        Backtrace:
        0: /usr/bin/X(xf86SigHandler+0x6a) [0x49263a]
        1: /lib/libc.so.6 [0x7f9e61f5dda0]
        2: /usr/lib64/xorg/modules/drivers//fglrx_drv.so(atiddxFreeScreen+0x2f4) [0x7f9e5fcfa434]
        3: /usr/bin/X(xf86DeleteScreen+0x7e) [0x4a5ade]
        4: /usr/bin/X(InitOutput+0xa1f) [0x46c0bf]
        5: /usr/bin/X(main+0x2c6) [0x437256]
        6: /lib/libc.so.6(__libc_start_main+0xe6) [0x7f9e61f491d6]
        7: /usr/bin/X(FontFileCompleteXLFD+0x289) [0x4366f9]
        
        Fatal server error:
        Caught signal 11.  Server aborting
        exactly the same backtrace!! (info about my architecture are in that thread, too)
        http://www.phoronix.com/forums/showthread.php?t=11570


        and other people experienced it too:
        http://www.phoronix.com/forums/showthread.php?t=11794
        with other chipsets...


        Catalyst 8.8 and 8.6 didn't suffer for the hang.
        There may be a workaround?

        Comment


        • #34
          Its funny that WINE fixes are supposed to be an important feature of this release, but there is no mention of WINE in the release notes.

          Comment


          • #35
            That driver is fully crap for several reasons:

            a) Using Debian etch + Xorg 7.1.1

            OpenGL accelleration only works as root! The xorg.conf entry

            Section "DRI"
            Mode 0666
            EndSection

            Seems to be fully ignored. Absolutely unusable!

            b) Absolutely no rendering improvements - even as root pointsprites are missing

            Hey mtippet didn't you tell me at the end of JUNE that after 2 month all would work - like gl2benchmark and your example with flightgear?

            c) Not even the most trivial fixes for 2.6.27 support - load the kernel module only smp_call_function must be fixed - for 2.6.27 and newer the 3rd option has to be removed, wow thats really hard that you can not make it.

            Maybe AMD/ATI wants to wins the worst driver of the year award with that piece of shit. I guess the Linux devs there play at home with Nvidia cards in their pcs.

            Comment


            • #36
              Originally posted by Kano View Post
              That driver is fully crap for several reasons:

              a) Using Debian etch + Xorg 7.1.1

              OpenGL accelleration only works as root! The xorg.conf entry

              Section "DRI"
              Mode 0666
              EndSection

              Seems to be fully ignored. Absolutely unusable!

              b) Absolutely no rendering improvements - even as root pointsprites are missing

              Hey mtippet didn't you tell me at the end of JUNE that after 2 month all would work - like gl2benchmark and your example with flightgear?

              c) Not even the most trivial fixes for 2.6.27 support - load the kernel module only smp_call_function must be fixed - for 2.6.27 and newer the 3rd option has to be removed, wow thats really hard that you can not make it.

              Maybe AMD/ATI wants to wins the worst driver of the year award with that piece of shit. I guess the Linux devs there play at home with Nvidia cards in their pcs.
              well thats one hell of a great post...
              why don't you try to rant a little bit less and at least tell us what gpu you are using...

              Comment


              • #37
                Having tested it a bit further now (esp. regarding Wine), I noticed that (apart from the usual screen corruption) virtual desktop switching works again and Wine doesn't segfault anymore when started twice on the same terminal.

                By the way, @Michael: the official spelling is Wine, not WINE.

                Comment


                • #38
                  I couldn't get this driver to work: a few seconds after X started, it would (soft) crash. It's the first time a driver didn't work here and no amount of tinkering could get it in shape, so I'm back to 8.8 for now.

                  RV580 (X1950 Pro) on Ubuntu 8.04 x86_64 with 6GB of memory.

                  At least 8.8 works quite well, so it's not a problem. Looking forward to Ubuntu 8.10 with the open-source drivers now - already tested and they work flawlessly here!

                  Comment


                  • #39
                    Works fine, here (Ubuntu 8.04) with my HD 3870.

                    But, I'm not doing anything interesting.

                    Comment


                    • #40
                      Well now "OffscreenRenderingMode fbo" works in wine again, so no stuff thats not supposed to on the screen appears in the bottom left, but I cant minimize or switch desktop anymore . I can interact with the desktop ( e.g. open something in the taskbar ) , but i cant see anything . It flickers for a second where i see the desktop , then wine's all over the place again .

                      ( debian lenny , mobility x700 )
                      Last edited by flami; 09-18-2008, 11:36 AM.

                      Comment


                      • #41
                        @Pfanne

                        The errors I describe are independent of the GPU used. The PointSprites are missing since driver release 8.41.7, that's nothing new, I mentioned that 13 month ago already. And when the only change from one driver to the next is a extremely bad new error then you would not get angry, right? I am responsible for lots of ATI users who use Kanotix and I create patches for ATI drivers on my own if possible. But if the base is so bad then this is completely lost time. If a huge company can not even fix issues introduced over a year ago they lost completely. But to make you happy: the card i used is X700 Pro (RV410) chipset - one of the chipsets with the worst open source driver experience!

                        Comment


                        • #42
                          Originally posted by Kano View Post
                          That driver is fully crap for several reasons:

                          a) Using Debian etch + Xorg 7.1.1

                          OpenGL accelleration only works as root! The xorg.conf entry

                          Section "DRI"
                          Mode 0666
                          EndSection

                          Seems to be fully ignored. Absolutely unusable!
                          Check your permissions on /dev/dri/card0

                          Comment


                          • #43
                            Good idea to check this:

                            ls -l /dev/dri/card0
                            crw-r----- 1 root root 226, 0 2008-09-18 18:01 /dev/dri/card0

                            Comment


                            • #44
                              hum I got another nice "feature" ^^:
                              flikering lines on the top right part of my screen when I run anything that involves 3d

                              Im going back 8.8 , Ill be back soon (tm)

                              Comment


                              • #45
                                AGP?

                                Anyone try this driver with the AGP 3850 card yet? I haven't had success since the 8.05 driver? I'm on Hardy Heron. If I get a chance I'll try it in the next day or 2.

                                Comment

                                Working...
                                X