Announcement

Collapse
No announcement yet.

Ati driver Working no Display in Bash

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Ati driver Working no Display in Bash

    Hi
    I've got Sapphire Radeon x800se and my LCD Screen is Nec Multisync 20WGX2.
    The newes drivers from Ati are installed and working fine in X11. But when I am trying to go into bash mode the screen goes all black and there is no response from the computer. I have plugged in both cables DVI and VGA, so i can watch the startup messages. Is there anything i can do? Can't log of KDE and change user.

    Atsjo

  • #2
    Does it work from GRUB if you specify run-level 3 or if you edit your /etc/inittab ?
    Michael Larabel
    http://www.michaellarabel.com/

    Comment


    • #3
      Thanks

      This is my inittab
      I can see all the letters when the computer starts up. But when i try to leave X11 the screen says there is no input. will add my xorg.conf just to be safe or it may be of use.
      Wow really fast respond thanks.


      #
      # /etc/inittab
      #
      # Copyright (c) 1996-2002 SuSE Linux AG, Nuernberg, Germany. All rights reserved.
      #
      # Author: Florian La Roche, 1996
      # Please send feedback to http://www.suse.de/feedback
      #
      # This is the main configuration file of /sbin/init, which
      # is executed by the kernel on startup. It describes what
      # scripts are used for the different run-levels.
      #
      # All scripts for runlevel changes are in /etc/init.d/.
      #
      # This file may be modified by SuSEconfig unless CHECK_INITTAB
      # in /etc/sysconfig/suseconfig is set to "no"
      #

      # The default runlevel is defined here
      id:5:initdefault:

      # First script to be executed, if not booting in emergency (-b) mode
      si::bootwait:/etc/init.d/boot

      # /etc/init.d/rc takes care of runlevel handling
      #
      # runlevel 0 is System halt (Do not use this for initdefault!)
      # runlevel 1 is Single user mode
      # runlevel 2 is Local multiuser without remote network (e.g. NFS)
      # runlevel 3 is Full multiuser with network
      # runlevel 4 is Not used
      # runlevel 5 is Full multiuser with network and xdm
      # runlevel 6 is System reboot (Do not use this for initdefault!)
      #
      l0:0:wait:/etc/init.d/rc 0
      l1:1:wait:/etc/init.d/rc 1
      l2:2:wait:/etc/init.d/rc 2
      l3:3:wait:/etc/init.d/rc 3
      #l4:4:wait:/etc/init.d/rc 4
      l5:5:wait:/etc/init.d/rc 5
      l6:6:wait:/etc/init.d/rc 6

      # what to do in single-user mode
      ls:S:wait:/etc/init.d/rc S
      ~~:S:respawn:/sbin/sulogin

      # what to do when CTRL-ALT-DEL is pressed
      ca::ctrlaltdel:/sbin/shutdown -r -t 4 now

      # special keyboard request (Alt-UpArrow)
      # look into the kbd-0.90 docs for this
      kb::kbrequest:/bin/echo "Keyboard Request -- edit /etc/inittab to let this work."

      # what to do when power fails/returns
      pf:owerwait:/etc/init.d/powerfail start
      pn:owerfailnow:/etc/init.d/powerfail now
      #pn:owerfail:/etc/init.d/powerfail now
      po:owerokwait:/etc/init.d/powerfail stop

      # for ARGO UPS
      sh:12345owerfail:/sbin/shutdown -h now THE POWER IS FAILING

      # getty-programs for the normal runlevels
      # <id>:<runlevels>:<action>:<process>
      # The "id" field MUST be the same as the last
      # characters of the device (after "tty").
      1:2345:respawn:/sbin/mingetty --noclear tty1
      2:2345:respawn:/sbin/mingetty tty2
      3:2345:respawn:/sbin/mingetty tty3
      4:2345:respawn:/sbin/mingetty tty4
      5:2345:respawn:/sbin/mingetty tty5
      6:2345:respawn:/sbin/mingetty tty6
      #
      #S0:12345:respawn:/sbin/agetty -L 9600 ttyS0 vt102
      #cons:1235:respawn:/sbin/smart_agetty -L 38400 console

      #
      # Note: Do not use tty7 in runlevel 3, this virtual line
      # is occupied by the programm xdm.
      #

      # This is for the package xdmsc, after installing and
      # and configuration you should remove the comment character
      # from the following line:
      #7:3:respawn:+/etc/init.d/rx tty7


      # modem getty.
      # mo:235:respawn:/usr/sbin/mgetty -s 38400 modem

      # fax getty (hylafax)
      # mo:35:respawn:/usr/lib/fax/faxgetty /dev/modem

      # vbox (voice box) getty
      # I6:35:respawn:/usr/sbin/vboxgetty -d /dev/ttyI6
      # I7:35:respawn:/usr/sbin/vboxgetty -d /dev/ttyI7

      # end of /etc/inittab


      Here is my Xorg.conf


      # /.../
      # SaX generated X11 config file
      # Created on: 2007-01-31T16:43:10+0100.
      #
      # Version: 8.1
      # Contact: Marcus Schaefer <sax@suse.de>, 2005
      # Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
      #
      # Automatically generated by [ISaX] (8.1)
      # PLEASE DO NOT EDIT THIS FILE!
      #

      Section "ServerLayout"
      Identifier "Layout[all]"
      Screen 0 "aticonfig-Screen[0]" 0 0
      InputDevice "Keyboard[0]" "CoreKeyboard"
      InputDevice "Mouse[1]" "CorePointer"
      Option "Clone" "off"
      Option "Xinerama" "off"
      EndSection

      Section "Files"
      InputDevices "/dev/gpmdata"
      InputDevices "/dev/input/mice"
      FontPath "/usr/share/fonts/misc:unscaled"
      FontPath "/usr/share/fonts/local"
      FontPath "/usr/share/fonts/75dpi:unscaled"
      FontPath "/usr/share/fonts/100dpi:unscaled"
      FontPath "/usr/share/fonts/Type1"
      FontPath "/usr/share/fonts/URW"
      FontPath "/usr/share/fonts/Speedo"
      FontPath "/usr/share/fonts/PEX"
      FontPath "/usr/share/fonts/cyrillic"
      FontPath "/usr/share/fonts/latin2/misc:unscaled"
      FontPath "/usr/share/fonts/latin2/75dpi:unscaled"
      FontPath "/usr/share/fonts/latin2/100dpi:unscaled"
      FontPath "/usr/share/fonts/latin2/Type1"
      FontPath "/usr/share/fonts/latin7/75dpi:unscaled"
      FontPath "/usr/share/fonts/baekmuk:unscaled"
      FontPath "/usr/share/fonts/japanese:unscaled"
      FontPath "/usr/share/fonts/kwintv"
      FontPath "/usr/share/fonts/truetype"
      FontPath "/usr/share/fonts/uni:unscaled"
      FontPath "/usr/share/fonts/CID"
      FontPath "/usr/share/fonts/ucs/misc:unscaled"
      FontPath "/usr/share/fonts/ucs/75dpi:unscaled"
      FontPath "/usr/share/fonts/ucs/100dpi:unscaled"
      FontPath "/usr/share/fonts/hellas/misc:unscaled"
      FontPath "/usr/share/fonts/hellas/75dpi:unscaled"
      FontPath "/usr/share/fonts/hellas/100dpi:unscaled"
      FontPath "/usr/share/fonts/hellas/Type1"
      FontPath "/usr/share/fonts/misc/sgi:unscaled"
      FontPath "/usr/share/fonts/xtest"
      FontPath "/opt/kde3/share/fonts"
      FontPath "unix/:7100"
      EndSection

      Section "Module"
      Load "freetype"
      Load "dbe"
      Load "type1"
      Load "v4l"
      Load "glx"
      Load "extmod"
      EndSection

      Section "ServerFlags"
      Option "AllowMouseOpenFail" "on"
      EndSection

      Section "InputDevice"
      Identifier "Keyboard[0]"
      Driver "kbd"
      Option "Protocol" "Standard"
      Option "XkbLayout" "no"
      Option "XkbModel" "pc104"
      Option "XkbRules" "xfree86"
      EndSection

      Section "InputDevice"
      Identifier "Mouse[1]"
      Driver "mouse"
      Option "Buttons" "11"
      Option "Device" "/dev/input/mice"
      Option "Name" "Microsoft Wireless Optical Desktop?? 2.10"
      Option "Protocol" "explorerps/2"
      Option "Vendor" "Sysp"
      Option "ZAxisMapping" "4 5"
      EndSection

      Section "Modes"
      Identifier "Modes[0]"
      ModeLine "1600x1024" 138.8 1600 1704 1872 2144 1024 1025 1028 1061
      ModeLine "1600x1000" 135.5 1600 1704 1872 2144 1000 1001 1004 1036
      ModeLine "1280x1024" 110.8 1280 1360 1496 1712 1024 1025 1028 1061
      ModeLine "1440x900" 109.2 1440 1528 1680 1920 900 901 904 932
      ModeLine "1280x960" 103.8 1280 1360 1496 1712 960 961 964 994
      ModeLine "1366x768" 87.4 1368 1440 1584 1800 768 769 772 796
      ModeLine "1280x800" 85.0 1280 1344 1480 1680 800 801 804 829
      ModeLine "1152x864" 83.0 1152 1216 1336 1520 864 865 868 895
      ModeLine "1280x768" 81.6 1280 1344 1480 1680 768 769 772 796
      ModeLine "1024x768" 65.3 1024 1080 1184 1344 768 769 772 796
      ModeLine "1280x600" 62.5 1280 1336 1464 1648 600 601 604 622
      ModeLine "1024x600" 49.8 1024 1064 1168 1312 600 601 604 622
      ModeLine "800x600" 38.9 800 832 912 1024 600 601 604 622
      ModeLine "768x576" 35.5 768 792 872 976 576 577 580 597
      ModeLine "640x480" 24.3 640 656 720 800 480 481 484 498
      ModeLine "1680x1050" 147.1 1680 1784 1968 2256 1050 1051 1054 1087
      ModeLine "1400x1050" 122.6 1400 1488 1640 1880 1050 1051 1054 1087
      ModeLine "1680x1050" 147.1 1680 1784 1968 2256 1050 1051 1054 1087
      EndSection

      Section "Monitor"
      Identifier "Monitor[0]"
      VendorName "--> LCD"
      ModelName "1680X1050@60HZ"
      UseModes "Modes[0]"
      DisplaySize 305 230
      HorizSync 30.0 - 66.0
      VertRefresh 30.0 - 61.0
      Option "DPMS"
      EndSection

      Section "Monitor"
      Identifier "aticonfig-Monitor[0]"
      Option "VendorName" "ATI Proprietary Driver"
      Option "ModelName" "Generic Autodetecting Monitor"
      Option "DPMS" "true"
      EndSection

      Section "Device"
      Identifier "Device[0]"
      Driver "radeon"
      VendorName "ATI"
      BoardName "Radeon X800SE (R423) UK (PCIE)"
      BusID "1:0:0"
      EndSection

      Section "Device"
      Identifier "aticonfig-Device[0]"
      Driver "fglrx"
      EndSection

      Section "Screen"
      Identifier "Screen[0]"
      Device "Device[0]"
      Monitor "Monitor[0]"
      DefaultDepth 24
      SubSection "Display"
      Depth 15
      Modes "1680x1050" "1600x1024" "1600x1000" "1400x1050" "1280x1024" "1440x900" "1280x960" "1366x768" "1280x800" "1152x864" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
      EndSubSection
      SubSection "Display"
      Depth 16
      Modes "1680x1050" "1600x1024" "1600x1000" "1400x1050" "1280x1024" "1440x900" "1280x960" "1366x768" "1280x800" "1152x864" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
      EndSubSection
      SubSection "Display"
      Depth 24
      Modes "1680x1050" "1600x1024" "1600x1000" "1400x1050" "1280x1024" "1440x900" "1280x960" "1366x768" "1280x800" "1152x864" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
      EndSubSection
      SubSection "Display"
      Depth 32
      Modes "1600x1024" "1600x1000" "1280x1024" "1440x900" "1280x960" "1366x768" "1280x800" "1152x864" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
      EndSubSection
      SubSection "Display"
      Depth 8
      Modes "1680x1050" "1600x1024" "1600x1000" "1400x1050" "1280x1024" "1440x900" "1280x960" "1366x768" "1280x800" "1152x864" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
      EndSubSection
      EndSection

      Section "Screen"
      Identifier "aticonfig-Screen[0]"
      Device "aticonfig-Device[0]"
      Monitor "aticonfig-Monitor[0]"
      DefaultDepth 24
      SubSection "Display"
      Viewport 0 0
      Depth 24
      EndSubSection
      EndSection

      Section "DRI"
      Group "video"
      Mode 0660
      EndSection

      Comment


      • #4
        Well i tried to post a reply but it didn't show up. Hmm will write it again. Thanks for the quick reply.
        Atsjo

        Comment


        • #5
          Originally posted by Michael View Post
          Does it work from GRUB if you specify run-level 3 or if you edit your /etc/inittab ?
          Sorry Michael i can't post my settings for you to see.
          I don't know what i should look for in the inittab file. Tried to add some sequences from my old xorg.conf into the new but the x11 server crashed.
          Can't post long files, my posts get deleted.

          Comment


          • #6
            id:5:initdefault:

            change to

            id:3:initdefault:

            Then when you restart/start the computer you will be in runlevel 3/the mode you seem to be after. Edit it back to 5 to return to graphics by default.
            Michael Larabel
            http://www.michaellarabel.com/

            Comment


            • #7
              Thanks

              Found it and where to add it, but how do I make sure that i can shut down x11 and don't have to restart my computer to see whats going on.
              Sorry if i am being needy. Thanks for the help.
              Atsjo

              Comment


              • #8
                as root: init 3

                then CTRL ALT F3

                should be all that's normally done...
                Michael Larabel
                http://www.michaellarabel.com/

                Comment


                • #9
                  din't help

                  Hello changed the value to 3. Started X11 manually afterwards and tried to shut it down again. Computer freezes, my screen goes black. There is no output on the dvi or the vga, is there anyway to force the graphic card to use vga in bash and dvi in x11?

                  Comment

                  Working...
                  X