Announcement

Collapse
No announcement yet.

fglrx DPMS or standby control?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • fglrx DPMS or standby control?

    I'm using the proprietary fglrx drivers on an FC6 host with ATI x1300.

    I don't seem to have any control over whether or not the driver puts my displays into standby mode.

    In /etc/X11/xorg.conf, in the "Monitor" section, I've tried all of the following:
    Option "DPMS"
    Option "DPMS" "false"
    Option "DPMS" "true"

    The driver seems to recognize this option. In /var/log/Xorg.0.log, I see:
    (**) fglrx(0): Option "DPMS" "true"
    (II) fglrx(0): DPMS capabilities: StandBy Suspend Off; RGB/Color Display
    (II) fglrx(0): DPMS capabilities: StandBy Suspend Off; RGB/Color Display
    (**) fglrx(0): DPMS enabled

    However, whether I give the option false, true or no arguments, doesn't seem to affect whether or not the card puts the monitors into standby mode.

    Further, entries like the following seem to have no effect on the timeout:
    Option "StandbyTime" "60"

    Finally, I'm running KDE, and control panel is unable to override standby, suspend or power off timeouts, because, according to the tool "Your display does not support power saving."

    I'm using the proprietary ATI driver, version 8.33.6, x86_64.

    Host is a Dell Optiplex 745.
    O/S is FC6 w/ xen kernel v. 2.6.19-1.2895.
    Displays are dual Dell 2007FP lcd's. Saw the same behavior with LCD's from another vendor, so don't believe it is specific to the displays.

    thanks.

  • #2
    Does it work if you try:

    /usr/bin/xset -dpms

    ?
    Michael Larabel
    http://www.michaellarabel.com/

    Comment


    • #3
      % /usr/bin/xset -dpms
      server does not have extension for -dpms option

      Comment


      • #4
        I should clarify my original post. The graphics device is putting my monitors into standby mode. The trouble is that I don't seem to have any control to change the duration or to disable standby.

        Currently, the monitors go into standby mode, regardless of what I put in xorg.conf, after 10-15 minutes.

        Comment


        • #5
          A little additional info...

          % aticonfig --lsp
          Error: POWERplay is not supported on your hardware.

          Comment


          • #6
            No PowerPlay with the X1300? That isn't right unless you modified the Video BIOS.
            Michael Larabel
            http://www.michaellarabel.com/

            Comment


            • #7
              Haven't modified the video bios.

              System is a relatively new Dell Optiplex 745, with the ATI X1300 installed at the factory.


              Is it true that Powerplay is not supported when utilizing a dual-head setup?

              Couldn't find anything to that effect in the official ATI linux release notes.

              However, found the following in a Kubuntu laptop setup article, of all places:
              http://cartemere.online.fr/info/v6v/...buntu6.06.html
              "Powerplay is not supported in dual head configuration"

              ?

              Comment


              • #8
                hmmm that could be the case. PowerPlay may be disabled in a multi-head environment. Forgot about that
                Michael Larabel
                http://www.michaellarabel.com/

                Comment


                • #9
                  Originally posted by Michael View Post
                  hmmm that could be the case. PowerPlay may be disabled in a multi-head environment. Forgot about that

                  If PowerPlay is disabled, but the screen still blanks after ten minutes and goes into standby after 30, where should I be looking to override, if possible?

                  In other words, is it the card, the driver, the X server or something else acting on these timeouts?

                  thanks,
                  -pat

                  Comment

                  Working...
                  X