Announcement

Collapse
No announcement yet.

Catalyt & resolution (modeline not recognized)

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Catalyt & resolution (modeline not recognized)

    Hello all!

    I still have some minor problems with my Radeon HD4870. I finally managed to set the resolution to 1152x864 at 100Hz in Xfce using the Display Settings (or Catalyst Control Center). However, the log-in screen still is set at a much higher resolution, making it a pain for the eyes.

    With my nVidia card I simply have to add a modeline in xorg.conf to set the right resolution. But the Catalyst driver ignores modelines.

    On my search in the net I found some hints suggesting to delete a certain file where the ATi driver stores all settings so that it finally makes use of the xorg.conf settings. But I can't remember anymore which file this is.

    So my question is, how can I fix the above resolution for the whole system? How can I make Catalyst finally use xorg.conf settings/modelines?

  • #2
    IIRC fglrx does *not* support modelines. So even removing /etc/ati/amdpcsdb will not help either.

    Comment


    • #3
      Crap!

      Thanks for your help though, ivanovic.

      Comment


      • #4
        Originally posted by Janusz11 View Post
        Hello all!
        With my nVidia card I simply have to add a modeline in xorg.conf to set the right resolution. But the Catalyst driver ignores modelines.
        I can get fglrx to pick up a modeline I made like this -
        Code:
        .....
        
        Section "Monitor"
                Identifier   "aticonfig-Monitor[0]"
                Option      "VendorName" "ATI Proprietary Driver"
                Option      "ModelName" "Generic Autodetecting Monitor"
                Option      "DPMS" "true"
                UseModes        "HD1920"
        EndSection
        
        Section "Modes"
                Identifier "HD1920"
                # 1920x1440 @ 50.00 Hz (GTF) hsync: 74.10 kHz; pclk: 192.07 MHz
                Modeline "1920x1440_50.00"  192.07  1920 2048 2256 2592  1440 1441 1444 1482  -HSync +Vsync
        EndSection
        
        Section "Screen"
                Identifier "aticonfig-Screen[0]"
                Device     "aticonfig-Device[0]"
                Monitor    "aticonfig-Monitor[0]"
                DefaultDepth     24
                SubSection "Display"
                        Viewport   0 0
                        Depth     24
                        Modes   "1920x1440_50.00"
                EndSubSection
        EndSection

        Comment


        • #5
          Thanks legume.

          Tried it but it doesn't change anything at all. Thanks anyway.

          Comment


          • #6
            I really think ATI should fix that resolution hell once for all. I think I may have spent at least 15 hours in the last year trying different xorg.conf tags, messing with amdpcsdb and amdccc.

            3 days ago I upgraded to Hardy/kde4. fglrx was working great in big desktop with my samsung 1680x1050 screen at home. Then I booted with my LG 1680x1050 at work and never was able to go further than 1280x1024. A problem I haven't had since they supposedly fixed that resolution bug since 8.3 or something.

            SCREEN RESOLUTION is a BLOCKING feature if you can't use it, it should be on the top off regression tests list.

            fglrx seems to act almost randomly on that issue, sometimes it accepts to go beyond VESA resolutions, somtimes it doesn't.

            I really tried everything, Virtual, Mode2, Modeline, and finaly went back to radeon/xrandr tried xrandr --output VGA-0 --left-of LVDS
            and it worked!
            Not even had to restart X!
            end of story

            I don't want to just complain and ruin ATI dev's moral, it is great they're investing in Linux development, but I think they should build a more solid basis before adding fancy features such as anti-aliasing

            Comment


            • #7
              Originally posted by legume View Post
              Code:
              Section "Modes"
                      Identifier "HD1920"
                      Modeline "1920x1440_50.00"  192.07  1920 2048 2256 2592  1440 1441 1444 1482  -HSync +Vsync
              EndSection
              Many thanks, that convinced fglrx to use first monitor optimal.

              What is the trick for second monitor? Somewhere here:

              Code:
              Option	    "Mode2" "1280x960@75,1152x864,1024x768,800x600"
              ?

              Comment


              • #8
                I would also like to complain a bit about the lack of support for modelines and custom modes... this is a huge hole in fglrx and CCC at the moment, at least as far as I can tell.

                You should be able to force a specific output mode, so that attachment to devices that are non-standard will be feasible. That's a major issue with the driver in my opinion... I hope they address it!
                Last edited by Porter; 11-06-2008, 05:45 PM.

                Comment


                • #9
                  Originally posted by noiv View Post
                  Many thanks, that convinced fglrx to use first monitor optimal.

                  What is the trick for second monitor? Somewhere here:

                  Code:
                  Option	    "Mode2" "1280x960@75,1152x864,1024x768,800x600"
                  ?
                  I have never set up two monitors, but I think you will need to make separate screen,monitor and modes sections.

                  Device section and server layout also may need tweaking.

                  man xorg.conf has the info - it also looks like there is a way to just put modelines into the monitor section(s) and avoid using modes section(s) all together.

                  Comment


                  • #10
                    legume, fglrx does some VERY weird things for 2nd display. Unless they've changed things since I last used it, all settings for 2nd display go in the primary Device section using special options.

                    Comment

                    Working...
                    X