Announcement

Collapse
No announcement yet.

Videos tearing

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    I'm sorry but I don't understand what uvd and MC are.

    What projects are you talking about ?

    I don't think a P4 3.2 will quite do 1080 h264 (with a 2.1 GHz AMD I can only get 1/2 framerate on broadcast HD) it should be fine for 720.
    My CPU played 1080p fine when I had my nVIDIA card...

    Thanks
    Last edited by Guilo; 08-07-2008, 04:23 PM.

    Comment


    • #12
      Originally posted by Guilo View Post
      I'm sorry but I don't understand what uvd and MC are.

      What projects are you talking about ?



      My CPU played 1080p fine when I had my nVIDIA card...

      Thanks
      UVD is the unified video decoder that is built in to recent radeon cards. It can releive the CPU of alot of work -

      http://en.wikipedia.org/wiki/UVD

      MC is motion compensation - a part of decoding mpeg video.

      http://www.bitblit.org/gsoc/g3dvl/index.shtml

      Fair enough if you could play 1080p, though 1080p may not be a good way to describe how much work your processor needs to do. It depends on the bitrate of the video as well.

      Comment


      • #13
        Thanks for your explanations.

        The only 1080p movie I ever played was Big Buck Bunny and it was running fast when played with xv but quite slowly with gl

        Comment


        • #14
          Solution, at last

          Hi all !

          I just wanted to tell that I had found a solution while reading mplayer doc :

          (no)force−pbo

          Always uses PBOs to transfer textures even if this involves an extra copy. Currently this gives a little extra speed with NVidia drivers and a lot more speed with ATI drivers. May need −noslices and the ati−hack suboption to work correctly.
          so :

          mplayer -vo gl:force-pbo
          works great : no tearing and fast decoding.

          Hope it can help

          Comment


          • #15
            Originally posted by Guilo View Post
            Hi all !

            mplayer -vo gl:force-pbo

            works great : no tearing and fast decoding.
            Hope it can help
            Cool glad you found a solution.

            I tried it and using a recent mplayer couldn't get it to take the command without doing -

            mplayer -vo gl:ati-hack,force_pbo

            Unfortunately it still didn't stop ffmpeg h264 + -vo gl* eating pointless amounts of CPU in vo for me.

            Comment


            • #16
              I still have no video tearing, with -vo gl
              but the 1080p videos are too slow, even on a quadcore q9300

              that's really unacceptable to need to go on windows to watch videos
              Last edited by mirak63; 08-18-2008, 01:43 PM.

              Comment


              • #17
                this is still not fixed apparently

                and I get a screen corruption when going in windowed mode in opengl video output
                Last edited by mirak63; 08-21-2008, 05:04 AM.

                Comment


                • #18
                  legume
                  Try -vf scale option. It won't scale anything and should not convert color space either... Virtually it does nothing but CPU usage is much lower sometimes. Have no idea why.

                  Comment


                  • #19
                    Originally posted by vitalyb View Post
                    legume
                    Try -vf scale option. It won't scale anything and should not convert color space either... Virtually it does nothing but CPU usage is much lower sometimes. Have no idea why.
                    Thanks - I tried and it did fix usage for a small youtube mp4, but it doesn't change things for some bbc quicktime/264 demos I tried.

                    I know these particular demos were OK with gl on an older mplayer + old fglrx on my old card (X1600). I wonder which one of the three regressed.

                    Comment


                    • #20
                      legume
                      Setting large cache for Matroska definitely helps, not sure about mp4/qt, though. Try -cache 8192

                      Comment

                      Working...
                      X