Announcement

Collapse
No announcement yet.

Anti-Aliasing

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Anti-Aliasing

    Can someone point me to some documentation on how to configure anti-aliasing with the 8.7 Catalyst driver? I tried various greps on the installed documentation but wasn't able to find anything that looked pertinent.

    The X log says that the FSAAEnable option is not used and aticonfig doesn't recognize --fsaa as an option. There is an anti-aliasing section in amdcccle but all of the controls are inactive.

    So it looks like amdcccle is the tool I need to use but that maybe something in my setup doesn't allow anti-aliasing to be configured.

    Here is some system info...

    fglrxinfo
    Code:
       display: :0.0  screen: 0
       OpenGL vendor string: ATI Technologies Inc.
       OpenGL renderer string: ATI Mobility Radeon X1600
       OpenGL version string: 2.1.7769 Release
    some glxinfo
    Code:
       name of display: :0.0
       display: :0  screen: 0
       direct rendering: Yes
       server glx vendor string: SGI
       server glx version string: 1.2
       server glx extensions:
          GLX_ARB_multisample, GLX_EXT_import_context, GLX_EXT_texture_from_pixmap,
          GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_OML_swap_method,
          GLX_SGIS_multisample, GLX_SGIX_fbconfig, GLX_SGIX_visual_select_group
       client glx vendor string: SGI
       client glx version string: 1.4
    some xorg.conf
    Code:
       Section "dri"
          Group       "video"
          Mode        0666
       EndSection
    
       Section "Extensions"
          Option      "Composite"             "Enable"
          Option      "RENDER"                "Enable"
       EndSection
    
       Section "ServerFlags"
          Option      "RandR"                 "on"
          Option      "PM"                    "off"
       EndSection
    
       Section "Device"
          Identifier  "Radeon X1600"
          Driver      "fglrx"
          Option      "no_accel"              "no"
          Option      "no_dri"                "no"
          Option      "FSAAEnable"            "yes"
       EndSection

    Any help is appreciated.
    John

  • #2
    Isn't AA normally turned on in the application ?

    Comment


    • #3
      So the CCC does not let you set AA options? That's weird. Make sure you check the "override application setting" to be able to set AA options. AA is handled in the amdpcsbd file (/etc/ati/amdpcsdb), so editing it should force AA.

      Code:
      AntiAliasSamples=V4  # 4xAA

      Comment


      • #4
        The only application I have is Neverwinter Nights and the in-game AA slider doesn't seem to do anything.

        I seem to remember setting system-wide overrides for AA, but that was a while ago and I might be confusing it with something else.

        Comment


        • #5
          I never looked

          All I know is that (a) the trend seems to be having games controll AA/AF rather than forcing via the driver / control panel, and (b) for the limited amount of gaming I have time for I always set it in-game.

          EDIT -- and obviously I haven't played NWN...

          Comment


          • #6
            Originally posted by Melcar
            AA is handled in the amdpcsbd file (/etc/ati/amdpcsdb), so editing it should force AA.

            Code:
            AntiAliasSamples=V4  # 4xAA

            Thanks for such quick help on this. Editting /etc/ati/amdpcsdb directly worked. Here's my new OpenGL section:
            Code:
            [AMDPCSROOT/SYSTEM/OpenGL]
            FSAAEnable=V1
            AntiAliasSamples=V4
            VSyncControl=V1
            CatalystAI=V2

            Originally posted by Melcar
            So the CCC does not let you set AA options? That's weird. Make sure you check the "override application setting" to be able to set AA options.
            For what it's worth, the "override application setting" checkbox is inactive in CCC as well as all of the anisotropic settings.

            Could you post the anisotropic options for amdpscdb so I can try them out?

            Comment


            • #7
              AF should be:

              Code:
              AnisoDegree=V16   #16xAF

              Comment


              • #8
                Sorry for resurrecting this, but I'm suffering from the same problem. I can't get anti-aliasing to work in Ubuntu Karmic running 9.12 Catalyst drivers, no matter what. Settings changed from the Catalyst Control Panel somehow don't get applied to games (Urban Terror or Savage 2, for instance). I have tried editing the file mentioned above to no avail.

                Relevant hardware info:

                780G chipset motherboard (with HD3200 integrated graphics card).

                I've googled around for hours without finding the solution. Please help me to at least shed some light on the issue. Thanks.

                Comment


                • #9
                  Originally posted by pdr1 View Post
                  Sorry for resurrecting this, but I'm suffering from the same problem. I can't get anti-aliasing to work in Ubuntu Karmic running 9.12 Catalyst drivers, no matter what. Settings changed from the Catalyst Control Panel somehow don't get applied to games (Urban Terror or Savage 2, for instance). I have tried editing the file mentioned above to no avail.

                  Relevant hardware info:

                  780G chipset motherboard (with HD3200 integrated graphics card).

                  I've googled around for hours without finding the solution. Please help me to at least shed some light on the issue. Thanks.
                  I've had the same problem with World of Warcraft since I bought my 4850. Every couple of months I'll try messing with it again with no success. I upgraded my motherboard/processor/ram halfway through which had no effect and have reinstalled the OS several times since I started with no effect. So far I've tried various combinations of:

                  - blowing away all the fglrx and WoW config files
                  - upgrading to the latest fglrx
                  - setting AA in the game
                  - forcing AA in amdcccle
                  - manually setting things in /etc/ati/amdpcsdb

                  Some settings will cause screen corruption and some will just result in the game playing normally with no AA applied. Some will result in a fps decrease and others don't. I haven't noticed any error messages, and WoW *thinks* there are settings for 1,2,4,6, and 8x AA available (none of which do anything at all).

                  I'd be willing to give another crack at it if anyone has any ideas regarding what to test next. Is there any way to turn on some kind of driver logging?

                  Comment


                  • #10
                    There are some OpenGL paths that cannot be antialiased without explicit application support. Never played WoW, but try looking for (and disabling) any option that mentions HDR, bloom and/or FBOs (framebuffer objects). Enabling AA in-game may also help here.

                    Comment


                    • #11
                      Hi Blackstar,

                      Good thoughts, but unfortunately I think that is probably not the problem. WoW afaik doesn't use bloom or HDR. Also, the nvidia drivers under linux/windows can force AA and the ATI drivers can as well under windows. Enabling AA in the game "works" under linux (as in the game thinks it is being set), but no AA is actually applied.

                      Have you been able to get AA to work with fglrx? What I'm seeing sounds almost exactly like what phoronix saw when they were testing AA with their test suite here:

                      http://www.phoronix.com/scan.php?pag...x_lenvik&num=2

                      Comment


                      • #12
                        Hi Blackstar,

                        Good thoughts, but unfortunately I think that is probably not the problem. WoW afaik doesn't use bloom or HDR. Also, the nvidia drivers under linux/windows can force AA and the ATI drivers can as well under windows. Enabling AA in the game "works" under linux (as in the game thinks it is being set), but no AA is actually applied.

                        Have you been able to get AA to work with fglrx? What I'm seeing sounds similar to what phoronix saw in their test suite (but without the image artifacts):

                        http://www.phoronix.com/scan.php?pag...x_lenvik&num=2

                        Comment


                        • #13
                          I am using the 9.12 hotfix drivers on a 4850 and AA works fine here, either through CCC or through the application. I've been working with OpenGL3/fglrx since 9.3 and I cannot recall any issues with AA not working.

                          Comment


                          • #14
                            Well, if you're using WINE, AA with fglrx does not work in many cases. With native games it works fine though (Nexuiz, Alien Arena, etc.).

                            Comment


                            • #15
                              Finally stumbled upon other people having these AA issues as well. Last autumn I made a thread at the official ATI forums about this issue. It wasn't a surprise I didn't really get any answers.

                              My AA settings worked fine with my HD 4670 last summer when I bought the card. Nexuiz had AA and Wine games had AA. Then, as time passed and something got updated (I guess), AA stopped working in full screen but it did work windowed (or the other way around, can't even remember anymore). Then, at some point AA stopped working completely. This was somewhere around Catalyst 9.8 I think. Haven't had any luck since. Just today I upgraded to Catalyst 10.1.

                              The settings in amdpcsdb file get changed as I change them from CCC, but they don't have any effect. Xorg.conf has been the same all around, I'm using a manually configured one and it worked last summer.

                              Comment

                              Working...
                              X