Announcement

Collapse
No announcement yet.

Changing from fullscreen to Windowed in some games makes screen go crazy..

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Changing from fullscreen to Windowed in some games makes screen go crazy..

    Hi,
    I have an ATI X1650 Pro, with Catalyst 8.6 on Mandriva 2008 Spring.
    In some games, mainly Regnum Online, when I press Alt+Enter to change to Windowed mode, the screen goes crazy. I'm not sure how to describe it, but it looks like it's really messed up, two screens forced beside each other, and some wierd tiling effect. I will try to take a screenshot later.
    My xorg.conf:
    Code:
    # File generated by XFdrake (rev 234840)
    
    # **********************************************************************
    # Refer to the xorg.conf man page for details about the format of
    # this file.
    # **********************************************************************
    
    Section "ServerFlags"
        #DontZap # disable <Ctrl><Alt><BS> (server abort)
        AllowMouseOpenFail # allows the server to start up even if the mouse does not work
        #DontZoom # disable <Ctrl><Alt><KP_+>/<KP_-> (resolution switching)
    EndSection
    
    Section "Module"
        Load "dbe" # Double-Buffering Extension
        Load "v4l" # Video for Linux
        Load "extmod"
        Load "type1"
        Load "freetype"
        Load "glx" # 3D layer
        Load "dri" # direct rendering
    EndSection
    
    Section "InputDevice"
        Identifier "Keyboard1"
        Driver "kbd"
        Option "XkbModel" "pc105"
        Option "XkbLayout" "us,ara(digits)"
        Option "XkbOptions" "grp:alt_shift_toggle,grp_led:scroll,compose:rwin"
    EndSection
    
    Section "InputDevice"
        Identifier "Mouse1"
        Driver "mouse"
        Option "Protocol" "ExplorerPS/2"
        Option "Device" "/dev/mouse"
    EndSection
    
    Section "Monitor"
        Identifier "monitor1"
        VendorName "Generic"
        ModelName "1280x1024 @ 60 Hz"
        HorizSync 31.5-64.3
        VertRefresh 50-70
    EndSection
    
    Section "Device"
        Identifier "device1"
        VendorName "ATI Technologies Inc"
        BoardName "ATI Radeon X1300 and later"
        Driver "fglrx"
        BusID "PCI:1:0:0"
        Option "DPMS"
        Option "XAANoOffscreenPixmaps" "on" 
        Option "TexturedVideo" "on"
        Option "TexturedVideoSync" "on"
        Option "VideoOverlay" "off"
        Option "OpenGLOverlay" "off"
        Option "Textured2D" "on" 
        Option "TexturedXrender" "off"
    EndSection
    
    Section "Screen"
        Identifier "screen1"
        Device "device1"
        Monitor "monitor1"
        DefaultColorDepth 24
        
        Subsection "Display"
            Depth 8
            Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
        EndSubsection
        
        Subsection "Display"
            Depth 15
            Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
        EndSubsection
        
        Subsection "Display"
            Depth 16
            Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
        EndSubsection
        
        Subsection "Display"
            Depth 24
            Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
        EndSubsection
    EndSection
    
    Section "ServerLayout"
        Identifier "layout1"
        InputDevice "Keyboard1" "CoreKeyboard"
        InputDevice "Mouse1" "CorePointer"
        Option "AIGLX" "on"
        Screen "screen1"
    EndSection
    
    Section "Extensions"
        Option "DAMAGE" "Enable"
    #    Option "RENDER" "Enable"
        Option "Composite" "Enable"
    EndSection
    
    Section "DRI"
    Mode 0666
    EndSection
    Is there anything I can do to fix this?

    Thanks!

  • #2
    Option "Textured2D" "on"
    Maybe try turning Textured2D off ?

    Comment


    • #3
      I'm getting the same issue

      I start both my applications (Warcraft III and WoW) in fullscreen ( no switching ) and I get this dual-checkerbox display i.e. two copies of the same window side-by-side but sort of checkerboxed.

      I tried taking a screenshot (using scrot), but I actually got a normal image!!! i.e. what I would have seen if there was no issue.

      I don't have a digital camera handy or I would have taken a picture

      My xorg.conf

      Code:
      Section "ServerLayout"
      	Identifier     "Simple Layout"
      	Screen      0  "Screen 1" 0 0
      	InputDevice    "Mouse1" "CorePointer"
      	InputDevice    "Keyboard1" "CoreKeyboard"
      	Option	    "AIGLX" "true"
      EndSection
      
      Section "Files"
      	RgbPath      "/usr/share/X11/rgb"
      	FontPath     "/usr/share/fonts/misc"
      	FontPath     "/usr/share/fonts/100dpi:unscaled"
      	FontPath     "/usr/share/fonts/75dpi:unscaled"
      	FontPath     "/usr/share/fonts/TTF"
      	FontPath     "/usr/share/fonts/Type1"
      	FontPath     "/usr/share/fonts/local"
      EndSection
      
      Section "Module"
      	Load  "dbe"  	# Double buffer extension
      	SubSection "extmod"
      		Option	    "omit xfree86-dga"   # don't initialise the DGA extension
      	EndSubSection
      	Load  "freetype"
      	Load  "glx"
      	Load  "dri"
      EndSection
      
      Section "InputDevice"
      	Identifier  "Keyboard1"
      	Driver      "kbd"
      	Option	    "AutoRepeat" "500 30"
      	Option	    "XkbRules" "xorg"
      	Option	    "XkbModel" "pc105"
      	Option	    "XkbLayout" "us"
      EndSection
      
      Section "InputDevice"
      	Identifier  "Mouse1"
      	Driver      "mouse"
      	Option	    "Protocol" "Auto"	# Auto detect
      	Option	    "Device" "/dev/input/mice"
      	Option	    "ZAxisMapping" "4 5 6 7"
      EndSection
      
      Section "Monitor"
      	Identifier   "Syncmaster"
      	DisplaySize  270	203
      	VertRefresh  60.0 - 75.0
      	Option	    "DPMS" "true"
      EndSection
      
      Section "Device"
      	Identifier  "X1250"
      	Driver      "fglrx"
      	Option	    "UseFastTLS" "2"
      	BusID       "PCI:1:5:0"
      EndSection
      
      Section "Screen"
      	Identifier "Screen 1"
      	Device     "X1250"
      	Monitor    "Syncmaster"
      	DefaultDepth     24
      	SubSection "Display"
      		Viewport   0 0
      		Depth     24
      		Modes    "1024x768" "800x600" "640x480"
      	EndSubSection
      EndSection
      
      Section "DRI"
      	Mode         0666
      EndSection
      
      Section "Extensions"
      	Option	    "Composite" "true"
      EndSection
      Thanks in advance

      Comment


      • #4
        Originally posted by LordRaiden View Post
        I start both my applications (Warcraft III and WoW) in fullscreen ( no switching ) and I get this dual-checkerbox display i.e. two copies of the same window side-by-side but sort of checkerboxed.

        I tried taking a screenshot (using scrot), but I actually got a normal image!!! i.e. what I would have seen if there was no issue.

        I don't have a digital camera handy or I would have taken a picture

        My xorg.conf

        Code:
        Section "ServerLayout"
        	Identifier     "Simple Layout"
        	Screen      0  "Screen 1" 0 0
        	InputDevice    "Mouse1" "CorePointer"
        	InputDevice    "Keyboard1" "CoreKeyboard"
        	Option	    "AIGLX" "true"
        EndSection
        
        Section "Files"
        	RgbPath      "/usr/share/X11/rgb"
        	FontPath     "/usr/share/fonts/misc"
        	FontPath     "/usr/share/fonts/100dpi:unscaled"
        	FontPath     "/usr/share/fonts/75dpi:unscaled"
        	FontPath     "/usr/share/fonts/TTF"
        	FontPath     "/usr/share/fonts/Type1"
        	FontPath     "/usr/share/fonts/local"
        EndSection
        
        Section "Module"
        	Load  "dbe"  	# Double buffer extension
        	SubSection "extmod"
        		Option	    "omit xfree86-dga"   # don't initialise the DGA extension
        	EndSubSection
        	Load  "freetype"
        	Load  "glx"
        	Load  "dri"
        EndSection
        
        Section "InputDevice"
        	Identifier  "Keyboard1"
        	Driver      "kbd"
        	Option	    "AutoRepeat" "500 30"
        	Option	    "XkbRules" "xorg"
        	Option	    "XkbModel" "pc105"
        	Option	    "XkbLayout" "us"
        EndSection
        
        Section "InputDevice"
        	Identifier  "Mouse1"
        	Driver      "mouse"
        	Option	    "Protocol" "Auto"	# Auto detect
        	Option	    "Device" "/dev/input/mice"
        	Option	    "ZAxisMapping" "4 5 6 7"
        EndSection
        
        Section "Monitor"
        	Identifier   "Syncmaster"
        	DisplaySize  270	203
        	VertRefresh  60.0 - 75.0
        	Option	    "DPMS" "true"
        EndSection
        
        Section "Device"
        	Identifier  "X1250"
        	Driver      "fglrx"
        	Option	    "UseFastTLS" "2"
        	BusID       "PCI:1:5:0"
        EndSection
        
        Section "Screen"
        	Identifier "Screen 1"
        	Device     "X1250"
        	Monitor    "Syncmaster"
        	DefaultDepth     24
        	SubSection "Display"
        		Viewport   0 0
        		Depth     24
        		Modes    "1024x768" "800x600" "640x480"
        	EndSubSection
        EndSection
        
        Section "DRI"
        	Mode         0666
        EndSection
        
        Section "Extensions"
        	Option	    "Composite" "true"
        EndSection
        Thanks in advance
        Yeah that's exactly what I meant!

        Comment


        • #5
          Originally posted by bridgman View Post
          Maybe try turning Textured2D off ?
          Still same problem :/
          Also, this only happened to me with Catalyst 8.6, not before.

          Comment


          • #6
            I guess I've got the same problem. Happens when I use OpenGl as video-plugin in kaffeine (xine-backend) and switch from fullscreen to window. I took a picture:
            http://img365.imageshack.us/my.php?i...sc00064bm3.jpg

            Comment


            • #7
              Yeah, this has been happening to me since I got the new driver too.
              Whenever an application changes the screen resolution it happens. It forced me to load every application in windowed mode which is fine.
              Changing the resolution after doesn't help, but resetting x does.
              Heres a photo



              Other than that regression though, 8.6 for me is the best change yet, as some games actually work now!
              Last edited by poofyyoda; 06-28-2008, 05:55 AM.

              Comment


              • #8
                I just discovered that this does not happen when I set Option "UseFastTLS" "0" in my xorg.conf
                Edit: No wait, that's not what fixed it. Then it's fixed by upgrading to X Server 1.4.2, since that's the only other thing I've changed (I had previously downgraded to X Server 1.3.0 for testing purposes).
                Last edited by Zhick; 06-27-2008, 01:20 PM.

                Comment


                • #9
                  Hm... 1.4.2 is not what fixed it as well. When I today downgraded my X Server to 1.4.2 (previously Git + Radeon) and started using fglrx, the bug was there again...

                  Comment

                  Working...
                  X