Announcement

Collapse
No announcement yet.

Cannot make packages under 8.6 catalyst

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cannot make packages under 8.6 catalyst

    al@al-desktop:~$ sudo sh ati8.6.run --buildpkg Ubuntu/8.04
    Created directory fglrx-install.z16094
    Verifying archive integrity... All good.
    Uncompressing ATI Proprietary Linux Driver-8.501...
    ==================================================
    ATI Technologies Linux Driver Installer/Packager
    ==================================================
    Generating package: Ubuntu/8.04
    Resolving build dependencies...
    ./packages/Ubuntu/ati-packager.sh: 347: sh -c '/usr/sbin/synaptic --set-selections --non-interactive --hide-main-window < /tmp/fileYw8zr3': not found
    Unable to resolve cannot read packages/Ubuntu/dists/8.04/control. Please manually install and try again.


    what i should do??

  • #2
    try:

    --buildpkg Ubuntu/hardy
    Michael Larabel
    http://www.michaellarabel.com/

    Comment


    • #3
      no , but this helps apt-get install build-essential
      at install get pack of problems
      trying EnvyNG
      ahh still safe mode after install fglrx 64bit NO 3D ANYMORE
      (blank screen and delete russian keyboard from xorg)
      (i test 8.3,8.4,8.5,8.6)
      Radeon x800,X2900XT,X3870x2 - IS BEST _2D_ CARD Accelerator on 64bit
      (((((((((((((((((
      Driver still shitty, unable to installing himself.
      Last edited by dj--alex; 06-20-2008, 01:17 AM.

      Comment


      • #4
        This script even supports kernel 2.6.26:

        http://kanotix.com/files/install-fglrx-debian.sh

        Comment


        • #5
          after run scripts i got safe-mode and xorg conf down (lost russian keymap)
          Of course i restore last normal state (Without 3d,but 1280x1024+rus keymap)
          Vesa+Mesa=crap, no one game runs.
          And ATI drivers for 64 bit is full crap - no 3D present
          I lost >200 hours summary from month to install it and i get only catalyst, and no _3D_.
          Ati for 32bit is half-crap , runs only 1\2 of existed games.

          God help up...
          MAybe 1-5 years later, and i see _normal_ release driver from ATI\AMD
          I'm in weakness...Maybe buy S3 Virge DX 4Mb?
          Last edited by dj--alex; 06-20-2008, 07:18 AM.

          Comment


          • #6
            You can test 3d in live mode too.

            http://debian.tu-bs.de/project/kanot...-2-generic.iso
            http://debian.tu-bs.de/project/kanot...eneric.iso.md5

            Only 3d app preinstalled is gl2benchmark. This live system does not hurt your install, it seems you changed too much manually to let my script fully work. I guess I could fix your system with ssh access but I see no real reason to do so as you don't use Kanotix.

            Comment


            • #7
              Originally posted by Kano View Post
              You can test 3d in live mode too.

              http://debian.tu-bs.de/project/kanot...-2-generic.iso
              http://debian.tu-bs.de/project/kanot...eneric.iso.md5

              Only 3d app preinstalled is gl2benchmark. This live system does not hurt your install, it seems you changed too much manually to let my script fully work. I guess I could fix your system with ssh access but I see no real reason to do so as you don't use Kanotix.
              What is Kanotix? It's another Ubuntu 8 core files?

              Comment


              • #8
                I basically use Debian etch + losts of backports (but no newer KDE or GNOME) + latest kernels based on Ubuntu sources. This demonstration iso is not installable, but Thorhammer can be installed and the same kernel added.

                Comment


                • #9
                  Sorry,i read that 8.6 driver does not supported dual-head videocards like HD3870X2 ((
                  i ll be waiting support.

                  at this moment,i downgrade to 2900XT.

                  Comment


                  • #10
                    Code:
                    #!/bin/sh
                    # Well, you can force it when you add the pci id
                    
                    lspci -n|awk -F'[ :]' '/0300/{print "FGL_ASIC_ID(0x"toupper($6)"),"}' >> /lib/modules/fglrx/build_mod/fglrxko_pci_ids.h
                    
                    cd /lib/modules/fglrx/build_mod
                    ./make.sh
                    
                    cd /lib/modules/fglrx
                    ./make_install.sh
                    
                    #That change will allow you to still use your other card - but the pciid is #added to the new one. After that you add an override in your /etc/X11/xorg.conf
                    
                    perl -pi.backup -e 's/(Driver.*"fglrx".*\n)/\1\tChipID\t0x9501\n/' /etc/X11/xorg.conf
                    
                    #That should let the driver work - just with ATI unsupported hardware in one corner.

                    Comment

                    Working...
                    X