No announcement yet.

Need Help: Really want to get ATI drivers working on FC6

  • Filter
  • Time
  • Show
Clear All
new posts

  • Need Help: Really want to get ATI drivers working on FC6


    I am using a new install of Fedora Core 6, I would really appreciate a step by step walkthrough. I have used linux for a while but am still not sure of terms such as "make sure that the make package is installed".

    I have an ATI Radeon 9700, I used to be able to get the 3D accelleration working on Fedora Core 3 with an older version of the driver but have had no luck with FC6

    Also... If I have ATI Driver Installer.bin do i also need XFree86 4.3 Drivers or X.Org 6.8 Drivers installed aswell or is it all included in the installer

    If anyone can help I would really appreciate it.


    Karsten Pedersen

  • #2
    What graphics card are you using?

    All you should need to download is:

    Then run:

    ./ --buildpkg Fedora/FC6

    Then post the output. With so many different package combinations, it is just easier to see what is outputted when you try to build the packages (ideally it will just generate the RPMs right away).
    Michael Larabel


    • #3
      Im using a Radeon 9700...

      Because my Linux Box isn't connected to the internet i cant copy whole log but the installer log in /usr/share/ati/*.log say something along the lines of

      no kernel module build environment.

      Can I ask where I get this from... Is there a package on the fedora core 6 disks which i can install?

      Thanks so far for your help,


      • #4
        You can get the build environment if you select "Software Development" if you reinstall Fedora.
        Michael Larabel


        • #5
          (I reinstalled with the build environment)

          when i ran the installer i get this log


          [Message] Kernel Module : Trying to install a precompiled kernel module.
          [Message] Kernel Module : Precompiled kernel module version mismatched.
          [Message] Kernel Module : Found kernel module build environment, generating kernel module now.
          ATI module generator V 2.0
          patching 'highmem.h'...
          assuming new VMA API since we do have kernel 2.6.x...
          Assuming default VMAP API
          Assuming default munmap API
          doing Makefile based build for kernel 2.6.x and higher
          make -C /lib/modules/2.6.18-1.2798.fc6/build SUBDIRS=/lib/modules/fglrx/build_mod/2.6.x modules
          make[1]: Entering directory `/usr/src/kernels/2.6.18-1.2798.fc6-i586'
          CC [M] /lib/modules/fglrx/build_mod/2.6.x/firegl_public.o
          /lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:89:26: error: linux/config.h: No such file or directory
          /lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:456: warning: initialization from incompatible pointer type
          /lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function ‘firegl_stub_open’:
          /lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:579: warning: assignment discards qualifiers from pointer target type
          /lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function ‘__ke_smp_call_function’:
          /lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:4008: warning: passing argument 1 of ‘smp_call_function’ from incompatible pointer type
          make[2]: *** [/lib/modules/fglrx/build_mod/2.6.x/firegl_public.o] Error 1
          make[1]: *** [_module_/lib/modules/fglrx/build_mod/2.6.x] Error 2
          make[1]: Leaving directory `/usr/src/kernels/2.6.18-1.2798.fc6-i586'
          make: *** [kmod_build] Error 2
          build failed with return value 2
          [Error] Kernel Module : Failed to compile kernel module - please consult readme.

          When i create a package i get this output

          ATI Technologies Linux Driver Installer/Packager
          Generating package: Fedora/FC6
          ./packages/Fedora/ line 195: /etc/profile.d/ No such file or directory
          Removing temporary directory: fglrx-install
          Last edited by Karsten; 01-03-2007, 04:14 PM.


          • #6
            Install qt-devel

            yum install qt-devel
            Michael Larabel


            • #7
              Yep did so and it all gets made into some packages... (ATI said that qt was not required... but then again, they also said that their drivers worked )

              Ok I have then run these rpms which needed to install the dependency compatc++ Thats all good. It was still on MESA so i edited xorg.conf and typed in some extension composite disabled or some shit... now its all working great.

              Yay, UT2004 here i come !

              (is there any way for the yum to tell me the required dependency without going online? Coz i dont want to drag my other FC6 PC downstairs just to download some dependency which i already have on the damn disk lol)

              (How did u know I needed qt-devel and not some other QT package?)

              Anyways, thanks for all your support, you should start charging people

              All the best,


              • #8
                Basically I know the packages needed since I am the ATI fglrx Fedora package maintainer and have been using a Fedora/RHEL environment for years, so I can simply look at it and know what to do.
                Michael Larabel


                • #9

                  Hey, thats pretty cool.. Looks like I have come to the right place then.