Announcement

Collapse
No announcement yet.

black border

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #81
    My setup: Biostar TA790GX A2+ w/ on board HD 3300 connected to a Samsung HL-R5087W (older 50" DLP) via HDMI. Driver version 8.9. The TV supports 720p/1080i, no 1080p. My screen size is set to 1280x720 via the control center. The TV reports that it's receiving a 720p signal (found out what the info button does). I also had the black borders.

    Ran the aticonfig --set-pcs-val=MCIL,DigitalHDTVDefaultUnderscan,0 command. That fixed the black borders, but I lost part of the screen (overscan I assume by reading all these other posts).

    The TV supports different aspect ratios, zoom 1, zoom 2, panoramic, normal, 16:9, 4:3. However, when it detects an HD signal it only allows to select 16:9 or 4:3. I dug through all the menus, and couldn't find anything else to change the overscan.

    So, I ended up using the following settings to get the screen sized right.

    aticonfig --set-dispattrib=tmds2i,positionX:47
    aticonfig --set-dispattrib=tmds2i,positionY:18
    aticonfig --set-dispattrib=tmds2i,sizeX:1195
    aticonfig --set-dispattrib=tmds2i,sizeY:679

    I'm happy with this, and the wife comes back from a 2 week trip tonight so I need to be done messing with the production box. I just thought that I'd post my results in case anyone else is having problems with a Samsung DLP.

    By the way, in Myth I had set the resolution to 1279x720 to get a usable display.

    Comment


    • #82
      Hi,

      I have a AMD 780 based board (Gigabyte GA-MA78GM-S2H) as HTPC connected to an Panasonic TH42 PX80E (via HDMI).
      The box is running under Gentoo with Catalyst 8.10.
      X is running with 1280x720 @60 Hz, the TV recognises it as "720p". With Overscan turned off in the TV Menu, I get black borders around the screen (~ 3 cm).

      aticonfig --set-pcs-val=MCIL,DigitalHDTVDefaultUnderscan,0 didnt change anything.

      After running
      aticonfig --set-dispattrib=tmds2i,positionX:0
      aticonfig --set-dispattrib=tmds2i,positionY:0
      aticonfig --set-dispattrib=tmds2i,sizeX:1280
      aticonfig --set-dispattrib=tmds2i,sizeY:720
      the black borders are gone!

      The Problem occurs at the next Xorg start/restart: Xorg doesnt start any more, I get only a black screen! WTF ?!?

      aticonfig stored the position / size changes in /etc/ati/amdpcsdb.
      If I delete the changes made by aticonfig, Xorg starts again, but naturally the black borders are there again!

      I deleted /etc/ati/amdpcsdb to make sure that this is not a problem with legacy settings from older catalyst versions. After running aticonfig again, Xorg doesnt start. I didnt found any significant error message in the Xorg log.

      Does anybody know how
      x aticonfig can be prevented to store these settings in amdpcsdb?
      x or how could Xorg be persuaded to start in spite of these settings in amdpcsdb?

      Thanks,
      Dominik

      Comment


      • #83
        Matthew (mtippett) recommended a different use of aticonfig. I don't have time to search for it now but it was a single line rather than four position settings. I think that should be a more general solution.

        Comment


        • #84
          you mean
          aticonfig --set-pcs-val=MCIL,DigitalHDTVDefaultUnderscan,0
          I tried this first but it does not make any difference. Black borders are still there.

          Comment


          • #85
            Xorg log contains no error message, but ends with the following line.
            (II) fglrx(0): Largest offscreen area available: 1344 x 2401
            At this point, the xserver seems to die.

            /var/log/messages contains
            2008-10-29T21:25:37+01:00 hdvdr [fglrx] GART Table is not in FRAME_BUFFER range
            2008-10-29T21:25:37+01:00 hdvdr [fglrx] Reserved FB block: Shared offset:0, size:1000000
            2008-10-29T21:25:37+01:00 hdvdr [fglrx] Reserved FB block: Unshared offset:fffc000, size:4000
            2008-10-29T21:25:38+01:00 hdvdr kdm[11414]: X server for display :0 terminated unexpectedly
            2008-10-29T21:25:38+01:00 hdvdr kdm[11414]: Unable to fire up local display :0; disabling.

            Comment


            • #86
              I'm having the exact same problem as bofh. I set the X and Y position and size, which worked great. But now X won't start. There is a brief moment where the X cursor shows on screen, which is followed by some text. The text is complete garbage, and most of it appears to be memory addresses and such; I don't think its showing an error messages. I can't even get to a shell because X tries to start even when I'm in virtual terminals. I'm using the newest drivers available through Ubuntu 8.10 (8.543??). Any help would be greatly appeciated. I don't know much about any of this, but I was thinking a hackish way to fix it might be to create scripts to delete the settings on shutdown and have another to run after booting (I would image it would have to run after X loads). Is this viable or is there a better way? Thanks again.

              Edit: Never mind about deleting the config files; I've tried removing the persistant files from /etc/ati/amdpcsb (or whatever its called) and the same problem occurs.
              Last edited by jbrown96; 11-03-2008, 04:16 PM.

              Comment


              • #87
                Hi,

                I implemented a workaround:

                this script is executed at every kde start (put it in ~/.kde/Autostart):
                Code:
                #!/bin/bash
                
                logger -t vdr "kde_autostart fglrx-hdmi-fullscreen.sh"
                
                sudo aticonfig --set-dispattrib=tmds2i,positionX:0
                sudo aticonfig --set-dispattrib=tmds2i,positionY:0
                sudo aticonfig --set-dispattrib=tmds2i,sizeX:1280
                sudo aticonfig --set-dispattrib=tmds2i,sizeY:720
                
                sleep 5
                sudo /usr/local/bin/clean-amdpcsdb.sh
                it calls the second script as root, which cleans the amdpcsdb file:
                Code:
                #!/bin/bash
                
                sed  '/position[X|Y]=V0/d; /sizeX=V1280/d; /sizeY=V720/d; /\[AMDPCSROOT\/SYSTEM\/DDX\/tmds2i\/attribute\]/d' /etc/ati/amdpcsdb > /etc/ati/amdpcsdb.tmp
                mv /etc/ati/amdpcsdb.tmp /etc/ati/amdpcsdb
                Its a hack, but it works.

                Comment


                • #88
                  Originally posted by bofh View Post
                  Hi,

                  I implemented a workaround:

                  this script is executed at every kde start (put it in ~/.kde/Autostart):
                  Code:
                  #!/bin/bash
                  
                  logger -t vdr "kde_autostart fglrx-hdmi-fullscreen.sh"
                  
                  sudo aticonfig --set-dispattrib=tmds2i,positionX:0
                  sudo aticonfig --set-dispattrib=tmds2i,positionY:0
                  sudo aticonfig --set-dispattrib=tmds2i,sizeX:1280
                  sudo aticonfig --set-dispattrib=tmds2i,sizeY:720
                  
                  sleep 5
                  sudo /usr/local/bin/clean-amdpcsdb.sh
                  it calls the second script as root, which cleans the amdpcsdb file:
                  Code:
                  #!/bin/bash
                  
                  sed  '/position[X|Y]=V0/d; /sizeX=V1280/d; /sizeY=V720/d; /\[AMDPCSROOT\/SYSTEM\/DDX\/tmds2i\/attribute\]/d' /etc/ati/amdpcsdb > /etc/ati/amdpcsdb.tmp
                  mv /etc/ati/amdpcsdb.tmp /etc/ati/amdpcsdb
                  Its a hack, but it works.
                  nice script, but I can't get it to work. I'm using Ubuntu 8.10 (KDE4.1.2). I created the script in my autostart directory and called it graphics-resize. The second piece of text I saved as nice script, but I can't get it to work. I'm using Ubuntu 8.10 (KDE4.1.2). I created the script in my autostart directory and called it graphics-resize. The second piece of text I saved as nice script, but I can't get it to work. I'm using Ubuntu 8.10 (KDE4.1.2). I created the script in my autostart directory and called it graphics-resize. The second piece of text I saved as /usr/local/bin/clean-amdpcsdb.sh. Whenever I login, I get the following message
                  Klauncher could not be reached via D-Bus. Error when calling start_service_by_desktop_path: empty
                  Kate also opens with the autostart script. Any ideas to get this working??

                  Thanks

                  Comment


                  • #89
                    bash scripts in the kde autostart folder have to be executable and need the ending ".sh"

                    did you also configured root rights with visudo for aticonfig and clean-amdpcsdb.sh?

                    Comment


                    • #90
                      I copy good amdpcsdb when system start, because aticonfig write to amdpcsdb when fglrx starts and when closing. Simple script in init.d cp amdpcsdb from another location to /etc/ati.

                      Comment

                      Working...
                      X