Announcement

Collapse
No announcement yet.

black border

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #61
    Can you try commenting out most of the driver options in your conf file ? I'm thinking most about the "DesktopSetup" and "Mode2" options but I would be tempted to hack out pretty much everything.

    Comment


    • #62
      Originally posted by bridgman View Post
      Can you try commenting out most of the driver options in your conf file ? I'm thinking most about the "DesktopSetup" and "Mode2" options but I would be tempted to hack out pretty much everything.
      I'll try that as soon as I can. I've tried a lot of things with aticonfig and I might have messed up something.
      Thanks for the help.

      Edit:
      I've commented out almost everything in the device section and still no luck.
      here is my Xorg log and my xorg.conf
      http://pastebin.com/m7ea1a7f8
      http://pastebin.com/m4fefde7d
      Last edited by pepone; 07-04-2008, 02:55 PM.

      Comment


      • #63
        Great finally i can use my SHARP perfectly!!!

        Originally posted by mtippett View Post
        We asked some questions internally, it looks like a default setting for HDMI was changed in the common code. This has triggered a number of monitors to underscan.

        Note that this does not happen on all HDTV monitors, some actually need this setting to have a normal near-pixel perfect screen.

        To override this setting try setting this value and restarting X.

        aticonfig --set-pcs-val=MCIL,DigitalHDTVDefaultUnderscan,0

        To enable this functionality through the configuration tools it will not come for a number of releases, since this setting is quite deep under the covers and there are other issues that will need to be resolved to fix this fully.

        Please advise if this resolves this issue.
        This work perfect!!! thank you very much. I'm using Ati 8.7 Drivers with HD 3870 on Ubuntu Hardy.

        Comment


        • #64
          Finally got this working, only in 1920x1080

          These forums have been great. I got a gigabyte ga-ma78gm-s2h last week. Got the 8.8 drivers loaded, and had black borders. It took me two days to get rid of them. My TV is a Panasonic 42" 720p plasma, attached via hdmi. I was running in 1280x720 mode and none of the options posted here would make the borders go away. Turning off underscan did not work, at least not by itself. Adjusting the position and size had an effect, but still I could not get the borders to go away. However, changing my screen resolution to 1920x1080, and experimenting with the x and y size and position, with underscan off, I was able to make the borders go away. However, only in that resolution. If I change to any other resolution, the borders are back (and the screen isn't centered either). I noticed that when setting the resolution lower and using --query-dispattrib, the max size varied based on my resolution. So if I set the value of X to 1900 while in 1920x1080 mode, then switch to 1280x720 mode, the 'value' was reported as 1900, and the 'max' as 1280, which just seems wrong. I just wanted to post my experience here in case it can help somebody else. I'd also like to suggest that the size and position variables may need tweaking to either have multiple sets, so as to be assignable independently for each resolution, or if there is only one set, then it should always be relative to the native resolution of the monitor, rather than the current x-win resolution. I would love to be able to get this working at 720p resolution, since I can read text much better in a browser at that resolution on my TV. Also, though I haven't done any test to confirm this, I have to believe that my HTPC is wasting either CPU or GPU resources by upscaling video to 1080p, just so that my TV can scale in back down to 720p.

          Comment


          • #65
            Thanks!

            Originally posted by mtippett View Post
            We asked some questions internally, it looks like a default setting for HDMI was changed in the common code. This has triggered a number of monitors to underscan.

            Note that this does not happen on all HDTV monitors, some actually need this setting to have a normal near-pixel perfect screen.

            To override this setting try setting this value and restarting X.

            aticonfig --set-pcs-val=MCIL,DigitalHDTVDefaultUnderscan,0

            To enable this functionality through the configuration tools it will not come for a number of releases, since this setting is quite deep under the covers and there are other issues that will need to be resolved to fix this fully.

            Please advise if this resolves this issue.
            I was having the same issue on a HD 3850 outputting to a 1080p Panasonic Plasma via HDMI. This option fixed the black borders. Thanks!

            Comment


            • #66
              I'm having the same problem with black bars with my Radeon 9600 and a Sony 720p TV.

              Code:
              andy@andy-desktop:~$ cat updatescreen
              aticonfig --set-dispattrib=tmds1,positionX:0
              aticonfig --set-dispattrib=tmds1,positionY:0
              aticonfig --set-dispattrib=tmds1,sizeX:1216
              aticonfig --set-dispattrib=tmds1,sizeY:680
              
              andy@andy-desktop:~$ sudo ./updatescreen
               Try to Set positionX adjust of monitor tmds1 value : 0 failed.
               It may not supported by monitor or the value beyond the range.
               Try to Set positionY adjust of monitor tmds1 value : 0 failed.
               It may not supported by monitor or the value beyond the range.
               Try to Set sizeX adjust of monitor tmds1 value : 1216 failed.
               It may not supported by monitor or the value beyond the range.
               Try to Set sizeY adjust of monitor tmds1 value : 680 failed.
               It may not supported by monitor or the value beyond the range.
              andy@andy-desktop:~$
              And when I do:
              Code:
              aticonfig --query-dispattrib=tmds1
              Query monitors tmds1 ,Cap:0x0
              and nothing more. It seems like aticonfig is totally ignoring me.

              What am I doing wrong here? I also installed ATI Catalyst Control Center, and it doesn't show or give me an option to set 1216x680, the resolution I have set in XP. Here's a thread on another site:

              http://www.uluga.ubuntuforums.org/sh....php?p=5841181

              Any ideas???

              Andy-

              Comment


              • #67
                The commands provided by Matthew and others are intended for HDMI-connected displays which the driver recognizes as a "TV" rather than a "computer display", ie one where overscan is likely to be on by default.

                I don't think we have an HDMI connection option on ay 9600s, do we ? This is probably a different problem.

                Just curious, why 1216x680 rather than 1280x720 ?

                Comment


                • #68
                  Originally posted by bridgman View Post
                  The commands provided by Matthew and others are intended for HDMI-connected displays which the driver recognizes as a "TV" rather than a "computer display", ie one where overscan is likely to be on by default.

                  I don't think we have an HDMI connection option on ay 9600s, do we ? This is probably a different problem.
                  Aaah. Okay. That makes sense now as I'm using the DVI port with a DVI to HDMI cable.

                  Originally posted by bridgman View Post
                  Just curious, why 1216x680 rather than 1280x720 ?
                  I have no idea why, but if I give the TV 1280x720, it switches out of 720p and into 1080i with the image smushed and jittery in the top left. And, for some reason, 1216x680 fills the screen perfectly in Windows XP. I found it by trial & error on Windows.

                  Any ideas?

                  Andy-

                  Comment


                  • #69
                    How do I set an arbitrary resolution? My 720p screen is a bit wacky in that 1280x720 always overruns the screen (even under Windows XP).

                    I turned on the drivers that come with Ubuntu and I'm getting desktop effects and all that jazz. I'm using a Sony TV hooked up through the DVI port with a DVI to HDMI cable.

                    Code:
                    andy@andy-desktop:~$ fglrxinfo
                    display: :0.0  screen: 0
                    OpenGL vendor string: ATI Technologies Inc.
                    OpenGL renderer string: ATI RADEON 9600 Series
                    OpenGL version string: 2.1.7412 Release
                    
                    andy@andy-desktop:~$
                    But when I do 1280x720 the screen is too big--I have maybe a dozen pixels cut off on each side. If I resize down to 1152x648 it's too small and there's black bars around the screen. How do I either turn off the overscan (if that's what's happening here) or set an arbitrary resolution using aticonfig? Here's what happens when I try.

                    Code:
                    andy@andy-desktop:~$ aticonfig --resolution=0,1216x680
                    Error: Label is corrupted
                    error at set screen resolution : screen0 does not exist
                    aticonfig: parsing the command-line failed.
                    Andy-

                    Comment


                    • #70
                      The native res is often 1366x768, but if you try 1280x720 you might want to disable overscan in your tv settings.

                      Comment


                      • #71
                        Yep, this sounds like you have two separate problems :

                        - you have overscan turned on in the TV (just look for an option like "display all" or "display full" or "full screen" etc..

                        - your TV isn't liking the 720p timing

                        Lets try to fix the overscan first. That will be in the TV menus somewhere.

                        Comment


                        • #72
                          Originally posted by bridgman View Post
                          Yep, this sounds like you have two separate problems :

                          - you have overscan turned on in the TV (just look for an option like "display all" or "display full" or "full screen" etc..

                          - your TV isn't liking the 720p timing

                          Lets try to fix the overscan first. That will be in the TV menus somewhere.
                          TV options: There is no option for overscan on the TV. There are zoom options (zoom, wide zoom, normal), but it is in normal and has always been. If I zoom in, it crops much more. If there is no option like "full screen" (and I haven't found one), the way I fixed it under XP was to use the slightly lower resolution. Is there no way to have the fglrx drivers use an odd resolution?

                          On the 720p timing, perhaps that is the case... But why? How? I thought DVI/HDMI was digital? How would timing fit in? I don't understand how DVI/HDMI send video data--I know how frequencies and timings work on analog VGA, but not here...

                          I appreciate the assistance and expertise here. What information can I give to help diagnose what's going on?

                          Andy-

                          Comment


                          • #73
                            Originally posted by am7146 View Post
                            TV options: There is no option for overscan on the TV. There are zoom options (zoom, wide zoom, normal), but it is in normal and has always been. If I zoom in, it crops much more.
                            That's really wierd... I haven't seen that before on a digital HDTV.

                            Originally posted by am7146 View Post
                            If there is no option like "full screen" (and I haven't found one), the way I fixed it under XP was to use the slightly lower resolution. Is there no way to have the fglrx drivers use an odd resolution?
                            There may be but I'm not sure of the details, will ask.

                            Originally posted by am7146 View Post
                            On the 720p timing, perhaps that is the case... But why? How? I thought DVI/HDMI was digital? How would timing fit in? I don't understand how DVI/HDMI send video data--I know how frequencies and timings work on analog VGA, but not here...
                            Digital is not really that much different from analog. You still have H and V sync signals, and they still provide the reference timing for the video information -- it's just that (a) the video information itself is transmitted as a digital stream rather than an analog stream, (b) usually the display chooses its own scanning frequencies and digitally upscales/downscales the incoming data to match its native resolution. I think the sync signals are multiplexed onto one of the colours (blue ?) rather than having separate wires but that's no different from having "sync on green" with an analog display.

                            Originally posted by am7146 View Post
                            I appreciate the assistance and expertise here. What information can I give to help diagnose what's going on?
                            I'm not sure right now

                            What is the model number of your display ?

                            EDIT - never mind, found it in the Ubuntu thread. OK, it's a KLV-32M1 - 1366x768 native (that's a pretty common res for Sony). Seems to have some known problems running as a computer display and a couple of other users also suggested a lower than standard resolution. Maybe the manual will have some clues...

                            BTW we store persistent setting information in a file called amdpcsdb (AMD Persistent Configuration Store Data Base or something like that). The aticonfig command is the best way to manipulate it.

                            Also, from your error messages when running aticonfig I'm wondering if the tmds1 parameter was wrong, it varies from system to system. I think there is an aticonfig command to dump out information on connected displays, can you try to find that and paste the results ?
                            Last edited by bridgman; 09-26-2008, 05:31 PM.

                            Comment


                            • #74
                              According the the manual you should have four Screen options : Normal, Wide, Wide Zoom, and Full. You should be using Full. You're not supposed to be able to select Normal when the TV is receiving a 720p signal so I suspect you may be running 1280x720 monitor timing (which your TV probably won't accept) rather than 720p TV timing.

                              No idea if the driver can actually generate 720p TV timing with your card over DVI (I suspect we may only enable them over native HDMI connectors) but another thing to ask. The point here is that AFAIK the driver thinks you are driving a normal monitor via DVI connector so is using monitor timing (which your display is not designed to accept) rather than TV timing.

                              Comment


                              • #75
                                Black border with fglrx rendered modes.

                                Greetings,

                                I also get these black boarders. However; for me they only show up on what I will call "fglrx rendered modes" ie modes not native to my LCD-TV but created by fglrx thus adding additional modes to said tv. The TV is a sharp GP1U connected via DVI-D. I've tried all the commands, but they seem to be specific to the HDMI interface.

                                All "native" modes sync perfectly with no boarder. During "flgrx rendered modes" the TV syncs on the next largest "native" mode but leave 1/4" black boarder on screen. I've tried all the tv's scaling modes, none provide relief.

                                I greatly appreciate these additional modes as 1360x768 = to small 1920x1080 = to large 1440x900/1680x1050 = just right. I sit 4 - 6 feet from the tv. I realize these are not actually the correct aspect.

                                Any input would be appreciated.

                                MrMstrd

                                EDIT:
                                I'm running an 2900pro 1GB.
                                Last edited by MrMstrd; 09-29-2008, 03:45 PM. Reason: Video card clarification.

                                Comment

                                Working...
                                X