Announcement

Collapse
No announcement yet.

black border

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    Originally posted by Kano View Post
    There must be a boarder of 6 pixels (or 3 left and 3 right) because the gfx driver needs a res which can be divided by 8 -> 1366 native -> 1360 for driver. Impossible to fix that.
    1920 and 1080 are dividable by 8 though I have probably 100 pixels of blackborders

    this is really a huge and urgent issue here, since I can't use other resolution with the opensource driver
    I will need to plug back my 6600GT in the second 16x slot
    Last edited by mirak63; 06-23-2008, 06:04 AM.

    Comment


    • #32
      Well somebody before mentioned a phyiscal res of 1360x768.

      Comment


      • #33
        yep

        the problem is that hd4850 is almost unusable with fglrx on linux because of this, because 8.3 and 8.4 doesn't support this card
        I can't fallback on previous versions

        Comment


        • #34
          Unusable or just annoying?

          Comment


          • #35
            Originally posted by trentgbs View Post
            bridgman: Those aticonfig commands are for the fglrx binary drivers. They will not do anything with the radeonhd driver. You can do something similar with xrandr 1.2 when running radeonhd.
            Yeah, that's what puzzled me. Your post listed the aticonfig commands and said they had fixed the black border problem, but also said that you had switched to the radeonhd driver. The only other interpretation I could think of was that the commands fixed your problem with fglrx but you switched to radeonhd anyways.
            Last edited by bridgman; 06-23-2008, 10:49 AM.

            Comment


            • #36
              Originally posted by rbmorse View Post
              Unusable or just annoying?
              unsuable to the point where I think pluging back my 6600GT in the other pci express socket as a backup

              the problem is that my native resolution for the screen is 1920x1080 and that the computer still display 1920x1080 but they are not 1 per 1 pixel and downscaled to fit inside the black borders.
              I can't take a picture sorry.

              So for exemple the empty Xorg display that you get by just running X, doesn't display what it should, and you can imagine how look policies with this

              compiz works fine though lol

              Comment


              • #37
                Originally posted by mirak63 View Post
                e:/etc/X11# aticonfig --set-dispattrib=tmds2,positionX:0
                Try to Set positionX adjust of monitor tmds2 value : 0 failed.
                It may not supported by monitor or the value beyond the range.
                I noticed that others were using "tmds2i" rather than "tmds2", can you pls try that ?

                Comment


                • #38
                  Originally posted by bridgman View Post
                  I noticed that others were using "tmds2i" rather than "tmds2", can you pls try that ?
                  ha mon dieu merci beaucoup !!

                  now I have another issue, I have huge tearing at the bottom of the screen when playing videos
                  Last edited by mirak63; 06-23-2008, 03:22 PM.

                  Comment


                  • #39
                    Originally posted by toxic239 View Post
                    Hi

                    Finaly solved the issue with help of aticonfig command. It looks like Samsung TV claims to support 1080p but the visible area is touch smaller - very strange ...

                    Does anyone know if there is a linux software to analyse the EDID data ?

                    Best,
                    Toxic
                    o, my sony display w4000 I must enable "all pixels" option, otherwise it's zoomed

                    Comment


                    • #40
                      We asked some questions internally, it looks like a default setting for HDMI was changed in the common code. This has triggered a number of monitors to underscan.

                      Note that this does not happen on all HDTV monitors, some actually need this setting to have a normal near-pixel perfect screen.

                      To override this setting try setting this value and restarting X.

                      aticonfig --set-pcs-val=MCIL,DigitalHDTVDefaultUnderscan,0

                      To enable this functionality through the configuration tools it will not come for a number of releases, since this setting is quite deep under the covers and there are other issues that will need to be resolved to fix this fully.

                      Please advise if this resolves this issue.

                      Comment


                      • #41
                        black areas are gone (at least with driver version 8.5)

                        Originally posted by mtippett View Post
                        We asked some questions internally, it looks like a default setting for HDMI was changed in the common code. This has triggered a number of monitors to underscan.

                        Note that this does not happen on all HDTV monitors, some actually need this setting to have a normal near-pixel perfect screen.

                        To override this setting try setting this value and restarting X.

                        aticonfig --set-pcs-val=MCIL,DigitalHDTVDefaultUnderscan,0

                        To enable this functionality through the configuration tools it will not come for a number of releases, since this setting is quite deep under the covers and there are other issues that will need to be resolved to fix this fully.

                        Please advise if this resolves this issue.
                        For me this command seemed to do the trick and black areas are now gone. I am using 8.5 release.

                        BTW. How does tmds2i and tmds2 differ? Hopefully nothing about interlacing.

                        Comment


                        • #42
                          I had to ask Matthew the same question yesterday.

                          The "i" stands for internal, ie on-chip. Some of our older chips only offered a single tmds encoder, so by convention tmds1 was internal and tmds2 was external. When we added a second on-chip encoder it became "tmds2i", presumably since we could still support an external encoder as well.

                          Comment


                          • #43
                            Originally posted by Peruna View Post
                            For me this command seemed to do the trick and black areas are now gone. I am using 8.5 release.

                            BTW. How does tmds2i and tmds2 differ? Hopefully nothing about interlacing.
                            They are just names that are used to refer to connectors. The hardware can be configured in many funky ways, and so the "i" in this case means second internal tmds transmitter. The naming is really a layover from *many* years of incremental changes that blurs the meaning. We could call them "ralph","sarah" and "john" and it would carry about the same meaning.

                            Regards,

                            Matthew

                            Comment


                            • #44
                              thanks

                              Thank you for both of you. With that black border problem I somehow started to think that I have only 1080i and started to think that tmds2i has something to do with that.

                              Glad to know that there is no such a problem.

                              Comment


                              • #45
                                Originally posted by mtippett View Post
                                We asked some questions internally, it looks like a default setting for HDMI was changed in the common code. This has triggered a number of monitors to underscan.

                                Note that this does not happen on all HDTV monitors, some actually need this setting to have a normal near-pixel perfect screen.

                                To override this setting try setting this value and restarting X.

                                aticonfig --set-pcs-val=MCIL,DigitalHDTVDefaultUnderscan,0

                                To enable this functionality through the configuration tools it will not come for a number of releases, since this setting is quite deep under the covers and there are other issues that will need to be resolved to fix this fully.

                                Please advise if this resolves this issue.
                                This fixes my problem with this, however I have to set my resolution in xorg.conf. The driver sets the resolution to 1920*1080 and the monitors native resolution is 1680*1050.

                                Comment

                                Working...
                                X