Announcement

Collapse
No announcement yet.

Catalyst 8.5 not compiling on Hardy 64-bit

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Catalyst 8.5 not compiling on Hardy 64-bit

    I get this error when I tried to compile:
    dpkg-shlibdeps: warning: symbol XauFileName used by debian/xorg-driver-fglrx/usr/sbin/atieventsd found in none of the libraries.
    dpkg-shlibdeps: warning: debian/xorg-driver-fglrx/usr/sbin/atieventsd shouldn't be linked with libXrender.so.1 (it uses none of its symbols).
    dpkg-shlibdeps: failure: couldn't find library libfglrx_gamma.so.1 needed by debian/xorg-driver-fglrx/usr/bin/fglrx_xgamma (its RPATH is '').
    Note: libraries are not searched in other binary packages that do not have any shlibs or symbols file.
    To help dpkg-shlibdeps find private libraries, you might need to set LD_LIBRARY_PATH.
    dh_shlibdeps: command returned error code 512
    make: *** [binary] Error 1
    dpkg-buildpackage: failure: debian/rules binary gave error exit status 2
    How do I fix it?
    Why can't it find 'libfglrx_gamma.so.1'? Obviously this library is part of the Ati driver. Are the scripts broken?

  • #2
    I found 2 solutions:

    Solution A:
    Instead of
    Code:
    sudo sh ati-driver-installer-8-5-x86.x86_64.run --buildpkg Ubuntu/hardy
    Use
    Code:
    sudo sh ati-driver-installer-8-5-x86.x86_64.run --buildpkg Ubuntu/8.04
    Solution B:
    doing little googling and found a solution:

    Extract the archive and navigate to the new folder:
    Code:
    sudo sh ati-driver-installer-8-5-x86.x86_64.run --extract driver
    cd driver
    Navigate to where the libs are for 64 bit and make a symlink
    Code:
    cd arch/x86_64/usr/X11R6/lib64
    ln -s libfglrx_gamma.so.1.0 libfglrx_gamma.so.1
    Build the package(the command doesn't contain errors the script just behaves wrongly):
    Code:
    cd cd /home/<username>/driver
    sudo sh ati-installer.sh -- --buildpkg Ubuntu/hardy
    replace <username> with your username

    It built the packages and they installed. But after reboot the monitor goes black. I switch to a console, login and do a "dmesg|grep fglrx". 5-10 lines come up and they that the driver is loaded and working!!!

    Do you know how to solve this problem now?
    Last edited by SledgeHammer_999; 05-24-2008, 07:30 AM. Reason: Corrected an error in the last command

    Comment


    • #3
      I found for that too. But for me is a bit strange:

      Code:
      sudo modprobe -r radeon
      sudo modprobe fglrx
      I restarted X and it worked!!! And I only had to do it once(why?!?!?)
      But I have another problem:
      It displayer everything in 1920*1080. My monitor's manual says that it can go only up to 1024*768. Even the Catalyst for Windows recognize it up to 1024*768. Even older versions of Linux catalyst.

      What lines should I put to my xorg.conf file to limit the available resolutions to 1024*768?
      Last edited by SledgeHammer_999; 05-23-2008, 03:17 PM.

      Comment


      • #4
        So you were actually able to use the driver???

        I worked my way through this whole installation process and everything seemed to compile and install properly—no error messages—but when I restart X server, the display hangs after the restart, probably because of the very high resolution setting (my monitors limit is 1600X1280).

        So my question is were you actually able to use Ubuntu after you did modprobes or does your display hang too? Also did you ever learn how to reset the resolution to a different value?

        Comment


        • #5
          Add the desired resolution to xorg.conf. Fglrx sets my monitor to 1920x1200 despite it being only able to do 1680x1050. If I specify that max resolution in xorg.conf, then fglrx uses that as the default.

          Comment


          • #6
            yeah luckily I found a fix for that too(thank god I'm not the only one having problems with the resolution)

            in older versions of ubuntu all you had to do was
            Code:
            sudo dpkg-reconfigure -phigh xserver-xorg
            But those idiots have removed the resolution-related-stuff from 'dpkg-reconfigure' and put it into 'displayconfig-gtk'
            Code:
            sudo displayconfig-gtk
            And I say idiots because you cannot run a GUI app when you don't have a screen. The 'dpkg-reconfigure' worked nice in the console.

            How you solve that? Change the driver to 'vesa', boot into gnome(GUI), run displayconfig-gtk,select an appropriate monitor, change back the driver to 'fglrx', reboot.

            For me I had to run displayconfig-gtk multiple times in order to apply the new selections.

            If you don't know how to change the driver to 'vesa' then tell me to write more instructions.

            PS. vesa is not mandatory, use anything that gives you access to GUI.

            Comment


            • #7
              Max res line

              So I just add a line like the one below??

              Maximum resolution = 1600X1280

              ???

              Comment


              • #8
                Here are my fglrx sections in xorg.conf:
                Code:
                Section "Monitor"
                    Identifier   "aticonfig-Monitor[0]-0"
                    Option        "VendorName" "ATI Proprietary Driver"
                    Option        "ModelName" "Generic Autodetecting Monitor"
                    Option        "DPMS" "true"
                EndSection
                
                Section "Device"
                    Identifier  "aticonfig-Device[0]-0"
                    Driver      "fglrx"
                    BusID       "PCI:1:0:0"
                EndSection
                
                Section "Screen"
                    Identifier "aticonfig-Screen[0]-0"
                    Device     "aticonfig-Device[0]-0"
                    Monitor    "aticonfig-Monitor[0]-0"
                    DefaultDepth     24
                    SubSection "Display"
                        Viewport   0 0
                        Depth     24
                        Modes      "1680x1050"
                    EndSubSection
                EndSection
                You add the resolution under the Display subsection of the Screen section.

                Comment


                • #9
                  Thanks

                  Thanks to both of you—I'll give it a try back later in the day when I have some time!

                  Thanks again!

                  Comment


                  • #10
                    EDIT: I am refering to your earlier post
                    nope.

                    Obviously you need more instructions:

                    1.boot normally and when your display hangs press "Ctrl+Alt+F1"
                    2.Login
                    3.
                    Code:
                    sudo cp /etc/X11/xorg.conf /etc/X11.xorg_mybackup
                    4.
                    Code:
                    sudo nano /etc/X11/xorg.conf
                    5. scroll down (with the down arrow key) and replace [quote]Driver "fglrx"[/quote[ with
                    Driver "vesa"
                    6. Press Ctrl+O to save and Ctrl+X to exit.
                    7. reboot
                    8. now your screen shouldn't hang. login and run
                    Code:
                     sudo displayconfig-gtk
                    9. choose the required settings.
                    10.
                    Code:
                    nano /etc/X11/xorg.conf
                    and replace 'vesa' back to 'fglrx'
                    11.reboot and everything should work.


                    PS. If you made a mistake with the xorg.conf file you can restore the bakcup you make earlier with
                    Code:
                    sudo cp /etc/X11/xorg.conf_mybackup /etc/X11/xorg.conf

                    Comment


                    • #11
                      More thanks

                      Thanks again—as soon as I get finished writing what I'm working on right now I will give it a try.

                      Comment


                      • #12
                        Not much luck

                        Well I just spent about an hour and a half playing with this but don't have a whole lot to show for it. First, for some reason, the “Ctrl+Alt+F1" hotkey hardly ever works for me which makes experimenting with this very slow and time-consuming. The next major problem I've run into is that no combination of video card and monitor in displayconfig-gtk seems to work for me -- even after manually replacing the driver line with Driver "fglrx".

                        The process you describe seems perfectly logical to me. Do you have any idea which specific ATI card I should choose in displayconfig (I have a Radeon X1900—and a Samsung 213T monitor)? For the combination of two or three Radeon drivers that I managed to try in displayconfig and the Samsung 213T, I can't succeed in getting the GUI interface to start up—even after putting Driver "fglrx" into the file manually. Also, is there any explanation for why “Ctrl+Alt+F1" just doesn't seem to work for me?

                        Thanks again for the help!

                        Comment


                        • #13
                          Ctrl-alt-f1

                          PS -- I tried two different keyboards!

                          Comment


                          • #14
                            Just choose the correct monitor or a generic one. Don't try to choose a driver.
                            After you hit apply check xorg.conf file and replace all 'vesa' with 'fglrx' (there may be more than one)

                            To bypass Ctrl+Alt+F1 in the grub menu choose the 'safe mode' not the usual thing. I think this way you go straight to the console.

                            Comment


                            • #15
                              Well, I've not had much luck. I spent some time early this morning working on this again and, whether I use the appropriate Samsung driver or a generic monitor in display configuration, one of two things happens: either the display hangs on boot up or it reverts to very low resolution "plug-n-play." I have to do some real work now but it's rather exasperating to be apparently "so near and yet so far." I am attaching the monitor and driver information from one of my many attempts to make this work. Perhaps you will see something there that that I don't.

                              I suspect that what might be going on is that the main monitor stays cloned to the S-Video TV output or something like that. At least system/preferences/screen resolution always shows "cloned" as checked no matter how many times I uncheck and "apply" it.

                              The clip below is from the non-functioning Samsung 213T xorg.conf.

                              Section "Monitor"
                              Identifier "aticonfig-Monitor[0]"
                              Vendorname "Samsung"
                              Modelname "Samsung SyncMaster 213T/CX210T"
                              Horizsync 30-81
                              Vertrefresh 56-75
                              modeline "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
                              modeline "640x480@72" 31.5 640 664 704 832 480 489 491 520 -vsync -hsync
                              modeline "640x480@75" 31.5 640 656 720 840 480 481 484 500 -vsync -hsync
                              modeline "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
                              modeline "800x600@72" 50.0 800 856 976 1040 600 637 643 666 +hsync +vsync
                              modeline "800x600@75" 49.5 800 816 896 1056 600 601 604 625 +hsync +vsync
                              modeline "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
                              modeline "832x624@75" 57.284 832 864 928 1152 624 625 628 667 -vsync -hsync
                              modeline "1024x768@75" 78.8 1024 1040 1136 1312 768 769 772 800 +hsync +vsync
                              modeline "1024x768@70" 75.0 1024 1048 1184 1328 768 771 777 806 -vsync -hsync
                              modeline "1024x768@60" 65.0 1024 1048 1184 1344 768 771 777 806 -vsync -hsync
                              modeline "1152x864@75" 108.0 1152 1216 1344 1600 864 865 868 900 +hsync +vsync
                              modeline "1280x1024@75" 135.0 1280 1296 1440 1688 1024 1025 1028 1066 +hsync +vsync
                              modeline "1280x960@60" 102.1 1280 1360 1496 1712 960 961 964 994 -hsync +vsync
                              modeline "1280x1024@60" 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
                              modeline "1280x960@75" 129.86 1280 1368 1504 1728 960 961 964 1002 -hsync +vsync
                              modeline "1400x1050@60" 122.61 1400 1488 1640 1880 1050 1051 1054 1087 -hsync +vsync
                              modeline "1600x1200@65" 175.5 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
                              modeline "1600x1200@60" 162.0 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
                              Gamma 1.0
                              EndSection

                              Section "Device"
                              Identifier "aticonfig-Device[0]"
                              Boardname "ati"
                              Busid "PCI:1:0:0"
                              Driver "fglrx"
                              Screen 0
                              EndSection

                              Section "Screen"
                              Identifier "aticonfig-Screen[0]"
                              Device "aticonfig-Device[0]"
                              Monitor "aticonfig-Monitor[0]"
                              Defaultdepth 24
                              SubSection "Display"
                              Depth 24
                              Virtual 1600 1200
                              Modes "1600x1200@65" "1600x1200@60" "1400x1050@60" "1280x960@75" "1280x1024@60" "1280x960@60" "1280x1024@75" "1152x864@75" "1024x768@60" "1024x768@70" "1024x768@75" "832x624@75" "800x600@60" "800x600@75" "800x600@72" "800x600@56" "640x480@75" "640x480@72" "640x480@60"
                              EndSubSection
                              EndSection

                              Section "device" #
                              Identifier "device1"
                              Boardname "ati"
                              Busid "PCI:1:0:0"
                              Driver "fglrx"
                              Screen 1
                              EndSection
                              Section "screen" #
                              Identifier "screen1"
                              Device "device1"
                              Defaultdepth 24
                              Monitor "monitor1"
                              EndSection
                              Section "monitor" #
                              Identifier "monitor1"
                              Gamma 1.0
                              EndSection
                              Section "ServerFlags"
                              EndSection

                              Comment

                              Working...
                              X