Announcement

Collapse
No announcement yet.

fglrx 8.32.5 and Xorg 7.2??

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • fglrx 8.32.5 and Xorg 7.2??

    Hello,
    I just switched from Slackware 11 to Frugalware current, which has Xorg 7.2 RC3.
    I installed the lastest fglrx driver and modules, everything seemed ok. But 3d acceleration doesn't work at all!!
    Here's the interested part in Xorg.0.log:
    Code:
    (EE) fglrx: Failed to load module "drm" (module does not exist, 0)
    and:
    Code:
    (EE) fglrx: Failed to load module "drm" (module does not exist, 0)
    (WW) fglrx(0): Failed to load drm module.
    (EE) fglrx(0): Failed to initialize GPS!
    (WW) fglrx(0): ***********************************************
    (WW) fglrx(0): * DRI initialization failed!                  *
    (WW) fglrx(0): * (maybe driver kernel module missing or bad) *
    (WW) fglrx(0): * 2D acceleraton available (MMIO)             *
    (WW) fglrx(0): * no 3D acceleration available                *
    (WW) fglrx(0): ********************************************* *
    Here's dmesg | grep fglrx:
    Code:
    fglrx: module license 'Proprietary. (C) 2002 - ATI Technologies, Starnberg, GERMANY' taints kernel.
    [fglrx] Maximum main memory to use for locked dma buffers: 1898 MBytes.
    [fglrx] module loaded - fglrx 8.32.5 [Dec 12 2006] on minor 0
    Of course I asked on Frugalware forums before posting here, but they told me probably Xorg 7.2 is not supported yet.. Is this the case? Thx

  • #2
    X.Org 7.2 is supported by the 8.32.5 drivers. However, between RC2 and RC3 was a change that really shouldn't have taken place (with drm not being loaded by default) and resulted in some problems for the fglrx drivers.

    A SuSE developer had written a patch so the fglrx drivers can be used with X.Org 7.2 RC3 / final, but unfortunately I no longer have the patch in my inbox. A patch initially appeared on an internal ATI beta mailing list, but it may be on the SuSE forums or some other site now. The fglrx drivers should work with OpenSuSE 10.2.
    Michael Larabel
    http://www.michaellarabel.com/

    Comment


    • #3
      Originally posted by slacker View Post

      Of course I asked on Frugalware forums before posting here, but they told me probably Xorg 7.2 is not supported yet.. Is this the case? Thx
      fglrx 8.32.5 have support for xorg 7.2 i am running it fine on Radeon 9800, opensuse 10.2 (xorg 7.2) although as in my question (other thread) there seems to be some problems with my sons x1900 card and opengl.

      Comment


      • #4
        Oh crap! So I have to wait for a new Xorg release, hoping they will fix that?? A new ATI driver is not going to fix it, right? Thx for the help

        Comment


        • #5
          Well, you could recompile it with the patch. Hopefully X.Org 7.2 final will adopt the patch.
          Michael Larabel
          http://www.michaellarabel.com/

          Comment


          • #6
            OK! I found it:
            https://bugs.freedesktop.org/show_bug.cgi?id=9367

            Any tips on how to recompile Xorg?
            Last edited by slacker; 12-26-2006, 10:16 AM.

            Comment


            • #7
              Thanks to a developer of Frugalware I installed a new Xorg package with the patch. It seems to work but I still can't get the 3d acceleration .

              Here's Xorg.0.log: http://forums.frugalware.org/index.p...2d4a61bb8c9ec5

              As you can see it says:

              (II) fglrx(0): [DRI] installation complete
              (II) fglrx(0): Direct rendering enabled
              (==) fglrx(0): Using hardware cursor

              Here's my xorg.conf:
              Code:
              Section "ServerLayout"
              	Identifier     "X.org Configured"
              	Screen      0  "aticonfig-Screen[0]" 0 0
              	InputDevice    "Mouse0" "CorePointer"
              	InputDevice    "Mouse1"
              	InputDevice    "Keyboard0" "CoreKeyboard"
              EndSection
              
              Section "Files"
              	RgbPath      "/usr/share/X11/rgb"
              	ModulePath   "/usr/lib/xorg/modules"
                  FontPath 	"/usr/lib/X11/fonts/misc"
                  FontPath 	"/usr/lib/X11/fonts/TTF"
                  FontPath 	"/usr/lib/X11/fonts/OTF"
                  FontPath 	"/usr/lib/X11/fonts/Type1"
                  FontPath 	"/usr/lib/X11/fonts/100dpi"
                  FontPath 	"/usr/lib/X11/fonts/75dpi"
                  FontPath 	"/usr/local/share/fonts"
              EndSection
              
              Section "Module"
              	Load  "glx"
              	Load  "extmod"
              	Load  "xtrap"
              	Load  "record"
              	Load  "GLcore"
              	Load  "dbe"
              	Load  "dri"
              	Load  "freetype"
              	Load  "type1"
              	Load  "freetype"
              EndSection
              
              Section "InputDevice"
              	Identifier  "Keyboard0"
              	Driver      "kbd"
              	Option	    "XkbLayout" "it"
              EndSection
              
              Section "InputDevice"
              	Identifier  "Mouse0"
              	Driver      "mouse"
              	Option	    "ZAxisMapping" "4 5"
              	Option	    "Buttons" "3"
              	Option	    "AlwaysCore" "true"
              	Option	    "Protocol" "imps/2"
              	Option	    "Device" "/dev/psaux"
              EndSection
              
              Section "InputDevice"
              	Identifier  "Mouse1"
              	Driver      "mouse"
              	Option	    "ZAxisMapping" "4 5"
              	Option	    "Buttons" "3"
              	Option	    "AlwaysCore" "true"
              	Option	    "Protocol" "auto"
              	Option	    "Device" "/dev/tts/0"
              EndSection
              
              Section "InputDevice"
              	Identifier  "Mouse3"
              	Driver      "mouse"
              	Option	    "ZAxisMapping" "4 5"
              	Option	    "Buttons" "3"
              	Option	    "AlwaysCore" "true"
              	Option	    "Protocol" "auto"
              	Option	    "Device" "/dev/input/mice"
              EndSection
              
              Section "Monitor"
              	Identifier   "Monitor0"
              	VendorName   "Monitor Vendor"
              	ModelName    "Monitor Model"
              	HorizSync    31.5 - 64.3
              	VertRefresh  60.0 - 75.0
              	Option	    "DPMS"
              EndSection
              
              Section "Monitor"
              	Identifier   "aticonfig-Monitor[0]"
              	Option	    "VendorName" "ATI Proprietary Driver"
              	Option	    "ModelName" "Generic Autodetecting Monitor"
              	Option	    "DPMS" "true"
              EndSection
              
              Section "Device"
              
                      ### Available Driver options are:-
                      ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
                      ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
                      ### [arg]: arg optional
                      #Option     "ShadowFB"           	# [<bool>]
                      #Option     "DefaultRefresh"     	# [<bool>]
                      #Option     "ModeSetClearScreen" 	# [<bool>]
              	Identifier  "Card0"
              	Driver      "vesa"
              	VendorName  "ATI Technologies Inc"
              	BoardName   "Radeon Mobility X1400"
              	BusID       "PCI:1:0:0"
              EndSection
              
              Section "Device"
              	Identifier  "aticonfig-Device[0]"
              	Driver      "fglrx"
              EndSection
              
              Section "Screen"
              	Identifier "Screen0"
              	Device     "Card0"
              	Monitor    "Monitor0"
              	DefaultDepth     24
              	SubSection "Display"
              		Viewport   0 0
              		Depth     1
              	EndSubSection
              	SubSection "Display"
              		Viewport   0 0
              		Depth     4
              	EndSubSection
              	SubSection "Display"
              		Viewport   0 0
              		Depth     8
              	EndSubSection
              	SubSection "Display"
              		Viewport   0 0
              		Depth     15
              	EndSubSection
              	SubSection "Display"
              		Viewport   0 0
              		Depth     16
              		Modes    "1280x800" "800x600" "640x480"
              	EndSubSection
              	SubSection "Display"
              		Viewport   0 0
              		Depth     24
              		Modes    "1280x800" "800x600" "640x480"
              	EndSubSection
              EndSection
              
              Section "Screen"
              	Identifier "aticonfig-Screen[0]"
              	Device     "aticonfig-Device[0]"
              	Monitor    "aticonfig-Monitor[0]"
              	DefaultDepth     24
              	SubSection "Display"
              		Viewport   0 0
              		Depth     24
              	EndSubSection
              EndSection
              
              Section "DRI"
              	Group        0
              	Mode         0666
              EndSection
              Any clues? Thx

              Comment

              Working...
              X