Announcement

Collapse
No announcement yet.

Can't create //usr/X11R6/lib/modules/dri/fglrx_dri.so: File exists

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Can't create //usr/X11R6/lib/modules/dri/fglrx_dri.so: File exists

    Detected configuration:
    Architecture: x86_64 (64-bit)
    X Server: X.Org 7.1 and later releases 64-bit
    loki_setup: directory: (null)
    loki_setup: Can't create //usr/X11R6/lib/modules/dri/fglrx_dri.so: File exists
    loki_setup: Can't create //usr/X11R6/lib64/modules/dri/fglrx_dri.so: File exists

    Wonderful, it can't create a file even as super user.

    I have removed both files several times but I always seem to get those two errors.

    It is trying to load the old fglrx_dri.so but when it does, all I see is black and flashes when my system tries to load X. I had to switch back to vesa for the time being.
    Last edited by Laughing1; 04-29-2008, 09:49 PM.

  • #2
    I found out what the issue was:

    First I ran:

    # lsmod | grep fglrx

    to see if there was the old version of fglrx running (it printed output), so I used the command:

    # rmmod fglrx

    in order to remove the old fglrx module then I ran the AMD script, rebooted, and it finally worked properly.

    Comment


    • #3
      I have the same problem, but i don't have any module loaded.

      lsmod | grep fglrx

      is clean.

      I have check the destination and there are not any fglrx_dri.so files in any place.

      The result is that i'm getting a black screen and the system freezes.

      Any hints?
      Last edited by baskin; 06-16-2009, 11:55 AM.

      Comment


      • #4
        Try this if you installed it from the .sh fglrx package as root:
        Code:
        # sh /usr/share/fglrx/fgrlx-uninstall.sh
        Or remove the RPM if you installed it via RPM.

        Comment


        • #5
          I have tried that, the unistalation completes successfully, there are not any files, but i'm continuing to get the error message.

          Comment


          • #6
            I get this too but when you look at the log file at /usr/share/ati you see other errors. I get this with kernels newer than 2.6.28, so I'm using 2.6.27.15 and have no problems. But you have to compile kernel with msi settings under bus options. I can't remember but think I enable the pci slot option too.

            Comment


            • #7
              Originally posted by forum1793 View Post
              I get this too but when you look at the log file at /usr/share/ati you see other errors. I get this with kernels newer than 2.6.28, so I'm using 2.6.27.15 and have no problems. But you have to compile kernel with msi settings under bus options. I can't remember but think I enable the pci slot option too.
              I'm using kernel 2.6.27.23 and on another similar system with the same kernel, I have no problem.

              Comment


              • #8
                I have searched this issue a little further.

                After the failed installation i have in /usr/share/ati/fglrx-install.log:

                [Message] Kernel Module : Trying to install a precompiled kernel module.
                [Message] Kernel Module : Precompiled kernel module version mismatched.
                [Message] Kernel Module : Found kernel module build environment, generating kernel module now.
                AMD kernel module generator version 2.1
                doing Makefile based build for kernel 2.6.x and higher
                rm -rf *.c *.h *.o *.ko *.GCC* .??* *.symvers
                make -C /lib/modules/2.6.27.23-0.1-default/build SUBDIRS=/lib/modules/fglrx/build_mod/2.6.x modules
                make[1]: Entering directory `/usr/src/linux-2.6.27.23-0.1-obj/x86_64/default'
                make -C ../../../linux-2.6.27.23-0.1 O=/usr/src/linux-2.6.27.23-0.1-obj/x86_64/default/. modules
                CC [M] /lib/modules/fglrx/build_mod/2.6.x/firegl_public.o
                CC [M] /lib/modules/fglrx/build_mod/2.6.x/kcl_acpi.o
                CC [M] /lib/modules/fglrx/build_mod/2.6.x/kcl_agp.o
                CC [M] /lib/modules/fglrx/build_mod/2.6.x/kcl_debug.o
                CC [M] /lib/modules/fglrx/build_mod/2.6.x/kcl_ioctl.o
                CC [M] /lib/modules/fglrx/build_mod/2.6.x/kcl_io.o
                CC [M] /lib/modules/fglrx/build_mod/2.6.x/kcl_pci.o
                CC [M] /lib/modules/fglrx/build_mod/2.6.x/kcl_str.o
                CC [M] /lib/modules/fglrx/build_mod/2.6.x/kcl_wait.o
                LD [M] /lib/modules/fglrx/build_mod/2.6.x/fglrx.o
                Building modules, stage 2.
                MODPOST 1 modules
                CC /lib/modules/fglrx/build_mod/2.6.x/fglrx.mod.o
                LD [M] /lib/modules/fglrx/build_mod/2.6.x/fglrx.ko
                make[1]: Leaving directory `/usr/src/linux-2.6.27.23-0.1-obj/x86_64/default'
                build succeeded with return value 0
                duplicating results into driver repository...
                done.
                You must change your working directory to /lib/modules/fglrx
                and then call ./make_install.sh in order to install the built module.
                - recreating module dependency list
                - trying a sample load of the kernel modules
                failed.
                [Error] Kernel Module : Failed to install compiled kernel module - please consult readme.
                If i change to /lib/modules/fglrx and execute ./make_install.sh i get:

                FATAL:Error inserting fglrx(/lib/modules/2.6.27.23-0.1.default/kernel/drivers/char/drm/fglrx.ko): Operation not permitted
                All executed as root.

                Comment


                • #9
                  Are you sure that the oss modules (drm radeon) are not loaded? Also check dmesg for errors.

                  Comment


                  • #10
                    I always try after clean boot on init 3.

                    Just to be sure i checked with lsmod and no drm or radeon modules are loaded.

                    dmesg | grep fglrx shows this:

                    fglrx: module license 'Proprietary. (C) 2002 - ATI Technologies, Starnberg, GERMANY' taints kernel.
                    [fglrx] Maximum main memory to use for locked dma buffers: 3795 MBytes.
                    [fglrx] vendor: 1002 device: 9490 count: 1
                    [fglrx] ioport: bar 4, base 0xe000, size: 0x100
                    [fglrx] Kernel PAT support is enabled
                    [fglrx:firegl_init_module] *ERROR* firegl_stub_register failed
                    [fglrx] Maximum main memory to use for locked dma buffers: 3795 MBytes.
                    [fglrx] vendor: 1002 device: 9490 count: 1
                    [fglrx] ioport: bar 4, base 0xe000, size: 0x100
                    [fglrx] Kernel PAT support is enabled
                    [fglrx:firegl_init_module] *ERROR* firegl_stub_register failed
                    [fglrx] Maximum main memory to use for locked dma buffers: 3795 MBytes.
                    [fglrx] vendor: 1002 device: 9490 count: 1
                    [fglrx] ioport: bar 4, base 0xe000, size: 0x100
                    [fglrx] Kernel PAT support is enabled
                    [fglrx:firegl_init_module] *ERROR* firegl_stub_register failed
                    [fglrx] Maximum main memory to use for locked dma buffers: 3795 MBytes.
                    [fglrx] vendor: 1002 device: 9490 count: 1
                    [fglrx] ioport: bar 4, base 0xe000, size: 0x100
                    [fglrx] Kernel PAT support is enabled
                    [fglrx:firegl_init_module] *ERROR* firegl_stub_register failed
                    [fglrx] Maximum main memory to use for locked dma buffers: 3795 MBytes.
                    [fglrx] vendor: 1002 device: 9490 count: 1
                    [fglrx] ioport: bar 4, base 0xe000, size: 0x100
                    [fglrx] Kernel PAT support is enabled
                    [fglrx:firegl_init_module] *ERROR* firegl_stub_register failed
                    [fglrx] Maximum main memory to use for locked dma buffers: 3795 MBytes.
                    [fglrx] vendor: 1002 device: 9490 count: 1
                    [fglrx] ioport: bar 4, base 0xe000, size: 0x100
                    [fglrx] Kernel PAT support is enabled
                    [fglrx:firegl_init_module] *ERROR* firegl_stub_register failed
                    [fglrx] Maximum main memory to use for locked dma buffers: 3795 MBytes.
                    [fglrx] vendor: 1002 device: 9490 count: 1
                    [fglrx] ioport: bar 4, base 0xe000, size: 0x100
                    [fglrx] Kernel PAT support is enabled
                    [fglrx:firegl_init_module] *ERROR* firegl_stub_register failed
                    [fglrx] Maximum main memory to use for locked dma buffers: 3795 MBytes.
                    [fglrx] vendor: 1002 device: 9490 count: 1
                    [fglrx] ioport: bar 4, base 0xe000, size: 0x100
                    [fglrx] Kernel PAT support is enabled
                    [fglrx:firegl_init_module] *ERROR* firegl_stub_register failed
                    [fglrx] Maximum main memory to use for locked dma buffers: 3795 MBytes.
                    [fglrx] vendor: 1002 device: 9490 count: 1
                    [fglrx] ioport: bar 4, base 0xe000, size: 0x100
                    [fglrx] Kernel PAT support is enabled
                    [fglrx] module loaded - fglrx 8.62.4 [May 20 2009] with 1 minors
                    [fglrx] module unloaded - fglrx 8.62.4 [May 20 2009]

                    Comment


                    • #11
                      Originally posted by baskin View Post
                      If i change to /lib/modules/fglrx and execute ./make_install.sh i get:

                      FATAL:Error inserting fglrx(/lib/modules/2.6.27.23-0.1.default/kernel/drivers/char/drm/fglrx.ko): Operation not permitted
                      All executed as root.
                      A few things to consider. First either with the newer kernels or all 64 bits (I'm not sure) the files are put at /lib/modules/.../drivers/gpu, so this might explain install error.

                      Second, the autoinstaller needs 32 bit libraries to install, even on a 64 bit system. I haven't got fglrx working yet on a 64 bit system.

                      Did you compile your own kernel and enable the msi options?

                      Maybe PAT with your hardware might be issue.

                      What is your hardware and linux distribution

                      Comment


                      • #12
                        I have made a successful installation on an identical system (regarding the software)

                        I'm running opensuse 11.1 64bit with the default kernel and my VGA is an HD4670.

                        The successful install was made on a HD3200.

                        Comment


                        • #13
                          Originally posted by forum1793 View Post
                          A few things to consider. First either with the newer kernels or all 64 bits (I'm not sure) the files are put at /lib/modules/.../drivers/gpu, so this might explain install error.

                          Second, the autoinstaller needs 32 bit libraries to install, even on a 64 bit system. I haven't got fglrx working yet on a 64 bit system.
                          Update; I did just compile a 2.6.27.25 kernel for slackware64-current.
                          The catalyst autoinstaller 9-6 worked fine, no patching required. This means 32 bit libs are not needed or slackware64-current now has them.

                          For the 2.6.27.25 kernel the autoinstaller puts fgrlx in /lib.../drivers/char/drm and not /lib.../drivers/gpu, although it probably doesn't matter.

                          My system is hd3200 (780g)

                          edit: removed comment about sound over hdmi not working. I forgot to unmute it. alsamixer -c1. Too many versions running.

                          You may wish to compare your kernel config files between the two machines.

                          But, if all other things are equal to your two systems, I would think the problem must be due to the graphics card and the driver parts unique to it.
                          Last edited by forum1793; 06-20-2009, 04:32 PM.

                          Comment


                          • #14
                            I have made a successful install by generating distribution specific rpm from the installer.

                            The produced rpm package is installed correctly without errors (at least as far i can see) but when i try to execute:

                            Code:
                            sax2 -r -m 0=fglrx
                            i'm getting a black screen and the system freezes (needs hard reset).

                            Comment


                            • #15
                              Did you run sax2 before or after aticonfig --initial ?

                              My guess is that you don't need sax2 if you run aticonfig --initial (and you *should* run aticonfig --initial)

                              Comment

                              Working...
                              X