Announcement

Collapse
No announcement yet.

8.4+aiglx/compiz video flickering

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • 8.4+aiglx/compiz video flickering

    Hi...

    I've been using compiz since yesterday with the release of 8.4 but I can't seem to find the solution to play videos decently. I can either get a black window or severe flickering depending on the combination of configurations I try.

    I'm able to play fullscreen correctly but I would like to be able to play windowed.

    Does anyone have a solution for this? (Besides disabling aiglx?).

    Thanks!

    Mobility X700 128MB (R300)

  • #2
    When you say "disabling aiglx" do you mean "disabling compiz" ?

    Comment


    • #3
      Hmm, how can I leave AIGLX enabled without Compiz?

      If I disable the effects on Ubuntu configuration without setting AIGLX "false" on xorg.conf, does it mean AIGLX is enabled (without Compiz)?

      I can try this later...

      Comment


      • #4
        Use X11 to render videos.

        Comment


        • #5
          Code:
          Section "Device"
                  Identifier  "ATI Technologies Inc Radeon Mobility X700 (PCIE)"
                  Driver      "fglrx"
                  Option      "VideoOverlay" "on"
                  Option      "OpenGLOverlay" "off"
                  Option      "TexturedVideo" "off"
                  Option      "XAANoOffscreenPixmaps" "true"
                  Option      "AllowGLXWithComposite" "true"
          #       Option      "DisableGLXRootCLipping" "true"
          #       Option      "TexturedVideoSync" "on"
                  Option      "EnableMonitor" "tmds1"
          #       Option      "EnableMonitor" "tmds1,lvds"
                  Option      "DesktopSetup" "single"
                  BusID       "PCI:1:0:0"
          EndSection
          With these options I get unaccelerated video (XV doesn't work).
          Edit: Opengl crashes my aiglx (refreshes no longer happen automatically). Had to comment out AllowGLXWithComposite.

          If I enable VideoOverlay, I get flickering, with both video and OpenGL. Also, if I move a window with video or OpenGL content, the content stays on the same place until I set the final window location, with severe flickering.
          Last edited by Nicolas; 04-17-2008, 11:50 AM.

          Comment


          • #6
            using X11 for video is fine, but not an option if you want to run apps like google earth under compiz. Is there any other way to get rid of the flickering while still running compiz?

            Comment


            • #7
              It's a limitation of the DRI framework. There is a thread on this somewhere around here. Basically you can't have accelerated desktops and accelerated playback on at the same time. Just use X11 to render videos and the flickering will go away, but 3D games (and applications like Google Earth) will still suffer from flickering. If you really want to use Xv/opengl you're going to have to turn Compiz off. DRI2 fixes this issue and I hear it should be coming out soon.

              Comment


              • #8
                I can't get video without flickering when aiglx/compiz is enabled. No combination of configurations works for me.

                DRI2 should be out soon. OK... But when will fglrx support DRI2?

                Comment


                • #9
                  Originally posted by Nicolas View Post
                  Hi...

                  I've been using compiz since yesterday with the release of 8.4 but I can't seem to find the solution to play videos decently. I can either get a black window or severe flickering depending on the combination of configurations I try.

                  I'm able to play fullscreen correctly but I would like to be able to play windowed.

                  Does anyone have a solution for this? (Besides disabling aiglx?).

                  Thanks!

                  Mobility X700 128MB (R300)
                  Which video player are you using, and do you have XVideo enabled?

                  Comment


                  • #10
                    Originally posted by Dandel View Post
                    Which video player are you using, and do you have XVideo enabled?
                    How do I check if my XVideo is enabled?

                    I've tried Totem and MPlayer.

                    Comment

                    Working...
                    X