Announcement

Collapse
No announcement yet.

8.4+aiglx/compiz video flickering

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    The easiest way is to run the program:

    gstreamer-properties

    then under the video tab you should be able to figure out very easily if your using Xvideo or not.

    Comment


    • #12
      Originally posted by Nicolas View Post
      DRI2 should be out soon. OK... But when will fglrx support DRI2?
      Good question, any idea when fglrx will support DRI2?

      Comment


      • #13
        DRI2 *just* came out, so it may be a while before fglrx supports it. The open-source driver may even support it first!

        Comment


        • #14
          How come neither Intel or nVidia drivers needed DRI2 to provide flicker-free video playback, plus flicker-free 3D rendering? What is preventing AMD's fglrx drivers to have the same functionality?

          Comment


          • #15
            Originally posted by Thetargos View Post
            How come neither Intel or nVidia drivers needed DRI2 to provide flicker-free video playback, plus flicker-free 3D rendering? What is preventing AMD's fglrx drivers to have the same functionality?
            Nvidia binaries use a "tweaked" glx extention. Don't ask me how exactly it works, but it has something to do with bypassing X or something. Not sure about Intel drivers, but I do know that they are the most actively supported, so it should no surprise that they offer the best experience out of all the available drivers.

            Comment


            • #16
              Is it something to do with Nvidia implementing it's own brand of AIGLX? I read about this somewhere online

              Comment


              • #17
                Originally posted by Nicolas View Post
                Hi...
                I'm able to play fullscreen correctly but I would like to be able to play windowed.

                Does anyone have a solution for this? (Besides disabling aiglx?).

                Thanks!

                Mobility X700 128MB (R300)
                You can recompile mplayer with some funky patches that apply the relevant zen.

                http://smspillaz.wordpress.com/2007/...ur-video-card/

                Under Ubuntu hardy, I had some problems with the stock release of mplayer, so I patched it with the ubuntu patches and the compiz patches and it all works really nicely - I can even have transparent windows. If you have Hardy, try this deb (it bumps the epoch number so it doesn't get overwritten by the ubuntu mplayer version).

                Comment


                • #18
                  Originally posted by Thetargos View Post
                  How come neither Intel or nVidia drivers needed DRI2 to provide flicker-free video playback, plus flicker-free 3D rendering? What is preventing AMD's fglrx drivers to have the same functionality?
                  nvidia doesn't use Xorg's direct rendering infrastructure. Under compiz the intel driver does suffer from the same flickering video (unless you use textured video, which is still problematic) and flickering 3D applications (unless you use DRI2).

                  Adam

                  Comment


                  • #19
                    Code:
                    Section "Device"
                            Identifier  "ATI Technologies Inc Radeon Mobility X700 (PCIE)"
                            Driver      "fglrx"
                            Option      "VideoOverlay" "on"
                            Option      "OpenGLOverlay" "off"
                            Option      "TexturedVideo" "off"
                            Option      "XAANoOffscreenPixmaps" "true"
                            Option      "AllowGLXWithComposite" "true"
                    #       Option      "DisableGLXRootCLipping" "true"
                    #       Option      "TexturedVideoSync" "on"
                            Option      "EnableMonitor" "tmds1"
                    #       Option      "EnableMonitor" "tmds1,lvds"
                            Option      "DesktopSetup" "single"
                            BusID       "PCI:1:0:0"
                    EndSection
                    You have too many options cluttering your conf... try this.

                    Code:
                    Section "Device"
                            Identifier  "ATI Technologies Inc Radeon Mobility X700 (PCIE)"
                            Driver      "fglrx"
                            Option      "TexturedVideo" "on"
                            Option      "XAANoOffscreenPixmaps" "true"
                            Option      "DesktopSetup" "single"
                            BusID       "PCI:1:0:0"
                    EndSection
                    There's nothing you can do about the flickering besides disabling video acceleration and using software rendering with the x11 output - mplayer and vlc both allow you to configure your output to x11.

                    Hopefully this is fixed in the next version of fglrx.

                    Comment


                    • #20
                      Originally posted by Melcar View Post
                      Use X11 to render videos.

                      better yet, use compiz video.

                      you'll need a compiz-patched mplayer to render the video - that is, it patches the code to run the 'xv' video driver to point to compiz instead. when that'll all fine & done, run mplayer using 'xv' as the video, and compiz will do the rendering.

                      result: redirected video, thats higher on the CPU than actual xv but much lower so than x11, and smoother + prettier might I add. that what i use.

                      the real fix for this will come when all direct rendered data - that is, xv video & all fashions of opengl apps that draw straight to the framebuffer - gets to be redirected using DRI2, which is still somewhat experimental and for which fglrx support is expected to be somewhere in the long, long term future. unfortunatly.

                      go ati
                      Last edited by pedepy; 04-25-2008, 08:59 PM.

                      Comment

                      Working...
                      X