Announcement

Collapse
No announcement yet.

catalyst 8.3 won't compile on 2.6.25-rc4

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • catalyst 8.3 won't compile on 2.6.25-rc4

    The 8.3 driver won't compile for me. Specs: HP 6515b laptop with an ati 1250 integrated video card running slackware 12 and a custom 2.6.25-rc4 kernel.
    I downloaded the driver. Did a chmod a+x ati....sh, ran the file ./ati....
    answered the prompts and the end result is:
    [Message] Kernel Module : Trying to install a precompiled kernel module.
    [Message] Kernel Module : Precompiled kernel module version mismatched.
    [Message] Kernel Module : Found kernel module build environment, generating kernel module now.
    ATI module generator V 2.0
    ==========================
    initializing...
    cleaning...
    patching 'highmem.h'...
    assuming new VMA API since we do have kernel 2.6.x...
    Assuming default VMAP API
    Assuming default munmap API
    doing Makefile based build for kernel 2.6.x and higher
    make -C /lib/modules/2.6.25-rc4/build SUBDIRS=/lib/modules/fglrx/build_mod/2.6.x modules
    make[1]: Entering directory `/usr/src/linux-2.6.25-rc4'
    CC [M] /lib/modules/fglrx/build_mod/2.6.x/firegl_public.o
    /lib/modules/fglrx/build_mod/2.6.x/firegl_public.c : In function 'KCL_SetPageNoCache':
    /lib/modules/fglrx/build_mod/2.6.x/firegl_public.c :1161: warning: 'change_page_attr' is deprecated (declared at include/asm/cacheflush.h:28)
    /lib/modules/fglrx/build_mod/2.6.x/firegl_public.c : In function 'KCL_PosixSecurityCapGetEffectiveVector':
    /lib/modules/fglrx/build_mod/2.6.x/firegl_public.c :1888: error: implicit declaration of function 'cap_t'
    /lib/modules/fglrx/build_mod/2.6.x/firegl_public.c : In function 'KCL_PosixSecurityCapSetEffectiveVector':
    /lib/modules/fglrx/build_mod/2.6.x/firegl_public.c :1896: error: invalid lvalue in assignment
    /lib/modules/fglrx/build_mod/2.6.x/firegl_public.c : In function '__ke_check_pci':
    /lib/modules/fglrx/build_mod/2.6.x/firegl_public.c :1951: warning: 'pci_find_slot' is deprecated (declared at include/linux/pci.h:507)
    /lib/modules/fglrx/build_mod/2.6.x/firegl_public.c : In function '__ke_pci_find_slot':
    /lib/modules/fglrx/build_mod/2.6.x/firegl_public.c :2840: warning: 'pci_find_slot' is deprecated (declared at include/linux/pci.h:507)
    make[2]: *** [/lib/modules/fglrx/build_mod/2.6.x/firegl_public.o] Error 1
    make[1]: *** [_module_/lib/modules/fglrx/build_mod/2.6.x] Error 2
    make[1]: Leaving directory `/usr/src/linux-2.6.25-rc4'
    make: *** [kmod_build] Error 2
    build failed with return value 2
    [Error] Kernel Module : Failed to compile kernel module - please consult readme.

    I did a quite google and tried setting the CONFIG_PCI_LEGACY to n (original setting was y) and I get the same error.

    Thanks,
Working...
X