Announcement

Collapse
No announcement yet.

AMD Catalyst 8.3 Linux Driver

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #46
    Wow !

    This is incredible. XVideo / Radeon AVIVO video is actually now working on my ATI X1400 mobile (I need OpenGLOverlay "on" + TexturedVideoSync "on" in xorg.conf). No blocky scaling and completely VSYNC-ed. Thank you AMD, that was ABOUT TIME ! The two latest Catalyst releases have been good for me. So hope is definitely coming back. I've only tested this new driver for a few minutes, will report back when I have more experience with it.

    ATI X1400 Radeon mobile, Lenovo Thinkpad Z61m, Intel Core duo 2GHz, 2GB RAM, Ubuntu Gutsy 32bit.

    Comment


    • #47
      tvtime

      Are the problems with tvtime solved ?

      Since 8.42, I have been unable to use this great tv player.

      Comment


      • #48
        Originally posted by samase View Post
        "This release still lacks AGP support for R600 owners."

        GREAT NEWS!!! well maybe next year... or year after that... then i can be very proud of my brand new card which is finally supported...


        and once again this is not mentioned in release notes.
        How couldn't I quote you? Same situation, bought this card on November and i could easily use it as an expensive paperweight.
        Ah, for once, situation on Windows front isn't better: i'm stuck with Catalyst 7.7 for acceptable performance.
        Worst product ever, probably.

        Great work AMD/ATI, you really KNOW how to keep your market share...

        Comment


        • #49
          Originally posted by samase View Post
          "This release still lacks AGP support for R600 owners."
          Also not working on RV530 AGP (nforce-2 mobo).

          With 8-2 I could run 3d apps just didn't get output - now they crash aswell (oom - not instantly), Xv also fails to draw to screen.

          My card has 512 ram, when using nvidia-agp, GART has to be 256 or I crash on startx. 4x/8x in bios and many configs tried.

          Without nvidia-agp fglrx starts OK but fails to init AGP so no 3d to try.

          Last working (bar Xv) fglrx for me is 8.40.4 with kernnel reverted to 2.6.21.7.

          Comment


          • #50
            Still blinking video

            With x1600 on 32-bit gutsy, my Xv and OpenGl video, and even general 3d apps, are blinking badly under compiz with current driver.
            Can anyone who got this working please send his Device section of xorg.conf? This will be a great help to me.
            Here is my current Device section:

            Section "Device"
            Identifier "Generic Video Card"
            Boardname "ati"
            Busid "PCI:1:0:0"
            Driver "fglrx"
            Screen 0
            Option "VideoOverlay" "on"
            Option "OpenGLOverlay" "off"
            Option "TexturedVideo" "on"

            EndSection

            (I tried switching on OpenGLOverlay, which gave me the option to use OpenGL mode in mplayer but didn't change tearing)

            Comment


            • #51
              I think the blinking is addressed by Compiz settings, not driver settings. The problem AFAIK is app and compiz both writing to the same area of the screen.

              Comment


              • #52
                Wow. XVideo finally works! That's great news!

                Compiz still has some issues: glxgears, videos, and everything 3D is flickering horribly with Compiz enabled.

                Comment


                • #53
                  Originally posted by bridgman View Post
                  I think the blinking is addressed by Compiz settings, not driver settings. The problem AFAIK is app and compiz both writing to the same area of the screen.
                  In CompizConfig Settings Manager, enabling General Options->General->Unredirect Fullscreen Windows solves the flickering in fullscreen Xv. However, any use of compiz during the playback (moving volume/position sliders etc.) starts another 5-seconds session of blinking until the screen is "full" again.

                  I had no trouble with this using Xgl on top of the "old" fglrx. Isn't the new driver supposed to enable us playing Xv in a window under compiz? I repeat my request for the xorg.conf of a person who managed to get that working.
                  Last edited by Wise Ferret; 03-06-2008, 09:57 AM.

                  Comment


                  • #54
                    Great release for me, 3D finally works

                    Comment


                    • #55
                      Originally posted by Wise Ferret View Post
                      In CompizConfig Settings Manager, enabling General Options->General->Unredirect Fullscreen Windows solves the flickering in fullscreen Xv. However, any use of compiz during the playback (moving volume/position sliders etc.) starts another 5-seconds session of blinking until the screen is "full" again.

                      I had no trouble with this using Xgl on top of the "old" fglrx. Isn't the new driver supposed to enable us playing Xv in a window under compiz? I repeat my request for the xorg.conf of a person who managed to get that working.

                      I think it's because XGL is not really part of the xserver like AIGLX is, and the blinking is due to an xserver issue with window management.

                      Comment


                      • #56
                        I'm happy to see this release cleared up the issues with xv rendering.

                        The xv problems bothered me enough to have me go and get an nvidia card. Slowly but surely things will get ironed out and in my next round of upgrades I'll pick myself up an AMD graphics card.

                        Keep up the good work AMD!

                        Comment


                        • #57
                          @bridgeman

                          How long will it take to see pointsprites again? Did you ever try gl2benchmark?

                          Comment


                          • #58
                            What is Xvideo ?

                            I have intall the new driver:
                            - freeze on some Gnome Screen Saver on the screen-saver control panel
                            - flicker on 3D software like video-games, fgl_glxgears and others when compiz effet is activated

                            - The calibration with GammaPage and others work perfectly
                            - no flicker when a screen-saver start
                            - Work perfectly on firefox

                            Comment


                            • #59
                              screen locked

                              new driver tested. i have a serious problem about screen locked: when i try to logout and login into gnome or restart gdm with ctrl+alt+canc or switch to shell mode (ctrl+alt+f1,f2,etc...) driver locks screen and i must reset my notebook

                              p.s. notebook with 9700 mobility

                              Comment


                              • #60
                                http://wiki.cchtml.com/index.php/Ubu...allation_Guide

                                Note: The newest 8.471.0 does not enable DRI using gutsy. It needs a more recent X.org for this, but 2D does work. "(II) fglrx(0): driver needs X.org 7.1.x.y with x.y >= 0.0"
                                Is this true?

                                Comment

                                Working...
                                X