Announcement

Collapse
No announcement yet.

AMD Catalyst 8.3 Linux Driver

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Yes you re right guys! My mislook! Downloading now...

    I cannot wait to see Textured Video finally working on my RS690!!

    Comment


    • #17
      Suspend/hibernate still not working with Compiz enabled...

      Peter

      Comment


      • #18
        Originally posted by SledgeHammer_999 View Post
        look the posts above


        I HAVE A PROBLEM: I am running gutsy amd64. When I try to install "xorg-driver-fglrx_8.471-0ubuntu1_amd64.deb" it gives an error. It says that this package tries to delete /usr/lib32/libGL.so.1 from ia32-libs (or something like that).

        PLZ FIX IT. I really want to try this release. I wanna see the Xv fixes.
        Do
        Code:
        ls -l /usr/lib32/libGL.so*
        and check that you get something like
        Code:
        /usr/lib32/libGL.so -> libGL.so.1
        /usr/lib32/libGL.so.1 -> /usr/lib/libGL.so.1.2
        /usr/lib32/libGL.so.1.2
        I had to redo the link from libGL.so.1 to libGL.so.1.2 with
        Code:
        $ cd /usr/lib32
        $ sudo ln -s /usr/lib32/libGL.so.1.2 libGL.so.1

        Comment


        • #19
          This time ati managed to fix at least 1 bug of the things I always test with a new driver:

          + gl2benchmark does not segfault with sid/amd64 anymore

          but all other errors are still the same

          - last pointsprite was seen with driver 8.40.4, that was now 6 driver releases ago (to verify just use gl2benchmark test 3/4)

          - black screen with modelines (it was only a joke in the release notes that these would work some time ago, a bad one however)

          - kills vesa framebuffer with some kernels and my x700se (release notes are incorrect)

          I can not test any issues with X1300+ cards as I do not own em and nobody wanted to send me a test card. But this releases really states how much better are NV cards...

          Comment


          • #20
            Uchi's 8.03 driver rundown
            Quick summary: It works for pretty much everything. Including hibernate and suspend.

            Broken down into

            - Machine configuration
            - Installation
            - Fglrxinfo/glxinfo/xvinfo
            - glxgears/powerplay
            - Compiz
            - Compiz & Video (Xv)
            - Video (Xv)
            - Suspend/Hibernate
            - Remarks

            Machine details

            Machine: Dell Inspiron 6400
            Card: ATI Mobility x1400 256MB Hypermemory (PCI-Ex)
            RAM: 1 GB
            Distro: OpenSUSE
            State: Clean-install, no previous ATI driver
            Xorg: 7.3

            Install

            So, we start off this test by attempting to install via the installer. The installer is now text-based! This makes it possible to run it in console. Starting off:

            Code:
            sudo chmod a+x ati-driver-installer-8.3-x86.x86_64.run
            sudo ./ati-driver-installer-8.3-x86.x86_64.run
            The first command to make it runnable, the second to run it. The installer successfully detected the distro, Xorg version range, and that I was in a 32bit x86 environment. Mm. Nothing out of the ordinary so far. It then presents the choice of generating a distro-specific package or doing the 'easy way'. I chose the easy way. Watch it do its thing and success! (Ensure that you have the kernel source and all the tools needed else you'll get an error message and a log saying that it failed to generate the kernel module).

            Next up, ran the following commands (since I just recently installed OpenSuse...today actually, great timing huh?):

            Code:
            sudo aticonfig --initial
            sudo aticonfig --overlay-type=Xv
            Restarted X and my resolution is now nice and proper. Let's verify that life is good.

            Fglrxinfo/glxinfo/xvinfo

            Code:
            tachikoma@n198-239:~> fglrxinfo
            display: :0.0  screen: 0
            OpenGL vendor string: ATI Technolgies Inc.
            OpenGL renderer string: ATI Mobility Radeon X1400
            OpenGL version string: 2.1.7412 Release
            Code:
            tachikoma@n198-239:~> glxinfo
            name of display: :0.0
            display: :0  screen: 0
            direct rendering: yes
            server glx vendor string: SGI
            server glx version string: 1.2
            [server extensions listed below]
            client glx vendor string: SGI
            client glx version string: 1.4
            [client glx extensions listed below]
            Xvinfo reports two image formats YV12 (0x32315659), type: YUV (planar) and I420 (0x30323449), type: YUV (planar). Powerstates gives me the usual three states:

            Powerstates, glxgears average (non-compiz)

            Code:
            tachikoma@n198-239:~> aticonfig --list-powerstates
                 core/mem       [flags]
            -----------------
              1: 209/135 MHz      [low voltage]
              2: 392/252 MHz     
            * 3: 432/396 MHz      [default state]
            Glxgears gives me an average of about 2600ish FPS.

            Next up. Compiz.

            Installed compiz and added the necessary flags to xorg.conf and then gave it a whirl. Ran it manually in console using "compiz-manager&". Emerald window manager, and it works just fine.

            Scrolling is decent, glxgears gives me an average of about 2423-2600 FPS. So, not bad at all. Dragged the glxgears window around and it was fine. All the effects work decently well (rotate workspace, fading windows, wobbly drag, alt+tab). Resizing a window tends to be slow and jerky. Mm...further tries and I get a blank window issue. Not usable, but I still need to test video in compiz...so moving on...

            Video in compiz!

            In Xv mode no less. Lets see what hapepns. The video is a music video (Nana Mizuki - Astrogation, Xvid(MPEG-4 ASP), MP3 (audio)) and played in the default video player in OpenSUSE.

            Default size: Works
            Resize: Works
            Fullscreen: Works
            CPU Utilization (resized fullscreen, 1280x800): 5-25% CPU utilization for each CPU (CPU 1 and 2)

            Video not in compiz!

            Same video.

            Default size: Works
            Resize: Works
            Fullscreen: Works
            CPU Utilization (non fullscreen): 20-25%, 5-10% alternating between CPU's

            [as reported by system monitor]
            [idle is about 5%]

            Hibernation and suspend!

            Settings are OpenSUSE 10.3 defaults.

            Suspend was tested by pressing Fn+Esc (Stand by). Suspend finished correctly. Woke up correctly. I'm a happy panda. Hell yes. I'm going to do it again just for the hell of it. Suspend finished correctly. Woke up correctly. RAWR. I'm going to do it again with compiz on. uspend finished correctly. Woke up correctly. RAWRx2. I gave my console window a little wobble to check too.

            Hibernate was tested by pressing Fn+F1 (Hibernate). It got tested with compiz on since compiz was already loaded (see above). OpenSUSE has the nice splash while it prepares the hibernate. It's quite nice really. Anyways, hibernate is successful, and computer is turned off. But...does it turn back on? Interestingly, if you hibernate in OpenSUSE it skips Grub when you turn it back on. In any case, was able to resume successfully with Compiz on.

            I'm not going to try without compiz on right now, but if someone wants me to try it, let me know.

            Closing remarks:

            So compiz works, but doesn't work. Mm. Maybe it's just how I set it up. I did set it up rather hastily. Or perhaps its the driver. In any case, barring compiz, it all works mighty fine and I really don't have any real complaints. Compiz? I don't usually use it...but people here like to use it so...tried it out.
            Last edited by Uchikoma; 03-05-2008, 07:04 PM.

            Comment


            • #21
              [QUOTE=SledgeHammer_999;26505]
              I HAVE A PROBLEM: I am running gutsy amd64. When I try to install "xorg-driver-fglrx_8.471-0ubuntu1_amd64.deb" it gives an error. It says that this package tries to delete /usr/lib32/libGL.so.1 from ia32-libs (or something like that)./QUOTE]

              Code:
              $ sudo dpkg -i --force-overwrite xorg-driver-fglrx_8.471-0ubuntu1_amd64.deb

              Comment


              • #22
                GOD!!!! A usable driver release!!!! thanks bridgman for listening our rants and take notes of our problems... XV works as a charm now... Thanks AMD guys, at last the fglrx mess is almost over! OpenGL output in VLC is still messed up... don't know what might be, but Mplayer OpenGL rendering works fine...
                Last edited by linzerd; 03-05-2008, 07:13 PM.

                Comment


                • #23
                  It installs! It runs! But...

                  So glxgears runs and gives me > 3100 fps, with no trace of corruption on a 1680x1050 screen. Yay.

                  Playing videos using xine and XVideo no longer crashes the Xserver when xine exits, but does crash the Xserver when the video file reaches its end. The backtrace suggests an illegal memcpy in glesx.so, as called by XVidPutImage(). At the bottom of the stack trace is the function FontFileCompleteXLFD(), and there's not much information between the two.

                  World of Warcraft/Wine 0.9.56 (OpenGL mode) still locks up the Xserver (but not the laptop) when run full-screen at 1680x1050. However, it seems to run OK in a 1400x900 window, and that is what I am doing at the moment. At 1680x1050, WoW's login screen renders correctly and the music plays in the background, but none of the animations work and the mouse and keyboard do not respond.

                  So on balance, I think I'll be sticking with 8.3 for a bit longer. However, being stuck at 1400x900 is annoying. Also, WoW's rendering does some weird things unless I provide WoW with the following options:

                  SET pixelShaders "0"
                  SET M2UseShaders "0"
                  SET M2USePixelShaders "1"

                  This is on a Thinkpad T60p, with a FireGL V5250 chip, and running Fedora 8. The laptop uses an Intel Core 2 Duo running at 2.33 GHz, and has 2 GB RAM.
                  Last edited by chrisr; 03-05-2008, 07:50 PM.

                  Comment


                  • #24
                    After reading the posts in this thread I cannot wait until this new driver would be available in Arch's [extra] repository. Don't want to create my own PKGBUILD by modifying the one from previous drivers, cause I have much more believe in Arch's devs skills, than in mine

                    Comment


                    • #25
                      Originally posted by phoronix View Post
                      Phoronix: AMD Catalyst 8.03 Linux Driver

                      there are a few bug fixes that may satisfy some Linux users.

                      http://www.phoronix.com/vr.php?view=11954
                      As far as I'm concerned that's the understatement of the year. I don't want to speak too soon (I've been messing with it for about 30 minutes) but as far as I can tell, this one is a godsend!

                      XV video looks good, no diagonal nonsense, no blocky crapola, no horizontal flicker.... glxgears gets a satisfying speed... I can do 3D and whatever else. Timing was great too as I was messing around with the OSS driver all day yesterday trying to get it to do 3D on my M54 (x1400) which it does not want to do... and for what it's worth, I had flicker when playing video on the OSS driver, which I don't have with the new release.

                      Thanks Bridgman, for listening to my bitches and anti-ATI rants. Long live ATI!

                      ...I will probably never upgrade my driver again!

                      Comment


                      • #26
                        Bingo!

                        Textured Video is working for my RS690 chip!!!
                        No diagonial tearing anymore!!
                        3D corruption is gone now! Games are playble again!

                        To all ATi staff out there Matthew, John, Alex and rest of the team:
                        Thanks a lot guys from X1250 owners for this springtime gift!
                        Finally we can use our Home Theater PC's under our Linux revolutionary 64-bit Operating Systems!!

                        Comment


                        • #27
                          Originally posted by Netsnipe View Post
                          Originally posted by SledgeHammer_999 View Post
                          I HAVE A PROBLEM: I am running gutsy amd64. When I try to install "xorg-driver-fglrx_8.471-0ubuntu1_amd64.deb" it gives an error. It says that this package tries to delete /usr/lib32/libGL.so.1 from ia32-libs (or something like that).
                          Code:
                          $ sudo dpkg -i --force-overwrite xorg-driver-fglrx_8.471-0ubuntu1_amd64.deb
                          I was able to install BUT:

                          WORKS:
                          1.glxgears
                          2.fgl_glxgears
                          3.compiz

                          VIDEO PLAYBACK IS F__KED UP:
                          the first time after reboot I tried to play the video file but the machine started "restart sequence". After that "restart" whenever I try to play something the app just dies/vanishes. This happens to Totem(gstreamer) and mplayer(xv). Opengl playback in mplayer works(haven't tried on totem). Come on how the hell did you fix Xv when I can't play anything??

                          EDIT: does anyone have any success with gutsy?(amd64)

                          Comment


                          • #28
                            Under openSuSE 10.3 64-bit, kernel 2.6.24.1, Xorg 7.3 xserver 1.4.90 and ATi X1250 card this driver seems like a gift for the new year!!

                            Also Xv can be double buffered and GLESX module now has flags=30(well don't know what this actually means but generally 2D is much better with Compiz-Fusion and without it!)

                            Well it's time to hit EXA, XvMC, and Crossfire along with AIGLX improvements!!

                            Comment


                            • #29
                              A little update to my previous post:

                              Using gst-launch to play a video file I get this in the terminal
                              X Error of failed request: BadValue (integer parameter out of range for operation)
                              Major opcode of failed request: 141 (XVideo)
                              Minor opcode of failed request: 19 ()
                              Value in failed request: 0x3800002
                              Serial number of failed request: 68
                              Current serial number in output stream: 69

                              Comment


                              • #30
                                Bulding Fedora 8 package still doesn't work

                                RPM build errors:
                                File not found by glob: /tmp/ATI-fglrx-8.471-1-9256-root/tmp/ATI-fglrx-8.471-1.f8-root-root/usr/X11R6/lib/modules/dri/*

                                Comment

                                Working...
                                X